none
criar mailbox coexistindo 2007 e 2003 RRS feed

  • Pergunta

  • Bom dia,

    Estou com um Lab para estudar o exchange 2007 antes de por em produção. Tenho um servidor com AD que instalei tb o Exchange 2003, para praticar a migração e outro servidor com o Exchange 2007.

    Antes de instalar o exchange 2007 criei alguns usuário com mailbox para mover para o exchange 2007. Instalei o exchange 2007, fiz o move mailbox tranquilo. O problema é quando crio um usuário com mailbox que da erro, independente em qual servidor eu crie, e quando verifico está no 2007 (que foi a opção que escolhi na criação), mas o icone está igual aos da mailbox q estão no 2003.

    Quando acesso pelo OWA do 2007 da a seguinte messagem de erro:


    Request
    Url: https://10.10.10.253:443/owa/lang.owa
    User host address: 10.10.10.12

    Exception
    Exception type: Microsoft.Exchange.Data.Storage.StoragePermanentException
    Exception message: There was a problem accessing Active Directory.

    Call stack

    Microsoft.Exchange.Data.Storage.ExchangePrincipal.Save()
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchLanguagePostLocally(OwaContext owaContext, OwaIdentity logonIdentity, CultureInfo culture, String timeZoneKeyName, Boolean isOptimized)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchLanguagePostRequest(OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)
    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)
    System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Inner Exception
    Exception type: Microsoft.Exchange.Data.Directory.InvalidADObjectOperationException
    Exception message: Property Languages cannot be set on this object because it requires the object to have version 0.1 (8.0.535.0) or later. Current version of the object is 0.0 (6.5.6500.0).

    Call stack

    Microsoft.Exchange.Data.Directory.PropertyBag.set_Item(PropertyDefinition key, Object value)
    Microsoft.Exchange.Data.Directory.ADObject.set_Item(PropertyDefinition propertyDefinition, Object value)
    Microsoft.Exchange.Data.Directory.ADObject.StampCachedCaculatedProperties(Boolean retireCachedValue)
    Microsoft.Exchange.Data.Directory.ADObject.ValidateWrite(List`1 errors)
    Microsoft.Exchange.Data.Directory.Recipient.ADRecipient.ValidateWrite(List`1 errors)
    Microsoft.Exchange.Data.Directory.Recipient.ADUser.ValidateWrite(List`1 errors)
    Microsoft.Exchange.Data.Directory.ADSession.Save(ADObject instanceToSave, IEnumerable`1 properties)
    Microsoft.Exchange.Data.Storage.ExchangePrincipal.Save()

    O que pode ser???

    • Editado Luiz Sérgio sexta-feira, 22 de maio de 2009 14:44 erro digitação
    sexta-feira, 22 de maio de 2009 14:43

Respostas

  • Ola Luiz,

    Em suma, qual o erro que acontece ao criar o usuário novo?
    E ainda, no OWA, pode atentar para isso: Exception message: There was a problem accessing Active Directory.
    E também ver se está tentando abrir o user Exchange 2003 no OWA 2007.

    Abs.
    Rodrigo Rodrigues .:. www.andersonpatricio.org .:. blog.rodrigorodrigues.org
    • Marcado como Resposta Luiz Sérgio quarta-feira, 3 de junho de 2009 17:12
    sexta-feira, 22 de maio de 2009 15:41

Todas as Respostas

  • Ola Luiz,

    Em suma, qual o erro que acontece ao criar o usuário novo?
    E ainda, no OWA, pode atentar para isso: Exception message: There was a problem accessing Active Directory.
    E também ver se está tentando abrir o user Exchange 2003 no OWA 2007.

    Abs.
    Rodrigo Rodrigues .:. www.andersonpatricio.org .:. blog.rodrigorodrigues.org
    • Marcado como Resposta Luiz Sérgio quarta-feira, 3 de junho de 2009 17:12
    sexta-feira, 22 de maio de 2009 15:41
  • Olá Rodrigo,

    Quando crio o usuário não dá erro algum. Seleciono a mailbox para o Exchange 2007 não consigo acessar, dando o erro que citei acima. Mas quando seleciono o exchange 2003, durante a criação, consigo acessar o OWA 2003 sem problemas.

    Detalhe: mesmo criando o usuário, pelo AD, no exchange 2007 no console de adm do 2007 o icone fica parecido como estiesse no 2003, mas o nome do server é o do exchange 2007.

    Mesmo criando o usuário/mailbox pela console do exchange 2007 dá o mesmo erro.

    Como faço para visualizar se o usuário do 2003 está tentando abrir com o OWA do 2007??? Se for nas propriedades do usuário, no AD, em Exchange General o server está o 2007.

    Obrigado.
    sexta-feira, 22 de maio de 2009 16:37
  • Ola Luiz,

    Junto com a dica do Rodrigo tu tem que atualizar a E-mail Address Policy e isto tem documentado durante o documento de transiçao da MS.
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    sábado, 23 de maio de 2009 12:31
  • Obrigado Anderson,

    Vou olhar essa documentação e dou um retorno aqui no post.
    segunda-feira, 25 de maio de 2009 12:13
  • Anderson,

    Não encontrei a documentação, mas fui pelo caminho que o Rodrigo citou.

    Rodrigo,

    valeu é isso mesmo. Achei um outro post com essa mesma situação em que você citou q não seria possivel. Não lembro qual foi o post, mas é isso mesmo q disse.

    obrigado de novo!
    quarta-feira, 3 de junho de 2009 17:12