none
Memória virtual baixa, após ingressar no domínio RRS feed

  • Discussão Geral

  • Boa Tarde!

    Primeiramente vou descrever nosso cenário para entender o problema

    Utilizamos um controlador de domínio Windows Server 2008 R2 Standard 64bits SP1, com 4GB, processador Intel Xeon E5506, 2,13Ghz

    As estações de trabalho são Windows 7 Professional SP1, 32 bits, 3GB, Processador Core I3 M380, 2,53 Ghz

    Após migrarmos 3 notebooks para o domínio, as estações de trabalho começaram a apresentar um problema com memória virtual baixa. Isso nunca aconteceu quando elas estavam fora do domínio.

    O problema geralmente ocorre após 6 a 8 horas de utilização.

    Verifiquei os logs de eventos do Windows  no notebook e encontrei o log Id 2004, Resource- Exhaustion- Detector, que faz referência a este problema. Este log informou isto:

    O Windows diagnosticou com êxito uma condição de memória virtual insuficiente. Os programas a seguir consumiram a maior parte da memória virtual: Skype.exe (5168) consumiu 137379840 bytes, svchost.exe (2176) consumiu 70836224 bytes e SearchIndexer.exe (4000) consumiu 69115904 bytes.”

    Como forma de corrigir este problema, configurei nas opções de desempenho para obter o melhor desempenho. Configurei a memória virtual manualmente como Mínima 4401mb e máxima 8610mb. Instalei o Service Pack 1.

    Mesmo após este procedimento, o problema persiste. Ontem após este problema, tive que reiniciar o Windows. Não abrir nenhum programa como skype, Outlook e navegador, bloqueie a estação e só voltei hoje pela manhã. Para a minha surpresa o problema voltou a ocorrer, mesmo sem trabalhar no equipamento. Desta vez o log de erro informou isso:

    “O Windows diagnosticou com êxito uma condição de memória virtual insuficiente. Os programas a seguir consumiram a maior parte da memória virtual: svchost.exe (3420) consumiu 71299072 bytes, svchost.exe (932) consumiu 37675008 bytes e SearchIndexer.exe (5088) consumiu 37048320 bytes.”

    Como posso resolver esse problema? Acredito que não preciso instalar o windows 7 professional 64 bits, ou aumentar para 4 Gb

    Isso esta nos impactando, pois não posso mais migrar outras estações no domínio.

    No aguardo

     

    Obrigado

    Fábio

    quinta-feira, 28 de julho de 2011 15:12

Todas as Respostas

  • Olá Fábio,

    Vamos por partes:

    Como está seu software anti-virus nessas máquinas? Já fez uma varredura completa?

    Pausando o serviço do Windows Search o problema ocorre?

    As últimas atualizações foram aplicadas nessas máquinas?

    Baixe e utilize a ferramenta Process Explorer para verificar quais são os aplicativos que estão de fato consumindo a memória através do svchost (3420) e do svchost (932)

    http://technet.microsoft.com/en-us/sysinternals/bb896653

     


    Elmo Baraúna, SSA-Ba - FSCTP / MCP / MCDST / MCTS / MCSA / MCT http://infraestruturaealgomais.blogspot.com
    quinta-feira, 28 de julho de 2011 17:17
    Moderador
  • Olá Fgoia,

     

    No site de suporte da microsoft você pode encontrar algumas ferramentas para correção de problemas comuns, chamado de "Microsoft Fix it". Abaixo alguns links de ferramentas "Micrososft Fix it" que podem ser úteis para você rodar nessas estações:

     

    http://support.microsoft.com/mats/slow_windows_performance/pt-br

    http://support.microsoft.com/mats/windows_security_diagnostic/pt-br

    http://support.microsoft.com/mats/Malware_Prevention/pt-br

    http://support.microsoft.com/mats/system_maintenance_for_windows/pt-br

     

    Outras ferramentas do "Microsoft Fix it" você encontra em http://support.microsoft.com/fixit/pt-br#tab0

     

    Caso minha resposta tenha sido útil, favor qualificar.

     

    Abraço!


    Atenciosamente, Maurício Pitangueira MCP - Windows Server 2003 mauriciopitangueira@hotmail.com
    quinta-feira, 28 de julho de 2011 18:25
  • Pelo que vc descreve o programa SearchIndexer.exe esta associado nos dois erros, va no painel de controle e verifique a "opcoes de indexaçao" analize as configuraçoes de indexaçao.

    Vc tbm pode pausar a indexaçao para fazer um teste.

    sexta-feira, 29 de julho de 2011 01:14
  • Obrigado Elmo,Mauricio e Daniel pelo retorno.

    Farei essas verificações, assim que terminar, retornarei com os resultados.

     

    Obrigado

    abs

     

     

    sexta-feira, 29 de julho de 2011 01:28
  • Olá Fgoia.

    Alguma novidade sobre o problema?

     

    Abraço.

     


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    segunda-feira, 1 de agosto de 2011 17:27
  • Olá Richard

     

    Mesmo desativando serviço  SearchIndexer.exe, o problema voltou hoje.

    O log apresentou a seguinte informação: 

    O Windows diagnosticou com êxito uma condição de memória virtual insuficiente. Os programas a seguir consumiram a maior parte da memória virtual: Skype.exe (2296) consumiu 144031744 bytes, iexplore.exe (5184) consumiu 87244800 bytes e svchost.exe (3104) consumiu 69697536 bytes.

    Usei o Process Explore, que apontou para estes mesmos aplicativos como os que consomem mais memória.

    Estou aplicando as correções que o Maurício indicou.



    segunda-feira, 1 de agosto de 2011 20:12
  • Fábio,

    faça a revisão com a guia seguinte http://www.todoespacoonline.com/post.php?id=111

     

    Revise se seu Windows possui atualizações pendentes para baixar e instalar, se possível faça o mesmo, pois poderá haver correções para este problema.

    segunda-feira, 1 de agosto de 2011 21:02
    Moderador
  • Olá Fgoia.

    Alguma novidade sobre o problema?

     

    Abraço.


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    terça-feira, 2 de agosto de 2011 17:05
  • Richard, ainda não, agora a pouco o problema voltou. O que reparei é que nem sempre o processo svchost.exe esta relacionando com o alto consumo de memória. 

    Vou tentar aplicar todas as atualizações da microsoft, embora não podemos desconsiderar, mas acho que não vai resolver.

     

    Abs

     

    Fábio

     

    terça-feira, 2 de agosto de 2011 20:47
  • Olá Fgoia.

    Sem problemas, assim que você atualizar, nos informe se continua o problema.

     

    Abraço.


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    quarta-feira, 3 de agosto de 2011 19:19
  • Olá Richard,

     

    Mesmo com as atualizações, o problema voltou.

    Já passei o antivírus, ajustei a memória virtual, apliquei atualizações da microsoft, já desativei o serviço SearchIndexer.exe, apliquei as correções que o Maurício sugeriu, mas não obtive sucesso.

    Estranho é que os programas que consomem mais memória nem sempre são os mesmos, as vezes é o skype, outllook, firefox, MsMpEng.exe.

    O que notei é que cerca de 6 à 8 horas de utilização que o problema começa a surgir

    O que mais poderia fazer?

     

    abs

     

    Fábio




    segunda-feira, 8 de agosto de 2011 19:11
  • Olá Fgoia,

     

    Existe alguma dessas estações com esse problema que esteja utilizando SO de 64bits ou todas as máquinas em sua rede utilizam SO de 32bits apenas?


    Atenciosamente, Maurício Pitangueira MCP - Windows Server 2003 mauriciopitangueira@hotmail.com
    segunda-feira, 8 de agosto de 2011 19:58
  • Olá Maurício,

     

    Sâo 6 estações que estão no domínio, uma delas é 64 bits, e não teve problemas, ela possui 4 GB. As demais são 32bits e 3 GB, sendo que 3 apresentaram o problema.

     

    terça-feira, 9 de agosto de 2011 13:28
  • Existe mais alguma coisa que esqueci de fazer?

     

    quarta-feira, 10 de agosto de 2011 19:40
  • Alguma resposta?
    quarta-feira, 17 de agosto de 2011 19:44
  • Olá Fgoia,

     

    Tenho mais algumas perguntas sobre seu ambiente:

     

    1. Você tem apenas um DC?
    2. Qual o nível funcional do seu DC?
    3. A instalação e configuração do seu DC foi limpa ou você atualizou do Win 2003 pro 2008?
    4. Existe alguma entrada erro ou warning no Event Viewer na parte de Sistema, Serviço de Diretório, Servidor DNS?

    Aguardo seu retorno!


    Atenciosamente, Maurício Pitangueira MCP - Windows Server 2003 mauriciopitangueira@hotmail.com
    quinta-feira, 25 de agosto de 2011 15:51
  • Olá Mauricio

    Segue as respostas

    1- Sim, temos apenas um DC

    2- Este servidor além de ser um DC, ele é o servidor DHCP, DNS, servidor de impressão e file server, embora tenha poucos usuários no domínio

    3 - A instalação foi limpa, o servidor veio sem o SO

    4 - Encontrei alguns warnings na parte de Sistemas, mas acredito que não tenham interferência com o problema, vejas os logs:

     

    Nome do Log:   System

    Fonte:         Microsoft-Windows-Kerberos-Key-Distribution-Center

    Data:          22/08/2011 15:53:54

    Identificação do Evento:29

    Categoria da Tarefa:Nenhum

    Nível:         Aviso

    Palavras-chave:Clássico

    Usuário:       N/D

    Computador:   

    Descrição:

    O KDC (Centro de Distribuição de Chaves) não encontra um certificado adequado para usar em logons de cartões inteligentes, ou então o certificado KDC não pôde ser verificado. O logon de cartões inteligentes pode não funcionar corretamente se esse problema não for resolvido. Para corrigir o problema, verifique o certificado KDC existente usando o certutil.exe ou inscreva-se em um novo certificado KDC.

    XML de Evento:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Microsoft-Windows-Kerberos-Key-Distribution-Center" Guid="{3FD9DA1A-5A54-46C5-9A26-9BD7C0685056}" EventSourceName="KDC" />

        <EventID Qualifiers="32768">29</EventID>

        <Version>0</Version>

        <Level>3</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2011-08-22T18:53:54.000000000Z" />

        <EventRecordID>25153</EventRecordID>

        <Correlation />

        <Execution ProcessID="0" ThreadID="0" />

        <Channel>System</Channel>

        <Computer></Computer>

        <Security />

      </System>

      <EventData>

      </EventData>

    </Event>

     

    Nome do Log:   System

    Fonte:         Microsoft-Windows-TerminalServices-Printers

    Data:          22/08/2011 15:40:13

    Identificação do Evento:1111

    Categoria da Tarefa:Nenhum

    Nível:         Erro

    Palavras-chave:Clássico

    Usuário:       N/D

    Computador:   

    Descrição:

    O driver SolidPDFConverter necessário para a impressora Solid Converter PDF é desconhecido. Entre em contato com o administrador para instalar o driver antes de você fazer logon novamente.

    XML de Evento:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Microsoft-Windows-TerminalServices-Printers" Guid="{952773BF-C2B7-49BC-88F4-920744B82C43}" EventSourceName="UmrdpService" />

        <EventID Qualifiers="0">1111</EventID>

        <Version>0</Version>

        <Level>2</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2011-08-22T18:40:13.000000000Z" />

        <EventRecordID>25152</EventRecordID>

        <Correlation />

        <Execution ProcessID="0" ThreadID="0" />

        <Channel>System</Channel>

        <Computer></Computer>

        <Security />

      </System>

      <EventData>

        <Data>SolidPDFConverter</Data>

        <Data>Solid Converter PDF</Data>

        <Binary>00000000A70E0000</Binary>

      </EventData>

    </Event>

     

    Obrigado

    No aguardo

     

    Fábio

     

     

    segunda-feira, 5 de setembro de 2011 18:17
  • Olá Fábio,

     

    Realmente é muito estranho o que está acontecendo. Sua solução anti-vírus está 100%?  Pode ser que por infecção de vírus dentro no seu domínio, após inserir a máquina no domínio é que as elas são infectadas.

     

    Faça varreduras a procura de vírus com soluções free diferentes da que você usa em seu ambiente de rede. O Tren Micro HouseCall é uma boa opção free para essa tarefa.

     

    Boa sorte!


    Atenciosamente, Maurício Pitangueira MCP - Windows Server 2003 mauriciopitangueira@hotmail.com
    sexta-feira, 9 de setembro de 2011 11:56
  • Fábio,

    Conseguiu resolver o problema?


    Leonardo Côco .:. MCP / MCDST / MCTS / MCSA / ITILF .:. Se a resposta foi útil classifique-a.
    sexta-feira, 9 de setembro de 2011 19:36
  • Mauricio,

     

    Farei isso, posto novamente os resultados

     

    Obrigado

     

    segunda-feira, 12 de setembro de 2011 14:17
  • Leonardo

     

    Ainda não consegui

    segunda-feira, 12 de setembro de 2011 14:17
  • Olá Maurício

    Desculpe a demora do retorno.

    Executei o Tren Micro HouseCall , tanto na estação como no servidor, e não identificaram nenhuma ameaça, executei também outro antivírus e também não identificou nada.

    Não sei mai o que fazer. Alguma outra ideia?

     

    abs

     

    Fábio

    segunda-feira, 10 de outubro de 2011 20:25
  • Olá pessoal.

    Estou enfrentando o mesmo problema em uma máquina com Windows 10 SL e creio que esse problema seja independente do fato das estações estarem no domínio ou não, já que tal versão não suporta tal recurso.

    Filtrei os logs e identifiquei que desde o dia 26/05/2017 o problema provavelmente surgiu pela primeira vez nessa máquina.

    Desinstalei programas desnecessários, desativei poucos serviços não Microsoft ou não necessários também, e estou procurando pelas possíveis soluções. 

    O Detector de Esgotamento de Recursos do Windows recebeu uma notificação que o computador tem memória virtual insuficiente. ID do evento: 1003

    O Solucionador de Esgotamento de Recursos do Windows recebeu uma notificação que o computador está com memória virtual insuficiente. Essa notificação foi ignorada porque não é mais válida. ID do evento: 1003

    O Windows diagnosticou com êxito uma condição de memória virtual insuficiente. Os programas a seguir consumiram a maior parte da memória virtual: OUTLOOK.EXE (10016) consumiu 139804672 bytes, vmware-remotemks.exe (9676) consumiu 125661184 bytes e PSANHost.exe (4680) consumiu 65622016 bytes. ID do evento: 2004

    O Windows diagnosticou com êxito uma condição de memória virtual insuficiente. Os programas a seguir consumiram a maior parte da memória virtual: TeamViewer_Desktop.exe (2608) consumiu 91860992 bytes, EXCEL.EXE (7200) consumiu 90607616 bytes e SearchIndexer.exe (6976) consumiu 70627328 bytes. ID do evento: 2004


    Atenciosamente, Johnson Cruz (MCP, MCTS, MTA). Conto com seu voto caso minha resposta seja util. Acesse: Blog com Dicas de Informática | CSP Mais Nuvem Microsoft | Meu Perfil no Linkedin

    sexta-feira, 2 de junho de 2017 14:48
  • Olá pessoal.

    Estou enfrentando o mesmo problema em uma máquina com Windows 10 SL e creio que esse problema seja independente do fato das estações estarem no domínio ou não, já que tal versão não suporta tal recurso.

    Filtrei os logs e identifiquei que desde o dia 26/05/2017 o problema provavelmente surgiu pela primeira vez nessa máquina.

    Desinstalei programas desnecessários, desativei poucos serviços não Microsoft ou não necessários também, e estou procurando pelas possíveis soluções. 

    O Detector de Esgotamento de Recursos do Windows recebeu uma notificação que o computador tem memória virtual insuficiente. ID do evento: 1003

    O Solucionador de Esgotamento de Recursos do Windows recebeu uma notificação que o computador está com memória virtual insuficiente. Essa notificação foi ignorada porque não é mais válida. ID do evento: 1003

    O Windows diagnosticou com êxito uma condição de memória virtual insuficiente. Os programas a seguir consumiram a maior parte da memória virtual: OUTLOOK.EXE (10016) consumiu 139804672 bytes, vmware-remotemks.exe (9676) consumiu 125661184 bytes e PSANHost.exe (4680) consumiu 65622016 bytes. ID do evento: 2004

    O Windows diagnosticou com êxito uma condição de memória virtual insuficiente. Os programas a seguir consumiram a maior parte da memória virtual: TeamViewer_Desktop.exe (2608) consumiu 91860992 bytes, EXCEL.EXE (7200) consumiu 90607616 bytes e SearchIndexer.exe (6976) consumiu 70627328 bytes. ID do evento: 2004


    Atenciosamente, Johnson Cruz (MCP, MCTS, MTA). Conto com seu voto caso minha resposta seja util. Acesse: Blog com Dicas de Informática | CSP Mais Nuvem Microsoft | Meu Perfil no Linkedin

    Como a configuração de definição automática da memória virtual, incluindo a configuração manual que havíamos deixado antes não resolveram, configuramos a memória virtual manualmente para ficar na faixa de 4Gb a 16Gb e executamos o procedimento descrito no link seguinte.
    https://support.microsoft.com/pt-br/help/947246/you-may-receive-an-out-of-memory-error-message-because-of-the-desktop-heap-limitation

    Em breve informarei o resultado dos testes realizados. 

    Segue outro link que poderá nos auxiliar no diagnóstico final se houver necessidade.

    http://www.winteltips.com/2016/05/22/memoria-virtual/


    Atenciosamente, Johnson Cruz (MCP, MCTS, MTA). Conto com seu voto caso minha resposta seja util. Acesse: Blog com Dicas de Informática | CSP Mais Nuvem Microsoft | Meu Perfil no Linkedin

    sexta-feira, 2 de junho de 2017 15:32