none
Isa Server X Porto Print RRS feed

  • Pergunta

  • Boa tarde pessoal.

     

    Tenho instalado o software da Porto Print em uma das empresas do grupo em dois computadores. Estão funcionando perfeitamente, porém, fora do ISA. Preciso colocar no ISA.

    Este software é para propostas de seguros para a Porto Seguro.

    Configurei as portas e os servidores externos que o software acessa.

    Percebi no mitoramento do Isa que ele tenta sair como anonymous e o ISA esta configurado para exigir autenticação.

    Já tentei também sem autenticação só para descargo de consciência, também não funcionou.

    Dentro do programa tem uma opção chamada parametros, existe até a opção de configuração para o apontamento do proxy, porta, usuário e senha só que como visto no monitoramento está lá só de alegre.

    Já liguei para o suporte e nada, passaram-me para a área de apoio da Porto e não retornaram até agora.

     

    Pergunta: Existe alguma forma de configurar o ISA para este problema?

     

    Abs. 

     

    quinta-feira, 3 de abril de 2008 18:55

Todas as Respostas

  •  

    Regton,

     

    Voce pode configurar uma regra sem autenticaçao, e sem filtro HTTP.

     

    Crie um objeto computer com o IP do servidor que essa plicaçao se conecta.

    Depois cria uma regra liberando o protocolo HTTP e HTTPS de interno e local host para esse objeto computer, para all users.

     

    Depois entra nas propriedades dos protocolos nessa regra e e desmarque o FILTRO...

     

    E teste ele...coloque essa regra antes da que libera sua internet.

     

    Faça o teste, veja no monitoring e post aki.

     

    Espero ter ajudado se foi util classifique

     

    abrax

    quinta-feira, 3 de abril de 2008 21:31
    Moderador
  • Oi Luiz,

     

    Vou fazer o que indicou sim e aviso se deu certo.

     

    Sou meio que aprendiz com o ISA 2006, tive que aprender até agora na unha (Livro How to Cheat at Configuring Isa Server 2004) e fica algumas dúvidas.

     

    Você poderia esclarecer 2 dúvidas que tenho:

    - A leitura que o Isa faz é de cima para baixo ou de baixo para cima?

    - Tenho uma policy comum de http, https e ftp padrão para usuários autenticados e criei um http (porta padrão 80) sem filtro para um determinado fim e percebi que no monitoring ele fica aparecendo mesmo para quem não deve: Neste caso, quem usar a internet para navegar http ele pega a primeira policy e se não estiver para ele parte para a segunda?     

     

    sexta-feira, 4 de abril de 2008 12:50
  •  

    Regton,

     

    Vamos la..Nao se preocupe, eu tb aprendi ISA na unha...rs...literalmente apanhando na cara...uhauhauhauh

     

    Suas duvidas:

     

    - Ele faz a leitura das regras de cima para baixo sempre, tanto que vc pode perceber que a ultima regra la embaixao é uma default do ISA que bloqueia TUDO e todos...

     

    -Sim esse erro que voce cometeu é comum, tendo em vista que vc nao especificou o destino desses acessos, por isso é importante voce criar um objeto COMPUTER como IP do servidor que esse acesso será realizado e liberar o acesso dessa rgra somente a ele, entendeu?

     

    Se nao vc vai ter problemas, todos passarao pela internet sem autenticaçao e sem filtro.

     

    Entende?

     

    Espero ter te ajudado

     

    fico no aguardo

     

    abraços

     

    sexta-feira, 4 de abril de 2008 13:33
    Moderador
  • Perfeita explicação Luiz, cara você nasceu para isso!

    Vou testar agora pela manhã e aviso a tarde se deu certo, por enquanto obrigadão.

    sexta-feira, 4 de abril de 2008 13:40
  • Até hj aind anao sei para que eu nasci..uhahuahuuha

     

    Eu fico no aguardo do seu retorno

     

    qualquer duvida volta aki.

     

     

    abraços

    sexta-feira, 4 de abril de 2008 13:46
    Moderador
  • Luiz,

     

    Percebi que se usar o protocolo padrão HTTP e remover o filtro dentro da policy remove de todas as diretivas de firewall.

    Criei um protocolo chamado HTTP sem filtro (porta 80) e removi o filtro de proxy e mesmo assim não funcionou, a mensagem no monitoramento é a seguinte:

     

    CONEXÃO NEGADA

    Tipo de Log: Proxy da Web (Direto)

    Status: 12209 O Isa Server exige autorização para preencher a solicitação. Acesso ao filtro de proxy da Web Negado.

    Regra:

    Origem: Interno (10.1.0.37) computador onde se localiza o softaware da Porto.

    Destino: (10.0.0.12:80) Isa, só que tentando utilizar a porta 80

    Solicitação: GET http://www.portoseguro.com.br/

     

    sexta-feira, 4 de abril de 2008 18:30
  • Na parte de usuarios dessa regra nova vc colocou ALL USERS?

    sexta-feira, 4 de abril de 2008 19:22
    Moderador
  • Sim.

     

    Hummmm esqueci de passar esta configuração.

    Nas estações...

    O Internet Explorer esta apontando para 10.0.0.12(Server ISA) na porta 3128

     

    No ISA SERVER...

    Na parte de Redes/Interno/Guia Proxy da Web

     

    Esta marcado:

    Habilitar conexões de cliente de proxy na Web para esta rede.

    Habilitar HTTP

                 Porta HTTP: 3128

     

     

     

    No botão Autenticação...

     

    Esta marcado:

    Básico

    Exigir autenticação de todos os usuários.

    (Quando marco e desmarco esta opção aparece uma mensagem: A exigência de autenticação de todos os usuários pode bloquear o tráfico a sites, como o do Windows Update, que não dão suporte à autenticação do usuário. Para não bloquear sem querer o tráfego a esses sites é recomendável impor a autenticação do usuário em regras de acesso da diretiva de firewall e em regras de publicação, em vez de marcar esta caixa de seleção.)

     

     

    sexta-feira, 4 de abril de 2008 19:48
  •  

    MAravilha explorer OK.

     

    No botao autenticaçao desmarque o baisco e marque INTEGRADO.

    E desmarque esse botao exigir autenticaçao de todos os usuarios...

     

    Faça o teste depois disso

     

     

    no aguardo

     

    abrax

    sexta-feira, 4 de abril de 2008 20:01
    Moderador
  •  

    Percebi que agora esta parando na regra padrão que tenho de http(com filtro),https e ftp que tinha citado anteriormente apresentando o mesmo erro anterior conforme abaixo:

    Status: 12209 O Isa Server exige autorização para preencher a solicitação. Acesso ao filtro de proxy da Web Negado.

     

    A diretiva de firewall que você pediu para criar esta no topo é a primeira.

    sexta-feira, 4 de abril de 2008 20:14
  • Vc criou o objeto computer, como destino?

     

    desmarcou as opçoes q eu falei?

    sexta-feira, 4 de abril de 2008 21:01
    Moderador
  • Oi Luiz,

     

    Sim esta da maneira que você explicou.

     

    Protocolos : HTTP sem filtro que eu criei, HTTPS, portas 220 e 6000 TCP e UDP

    De: Interno, Host Local

    Para: Os dois servidores fornecidos 200.196.232.130 e 200.168.247.66

    Usuários: Todos os usuários

    Em AUTENTICAÇÃO desmarquei a opção Básica e marquei a Integrada

    Desmarquei a opção de autenticaçao de todos os usuarios...

     

    Parece-me que a diretiva de firewall criada não corresponde a ele e vai para a padrão onde encontra-se o HTTP com filtro.

    O que fiz, fui lá na diretiva padrão (Permitir HTTP, HTTPS e FTP) e removi o filtro do HTTP, permiti a diretiva para TODOS OS USUÁRIOS, deixei de LOCAL HOST E INTERNO para EXTERNO e continua a mensagem:

     

    CONEXÃO NEGADA

    Tipo de Log: Proxy da Web (Direto)

    Status: 12209 O Isa Server exige autorização para preencher a solicitação. Acesso ao filtro de proxy da Web Negado.

    Regra: Permitir HTTP, HTTPS e FTP.

    Origem: Interno (10.1.0.37) computador onde se localiza o softaware da Porto.

    Destino: (10.0.0.12:80) Isa, só que tentando utilizar a porta 80

    Solicitação: GET http://www.portoseguro.com.br/

     

    Será que se eu instalar o client no computador do usuário ajuda em alguma coisa?

     

    Abs

     

    segunda-feira, 7 de abril de 2008 19:50
  • Vc pode fazer o teste com o client, porem acho q será a mesma coisa.

     

    Voce configurou as portas e os protocolos nos sentidos certo? (outbound e inbound)?

     

    abraços

    segunda-feira, 7 de abril de 2008 19:54
    Moderador
  • Sim,

    HTTP sem filtro; porta 80; saída.

    TCP: 220 saída

    TCP: 220 entrada

    TCP: 6000 saída

    TCP: 6000 entrada

    UDP: 220 saída

    UDP: 220 entrada

    UDP: 6000 saída

    UDP: 6000 entrada

    segunda-feira, 7 de abril de 2008 20:08
  • Nao tem como vc verificar no suporte deles com precisao de quais portas sao de quais protocolos?

    segunda-feira, 7 de abril de 2008 20:27
    Moderador
  • Vou ver isso.

     

     

     

    terça-feira, 8 de abril de 2008 14:02
  • Da uma olhada assim fazemos a config sem nenhuma brecha...

     

    fico no aguardo

     

    abraços

    terça-feira, 8 de abril de 2008 14:20
    Moderador
  • Desculpa a demora Fernando.

     

    Estava brigando com outro problema aqui.

     

    Consegui fazer funcionar.

     

    As portas 220, 6000 e https estavam certas, o problema realmente era de http, deixei com filtro mesmo (o que eu já estava utilizando) de interno para os servidores Porto Print mais URL e Dominio e funcionou 100%.

     

    Valeu pelas dicas e paciência!

     

    Abs.

     

     

     

     

    terça-feira, 22 de abril de 2008 17:05
  • Show de bola.

     

    Precisando estamos ai.

    Apenas nao esqueça de classificar o post que lhe foi util para finalizarmos o mesmo.

     

     

    Abraços

    terça-feira, 22 de abril de 2008 17:22
    Moderador