none
Um ou mais tipos de campo não estão instalados corretamente. Vá para a página de definições da lista e exclua os campos. RRS feed

  • Pergunta

  • Boa tarde pessoal.

    Ao acessar uma determinada lista, imediatamente recebo a seguinte mensagem: "Um ou mais tipos de campo não estão instalados corretamente. Vá para a página de definições da lista e exclua os campos."

    Ao acessar as configurações da lista, editei cada campo, até recebi uma mensagem de erro em um determinado campo:

    

    Ao clicar em OK nesse campo, recebo a seguinte mensagem:

    Algo deu errado

    A lista selecionada não existe. Talvez tenha sido excluída por outro usuário. Crie um novo campo de pesquisa apontando para uma lista existente.

    Detalhes Técnicos

    ID de Correlação: 23b22e9f-b984-0019-95f5-fa60f419b663

    Data e Hora: 24/01/2020 16:09:17

    > Não consigo identificar a lista em questão. Creio que nenhuma lista tenha sido excluída recentemente.

    > Exportei os dados da lista que apresenta o erro para excel e o campo em questão vem vazio.

    Como contornar o problema?

    O que pode ter causado?

    É possível restaurar um backup apenas desta lista?

    Grato desde já,

    Rodrigo Girão

    sexta-feira, 24 de janeiro de 2020 19:12

Todas as Respostas

  • Boa tarde,

    Este erro normalmente ocorre devido a diferença presente entre o nome do "FieldRef" que é passado na query e o nome interno do campo no SharePoint, há uma diferença entre o nome interno e o nome que é exibido.

    Obs: Este erro geralmente ocorre em coluna de lista que foram traduzidas ou que possuem acentos ou espaços.

    Consultar nome interno da coluna/field:

    Public Sub CamposLista(ByVal webMain As SPWeb, ByVal nomeLista As String)
    Dim lista As SPList = webMain.Lists(nomeLista)
    For Each field1 As SPField In lista.Fields
    If field1.Hidden = False Then
    console.writeline (field1.InternalName)
    End If
    Next
    End Sub

    Fonte: http://picsource.com.br/iBlog/archives/53

    Att,


    segunda-feira, 27 de janeiro de 2020 19:02
  • Boa tarde. Obrigado pela resposta.

    Perdão pela ignorância, mas onde posso executar este código? No SharePoint Designer?

    Outra coisa, identifiquei um campo do tipo "consulta" na lista que apresenta o erro. No local onde deveria aparecer o nome da lista em que é realizada a consulta aparecer a palavra "title".

    O campo em questão chama-se "Colaborador(a)".

    Quando tento exportar os dados da lista, esta coluna vem em branco.

    Desde já, muito obrigado.

    quarta-feira, 22 de abril de 2020 19:20