none
Erro após anexar banco à WebApp RRS feed

  • Pergunta

  • Amigos, estamos efetuando a migração do nosso servidor e também do SharePoint.

    Como fazíamos apenas backup dos arquivos de Banco (MDF), seguimos os procedimentos padrões:

    • Usar o Attach do banco no novo servidor (Banco Content e Config).
    • Geramos uma nova WebApp e referenciamos o nome do Content recém anexado.
    • Reiniciamos todos os serviços e posteriormente, o servidor.


    Quando acessamos a WebApp, ocorre uma mensagem informando que a página tem algum problema e por isso não pôde ser mostrada.

    O Content foi anexado corretamente à WebApp e a prova disso é que quando tentamos criar um Site Collection, com o mesmo nome de um Site Collection contido na Content recém anexada, o SharePoint nos informou que não era possível criar devido a existência de um Site Collection com o mesmo nome.

    quarta-feira, 15 de outubro de 2008 18:45

Todas as Respostas

  • Quando você criou seu novo WebApp você criou um novo Content e depois fez o Attach para o seu antigo conteúdo?

    quarta-feira, 15 de outubro de 2008 19:18
  • Caro Roberto.

    Não sei se entendi bem a sua pergunta, mas primeiro efetuamos o Attach e depois criamos a WebApp apontando para o Content já existente.
    quarta-feira, 15 de outubro de 2008 19:33
  • Você não deve dar restore do Config e nem do Content da Administração.

     

    Se tiver mais de um WebApp, deve criar o numero correspondente.

     

    Ai sim você vai na central e da detach do content database na nova WebApp criada.

     

    Na Administração Central > Gerenciamento de Aplicativo > Bancos de Dados de Conteúdo você seleciona Offline e checa o remover banco.

     

    Da um Attach no Content e volta pra central. Muda a WebApp e Adiciona o Content.

     

     

    Entendeu?

    quarta-feira, 15 de outubro de 2008 19:47
  • Amigos, estou enviando abaixo os passos mais detalhados que executamos:

    1) Copiamos os arquivos de Backup para o novo servidor:

    * WSS_Content_XXXXXX.mdf
    * WSS_Content_XXXXXX_log.ldf
    * SharePoint_Config_XXXXX.mdf
    * SharePoint_Config_XXXXX_log.ldf

    2) Através do SQL Management Studio Express 2005, efetuamos o Attach dos MDFs acima;

    3) Reiniciamos o serviço Timer do SharePoint através do “Services”;

    4) Abrimos o site de Administração do SharePoint e escolhemos a opção para Criar uma nova WebApp;

    5) Na tela de criação da WebApp, escolhemos as seguintes opções:
    * Create a new IIS web site ;
    * Authentication provider: NTLM;
    * Create new application pool;
    * Select a security account for this application pool: Predefined  (NETWORK SERVICE);
    * Database Name: colocamos o nome da Content que attachada no passo 2;
    * Database authentication: Windows authentication (recommended) .

    6)     Tentamos acessar a WebApp, mas sem sucesso.
    quarta-feira, 15 de outubro de 2008 19:47
  • Roberto, vou aplicar este procedimento que você passou e em breve colocarei uma resposta.
    Obrigado.
    quarta-feira, 15 de outubro de 2008 19:54
  • Roberto, fiz todos os passos que você colocou.
    Quando estou no último passo adicionando uma nova Content, ocorre a seguinte mensagem:
    "
    Attaching this database requires upgrade, which could time out the browser session.  You must use the STSADM command 'addcontentdb' to attach this database.".

    Efetuamos o Attach via SQL Management Studio.
    quarta-feira, 15 de outubro de 2008 20:11
  • Na Administração Central, na seção Farm Topology, o novo servidor está com o serviço de Windows SharePoint Services Database ?

    Caso não, vá em Operations -> Data Configuration -> Default database server -> informe o nome do novo server.

    quinta-feira, 16 de outubro de 2008 13:16
  • Sim, já estava configurado.

    Consegui vincular a Content a WebApp com o seguinte comando:
    stsadm.exe -o addcontentdb -url http://NOME_DO_SERVIDOR:2222 -databasename WSS_Content_c664841382b74e1a9539a94533dee250 -databaseserver NOME_DO_SERVIDOR\Microsoft##SSEE

    Não ocorreu nenhum erro na vinculação, mas ao tentar acessar os sites desta Content, ocorre mensagem de erro no Browser.
    quinta-feira, 16 de outubro de 2008 13:45
  • Você consegue visualizar todos os sites em Site collection?

     

    quinta-feira, 16 de outubro de 2008 13:52
  • Sim Bruno.

    Consigo ver o site pela Administração do SharePoint.
    Porém quando o acesso via browser, ocorre uma mensagem informando que há um erro no site e que por este motivo ele não pôde ser mostrado.
    quinta-feira, 16 de outubro de 2008 14:17
  • Algúem pode ajudar?

    Grato.
    quinta-feira, 16 de outubro de 2008 18:43
  • Você ainda tem o ambiente antigo?

    Caso sim, faça um bakup pela Administração central e recupere no ambiente novo, essa é a melhor maneira!

    Mas ainda estou pesquisando uma forma de arrumar o ambiente atual.

     

    quinta-feira, 16 de outubro de 2008 18:53
  • Bruno, obrigado pela resposta.

    Não temos o ambiente antigo mais.
    Só fazíamos backup dos bancos.
    quinta-feira, 16 de outubro de 2008 19:27
  • Qual a mensagem de erro exatamente?

     

    quinta-feira, 16 de outubro de 2008 20:34
  • No Browser:

    A página não pode ser exibida

    Há um problema com a página que você está tentando acessar e ela não pode ser exibida.

    HTTP 500 - erro interno do servidor
    Internet Explorer


    quinta-feira, 16 de outubro de 2008 20:54
  • Encontramos o seguinte Log:

    2008-10-17 10:10:49.72 Server      (c) 2005 Microsoft Corporation.
    2008-10-17 10:10:49.72 Server      All rights reserved.
    2008-10-17 10:10:49.72 Server      Server process ID is 5416.
    2008-10-17 10:10:49.72 Server      Logging SQL Server messages in file 'C:\WINDOWS\SYSMSI\SSEE\MSSQL.2005\MSSQL\LOG\ERRORLOG'.
    2008-10-17 10:10:49.72 Server      This instance of SQL Server last reported using a process ID of 316 at 10/17/2008 10:10:47 AM (local) 10/17/2008 1:10:47 PM (UTC). This is an informational message only; no user action is required.
    2008-10-17 10:10:49.72 Server      Registry startup parameters:
    2008-10-17 10:10:49.72 Server           -d C:\WINDOWS\SYSMSI\SSEE\MSSQL.2005\MSSQL\DATA\master.mdf
    2008-10-17 10:10:49.72 Server           -e C:\WINDOWS\SYSMSI\SSEE\MSSQL.2005\MSSQL\LOG\ERRORLOG
    2008-10-17 10:10:49.72 Server           -l C:\WINDOWS\SYSMSI\SSEE\MSSQL.2005\MSSQL\DATA\mastlog.ldf
    2008-10-17 10:10:49.75 Server      SQL Server is starting at normal priority base (=7). This is an informational message only. No user action is required.
    2008-10-17 10:10:49.75 Server      Detected 4 CPUs. This is an informational message; no user action is required.
    2008-10-17 10:10:50.00 Server      Using dynamic lock allocation.  Initial allocation of 2500 Lock blocks and 5000 Lock Owner blocks per node.  This is an informational message only.  No user action is required.
    2008-10-17 10:10:50.03 Server      Database mirroring has been enabled on this instance of SQL Server.
    2008-10-17 10:10:50.03 spid5s      Starting up database 'master'.
    2008-10-17 10:10:50.07 spid5s      Recovery is writing a checkpoint in database 'master' (1). This is an informational message only. No user action is required.
    2008-10-17 10:10:50.15 spid5s      SQL Trace ID 1 was started by login "sa".
    2008-10-17 10:10:50.17 spid5s      Starting up database 'mssqlsystemresource'.
    2008-10-17 10:10:50.17 spid5s      The resource database build version is 9.00.2047. This is an informational message only. No user action is required.
    2008-10-17 10:10:50.28 spid8s      Starting up database 'model'.
    2008-10-17 10:10:50.29 spid5s      Server name is 'SERVER\MICROSOFT##SSEE'. This is an informational message only. No user action is required.
    2008-10-17 10:10:50.29 Server      Server local connection provider is ready to accept connection on [ \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query ].
    2008-10-17 10:10:50.29 spid5s      Starting up database 'msdb'.
    2008-10-17 10:10:50.29 Server      Dedicated administrator connection support was not started because it is not available on this edition of SQL Server. This is an informational message only. No user action is required.
    2008-10-17 10:10:50.29 Server      SQL Server is now ready for client connections. This is an informational message; no user action is required.
    2008-10-17 10:10:50.39 spid8s      Clearing tempdb database.
    2008-10-17 10:10:50.51 spid8s      Starting up database 'tempdb'.
    2008-10-17 10:10:50.56 spid5s      Recovery is complete. This is an informational message only. No user action is required.
    2008-10-17 10:10:50.56 spid11s     The Service Broker protocol transport is disabled or not configured.
    2008-10-17 10:10:50.57 spid11s     The Database Mirroring protocol transport is disabled or not configured.
    2008-10-17 10:10:50.57 spid11s     Service Broker manager has started.
    2008-10-17 10:10:52.97 spid51      Starting up database 'WSS_Search_SERVER'.
    2008-10-17 10:10:53.09 spid51      Recovery is writing a checkpoint in database 'WSS_Search_SERVER' (7). This is an informational message only. No user action is required.
    2008-10-17 10:10:56.39 spid52      Starting up database 'SharePoint_Config_2dd1326c-a467-42c7-aee0-93a3c6a109a0'.
    2008-10-17 10:10:56.42 spid52      Recovery is writing a checkpoint in database 'SharePoint_Config_2dd1326c-a467-42c7-aee0-93a3c6a109a0' (5). This is an informational message only. No user action is required.

    sexta-feira, 17 de outubro de 2008 14:11