none
Problemas ao executar aplicativo desenvolvido em access Portugues x Espanhol RRS feed

  • Pergunta

  • Caros,

     
    Estou com um problema e gostaria de compartilhar aqui.
     
    Desenvolvi um aplicativo em Access 2007 (idioma Português Brasil).
    Instalei em várias máquinas com o mesmo idioma e funcionou normalmente.
     
    O problema começou quando instalei o aplicativo em uma máquina que utiliza o access na versão Argentina.
     
    Quando ocorre uma consulta, por exemplo:
    Um campo combobox busca uma lista de nome em uma tabela utilizando uma consulta que tem um critério:
    Este criterio em português ficou da seguinte forma:
     
    SELECT [Cadastro de Centro de Custos].[Centro de Custo Dep], Cad_Area.Nome_Area FROM Cad_Area INNER JOIN [Cadastro de Centro de Custos] ON Cad_Area.codigo_area=[Cadastro de Centro de Custos].Codigo_Area_Cc GROUP BY [Cadastro de Centro de Custos].[Centro de Custo Dep], Cad_Area.Nome_Area HAVING (((Cad_Area.Nome_Area)=[Formulários]![FrmRhMacrProc]![AreaRh]));
     
    Na versão Argentina o Access utiliza a mesma linha de comando, porém, sem o acento no formulários.
     
    Minha dúvida é a seguinte: Existe como contornar esse problema sem trocar a versão do access ou substituir as palavras com acentos das consultas?
     
    Grato Pelo Apoio
    Abraços a Todos
    JPiccirillo
    quinta-feira, 23 de setembro de 2010 20:41

Respostas

  • JPiccirillo,

    Tenta configurar as "Opções de Regionais e de Idioma" no Painel de Controle.
    Coloque das duas maquinas iguais.

    Acredito que ira resolver seu problema.

    --------------------------------------------------------------------------------------------
    Raphael Carvalho Cardoso

    • Marcado como Resposta Richard Juhasz segunda-feira, 8 de novembro de 2010 21:19
    quarta-feira, 6 de outubro de 2010 22:10

Todas as Respostas

  • JPiccirillo,

    Tenta configurar as "Opções de Regionais e de Idioma" no Painel de Controle.
    Coloque das duas maquinas iguais.

    Acredito que ira resolver seu problema.

    --------------------------------------------------------------------------------------------
    Raphael Carvalho Cardoso

    • Marcado como Resposta Richard Juhasz segunda-feira, 8 de novembro de 2010 21:19
    quarta-feira, 6 de outubro de 2010 22:10
  • JPiccirillo, você conseguiu resolver este problema? Eu estou com o mesmo problema, mas no meu filtro da caixa de combinação não tem a palavra formulário...
    terça-feira, 26 de abril de 2011 20:57