none
SharePoint 2010 published Inforpath forms opening error(the file is not a valid xml document. DTD is prohibited. Line 2, position 9)

    Pergunta

  • Hi,

    we have set of published inforpath forms in SharePoint 2010 CA. we are using these forms with a list in a site collection. these forms were working ok till couple of days ago, but now it is giving an error when trying to open in client application. the error message says,

    "form template: XXXXXXXXXXXXXXXX.xsn

    the file is not a valid xml document. DTD is prohibited. Line 2, position 9. "

    we removed and republished these forms but that didn't help.

    can someone please give any solution to fix this issue?

    Thanks & Regards.

    


    
    sexta-feira, 9 de março de 2012 10:29

Respostas

Todas as Respostas

  •  

    Hi Lenny,

    There are some reasons as the following may be caused this.

    1. The form template is not available.
    2. The form template cannot be downloaded from the site.
    3. The form template was not sent in the e-mail message.
    4. The form template was not published to a shared location.

    The resolution is to add the URL for the form template to your trusted sites or local zone and ensure that the person has ‘Contribute’, the minimum permissions required to update InfoPath forms.

    You can refer to the following links.

    http://blog.webtechy.co.uk/blog/_archives/2011/7/6/4853096.html

    http://iedaddy.com/2011/05/infopath-cannot-open-the-following-form/

    Thanks,

    Jack

    segunda-feira, 12 de março de 2012 03:52
    Moderador
  • hi,

    this issue is fixed now. the site was already there under trusted sites. it seemed that the problem was with the IE security level. setting the secuity level to default fixed the issue.

    • Marcado como Resposta Gayan Guna segunda-feira, 19 de março de 2012 05:53
    segunda-feira, 19 de março de 2012 05:53
  • Hi

    Im also having this issue with the Out the box approval workflow in SharePoint 2013

    However it does not appear to be happening to all users.

    I've made sure the permissions are the same, the reset of the settings for IE etc are handed by group policy. Im at a bit of a loss. Any help would be greatly appreciated.

    terça-feira, 18 de junho de 2013 19:00
  • Setting security levels back to default made no difference for us.

    What's nutty is that the same workflow forms are working just fine in our development environment.

    Email tasks from our production farm just aren't playing ball. I'm suspecting permissions and security settings somewhere are the cause.


    If at first you don't succeed, ask an MVP.

    sexta-feira, 12 de dezembro de 2014 00:52
  • Exactly the same for us. Works in our single-server DEV environment, fails in QA and produciton even though we moved the entire site collection DB from DEV to QA.  Permissions are the same.  All URLs are set by group policies to be in our intranet zone.  Works in DEV and fails in QA for same user, same browser.

    It's true that DEV has Request Management service stopped (becuase it's a single server and it's not needed) and Request Management service is running in other environments. But Microsoft issued a CU (November I think) that was supposed to fix this.


    Paul LoSacco, Web Presence Team, Omnicare

    segunda-feira, 26 de janeiro de 2015 22:55
  • Hello,

    a lot of these discussions about the error helped me to figure out my solution. In my case it we have a single Server farm SharePoint 2010 without Loadbalancing (2010) oder Request Managemenent Service (2013). In my case the users did not have any permission on the Website. When the custom Feedback workflow starts they get permission for a document library and a SharePoint Task list. When opening Outlook 2010 and trying to open the Task from Outlook the receive the error for the template XML is not valid and DTD is prohibited line 2 Position 9.

    Solution:

    So i figured out that there is hidden library called "Workflows" on the Website. You can only open it with SharePoint Designer. There you can administrate the user permissions for this page. It is necessary to give the users at leaser read permissions on this library. Once the have the read permission on the "Workflows" hidden library they can open the workflow Task directly from Outlook.

    In Addition: Important for reconstruct this error was deleting the local InfoPath Cache on the Client Laptop. Go to Windows Start -> Execute "InfoPath /cache clearall" which clears the local InfoPath Cache on the Client. This was helpful to test the Scenario with Read and without read permission. This Cache was important because once in the template was in the Cache and I deleted the permission, opening the task still works which was distracting. So I cleared the Cache and retested it again. The read permission on the "Workflows" library was the key to solve it.

    Hope this is helpful for some of you. Best regards


    • Editado sustimus quinta-feira, 19 de março de 2015 14:32
    quinta-feira, 19 de março de 2015 14:31