none
Após o Attach, tabela com Status Read-only! RRS feed

  • Pergunta

  • Bom dia a todos!

    Encontrei alguns posts correlacionados, mas infelizmente nada que pode esclarecer minha duvida, que é a seguinte:

    Estou mudando o SLQ2008 de maquina, obviamente tenho que trazer as tabelas do Servidor 01 para 02. Para manter a integridade da base e causar o mínimo de transtorno, executei o procedimento como de costume: BKP, Detach, copia para a pasta no novo servidor é por fim, o Attach das tabelas. Executei este procedimento em outros casos sem nenhum problema, mas agora as Tabelas atachadas ficam com acesso para somente leitura (Read-only).

    O servidor antigo (01) é um AD, um dos motivos para tiramos o SQL desta maquina. O Servidor novo (02) é um member Server, apenas nomeada e adicionada ao domínio.

    Será que alguém sabe como posso attachar a base normalmente sem ficar om este Read-only?

    Desde já agradeço,

    Brandão Jr.


    SharePoint Professinal MCTS: WSS 3.0 Microsoft Profissional Cinco Estrelas: SharePoint Service 3.0 Microsoft TechNet Experience: Windows Server 2008 Microsoft TechNet Experience: Windows Vista www.canalsharepoint.com.br www.brandaonetwork.com.br
    terça-feira, 19 de abril de 2011 11:39

Respostas

  • Brandão,

    Vale ressaltar, que este tipo de comportamento é normal ocorrer quando realizamos este tipo de procedimento através do Detach/Attach!!!!

    Acredito que o seu banco de dados estava com o Status de ReadOnly e não uma table específica.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    terça-feira, 19 de abril de 2011 17:56
    Moderador

Todas as Respostas