none
Hyper-V server 2012 problema com placa de rede broadcom RRS feed

  • Pergunta

  • Bom pessoal, estou com o seguinte problema:

    Instalei o Hyper-V server 2012, e no meu servidor tem uma placa quad-core broadcom.

    Acontece que ao criar uma nova VM com rede externa, meu consumo de rede fica muito lento.

    Gostaria de um auxílio para poder fazer uma atualização de driver de rede, uma vez que essa solução funciona no windows server 2008, mas não sei fazer no Hyper-V server 2012 pois é em modo texto.

    Obrigado!

    terça-feira, 26 de novembro de 2013 12:17

Respostas

Todas as Respostas

  • Bom dia Kevin!

    Normalmente os drivers vem com um instalador/setup que você pode rodar normalmente nas versões core.

    Da uma olhada neste artigo abaixo, pode te ajudar a tirar algumas dúvidas:

    http://technet.microsoft.com/en-us/library/jj647787.aspx


    Luiz Felipe S. T. Costa

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    terça-feira, 26 de novembro de 2013 12:39
  • Olá Kevin, já tive este problema até postei uma solução para isso no blog.

    De uma olhada na solução e faça o mesmo no seu servidor:

    http://ruwer.blogspot.com.br/2013/07/conexao-lenta-em-placas-de-rede.html

    Qualquer coisa me avisa.


    Leandro Ruwer MCP | MCSA Win 2003| MCITS - Server Virtualization | MCSA Win Srv 2012 | MCSE Win Srv 2012

    terça-feira, 26 de novembro de 2013 13:02
  • Pode tentar rodar o instalador do driver, as vezes o setup gráfico roda na boa no Hyper-V server.

    De toda forma, o comando para instalar drivers .inf no prompt é o pnputil:

    pnputil -i -a "d:\drivers\...\*.inf"


    Rafael Bernardes - http://www.cooperati.com.br

    quarta-feira, 27 de novembro de 2013 01:11
  • Olá Kevin, já tive este problema até postei uma solução para isso no blog.

    De uma olhada na solução e faça o mesmo no seu servidor:

    http://ruwer.blogspot.com.br/2013/07/conexao-lenta-em-placas-de-rede.html

    Qualquer coisa me avisa.


    Leandro Ruwer MCP | MCSA Win 2003| MCITS - Server Virtualization | MCSA Win Srv 2012 | MCSE Win Srv 2012

    Sobre o VMQ que era pra ser uma ótima solução, já vi falarem pra desabilitar mesmo, pois está ocorrendo problemas ao invés de ajudar. Acredito que seja a solução.
    quinta-feira, 28 de novembro de 2013 02:19
  • Cara, existem alguns parametros de redes como chimney, rss, netdma, etc, que desabilitados trazem uma melhor performance nas interfaces de redes. Onde eu trabalho é praticamente padrão desabilitar em todos os servidores esses parâmetros. Se quiser cria uma BAT com os comandos abaixo para desabilitar todos.

    netsh int tcp set global rss=disabled
    netsh int tcp set global chimney=disabled
    netsh int tcp set global netdma=disabled
    netsh int tcp set global dca=disabled
    netsh int tcp set global autotuninglevel=disabled
    netsh int tcp set global congestionprovider=none
    netsh int tcp set global ecncapability=disabled
    netsh int tcp set global timestamps=enabled

    Pode fazer durante o dia que não gera nenhuma indisponibilidade.



    Att. Marcelo - Analista de Suporte Microsoft - MCITP/MCSA Server Administrator (2012 e 2008) | Hyper-v | SCOM 2007 R2 | E-mail: marcelosep@outlook.com | http://mswiki.wordpress.com

    quinta-feira, 28 de novembro de 2013 04:35
  • Marcelo, você está desabilitando serviços incríveis por padrão!!!

    O RSS, RDMA, TCP Chimmey offload...

    Só faça isso se a placa não for compatível, ou se tiver total certeza do que está fazendo.


    Rafael Bernardes - http://www.cooperati.com.br

    quinta-feira, 28 de novembro de 2013 04:37
  • Sim Rafael, esses parâmetros para o nosso ambiente tem diferenças. De repente pode variar de acordo com o modelo do servidor e interface de rede.


    Att. Marcelo - Analista de Suporte Microsoft - MCITP/MCSA Server Administrator (2012 e 2008) | Hyper-v | SCOM 2007 R2 | E-mail: marcelosep@outlook.com | http://mswiki.wordpress.com

    quinta-feira, 28 de novembro de 2013 14:04