none
Comparar duas colunas no Excel RRS feed

  • Pergunta

  • Bom dia Pessoal,

         Tenho duas colunas no excel A e B. Gostaria de comparar as duas e os valores que forem iguais gostaria que aparececem na coluna C.

         Obs.: os valores iguais não necessariamente estarão na mesma linha.

         Ex.: Na coluna A na linha 3 tenho o valor 'OSCAR'. O valor 'OSCAR' repete-se na coluna B na linha 20. Neste caso gostaria que este valor duplicado aparece-se na coluna C.

         Como posso fazer isso?

    Obrigado,

    Jurandyr F. Alves

       

     


    • Editado jfonseca segunda-feira, 14 de março de 2016 13:54
    segunda-feira, 14 de março de 2016 13:53

Respostas

  • Boa tarde Jurandyr

    Considerando que os nomes se encontram na coluna A e B, na coluna C copie e cole a fórmula:

    =SEERRO(PROCV(A2;$B$2:B$100;1;0);"")

    Dê retorno.

    []s

    • Marcado como Resposta jfonseca quarta-feira, 16 de março de 2016 20:47
    terça-feira, 15 de março de 2016 17:56
  • Boa tarde,

    Desta forma também funciona:

    =PROCV(A1;B:B;1;0)

    Obrigado,

    Jurandyr F. Alves

    • Marcado como Resposta jfonseca quarta-feira, 16 de março de 2016 20:48
    quarta-feira, 16 de março de 2016 20:47

Todas as Respostas

  • Boa tarde Jurandyr

    Considerando que os nomes se encontram na coluna A e B, na coluna C copie e cole a fórmula:

    =SEERRO(PROCV(A2;$B$2:B$100;1;0);"")

    Dê retorno.

    []s

    • Marcado como Resposta jfonseca quarta-feira, 16 de março de 2016 20:47
    terça-feira, 15 de março de 2016 17:56
  • Boa tarde,

    Desta forma também funciona:

    =PROCV(A1;B:B;1;0)

    Obrigado,

    Jurandyr F. Alves

    • Marcado como Resposta jfonseca quarta-feira, 16 de março de 2016 20:48
    quarta-feira, 16 de março de 2016 20:47
  • desculpa ignorância, mas depois que eu coloco a formula como faço para fazer a verificação?

    São 8600 nomes, estou apavorada.

    sexta-feira, 26 de outubro de 2018 15:37
  • Fabiane,

    a PROCV procura um valor específico em um conjunto de dados. 

    No seu caso, entendo que você que procurar o conteúdo de uma célula da coluna B em todas as células da coluna A. Se a PROCV não encontrar este valor da célula de B nas células da coluna A, volta erro. Para evitar esse erro, usamos a função SEERRO

    Segue um exemplo de como deveria ficar sua planilha.

    sexta-feira, 26 de outubro de 2018 16:47
  • Gente, muito obrigada! Mesmo! abraço no coração de vcs!!!!!!!!!!!!!!!!!!!!!!!! 

    kkkkkkk

    terça-feira, 6 de novembro de 2018 17:23
  • Boa noite.

    No meu caso, tenho duas colunas: uma com 700 itens (coluna A) e uma com 150 itens (coluna B).

    O problema é que, com essa fórmula, o excel só está procurando nas 150 primeiras células da coluna A.

    Poderiam me ajudar?


    terça-feira, 4 de dezembro de 2018 21:40