none
Microsoft OLE DB Provider for SQL Server erro '8004d00a' RRS feed

  • Pergunta

  • Anteriormente eu tinha um servidor 2000 server SP4 com SQL server 2000 SP4, aonde rodava o IIS com softwares em ASP e .NET C# .
     
    Hoje estou com dos servidores:
    A)um servidor 2003 server com o ISS para rodar aplicação ASP e .NET
    B)um servidor 2003 server com o SQL Server 2000 SP4.
     
    Ou seja, um funciona como servidor de aplicação e outro como de banco de dados
    O servidor A possui duas interfaces de rede, uma com IP válido da internet e outro IP da rede interna. O servidor B possui uma interface de rede para a rede interna.
    Ou seja, no código dos sistemas que estão no servidor A está informado na string de conexão o endereço do servidor B de banco de dados na rede interna.

    Agora está dando esse erro:

    Microsoft OLE DB Provider for SQL Server erro '8004d00a'
    A nova transação não pode ser inscrita no coordenador de transação especificado.
     
     
    Acredito que tenha algo a ver com essa mudança para o outro servidor , só não sei o que.
     
    Alguém utiliza esse modelo de dois servidores, um de aplicação e outro de banco de dados?
     

    Atenciosamente,
    Sérgio Gurgel Menezes
    "o mal do inteligente é achar que o outro é burro!"

     


    Sérgio Gurgel msn/gtalk.: sergio.gurgel@gmail.com
    • Movido Gustavo Maia Aguiar sexta-feira, 31 de julho de 2009 20:32 (De:SQL Server - Desenvolvimento Geral)
    sexta-feira, 31 de julho de 2009 09:47

Respostas

  • Ola Sérgio

    O MSDTC esta iniciado?

    caso sim,
      Verifique em security se as opções abaixo esta marcadas.
      Allow inbound
      Allow Outbound
      Enable Transactional ... tip transactions
      Enable XA transactions
      e o X da questão.... (tive o mesmo problema e era isto)
       no meu caso eu marquei "No Authentication Required"

    Caso MSTDC parado, inicie-o

    Att.
    Marcelo Fernandes


    MCP, MCDBA, MCSA, MCTS. Se útil, classifique!!!
    • Marcado como Resposta Richard Juhasz quinta-feira, 29 de dezembro de 2011 18:07
    sexta-feira, 31 de julho de 2009 11:28
    Moderador