none
Exchange 2007, ISA 2004 e não consigo Sincronizar com o Smartphone RRS feed

  • Pergunta

  • Olá pessoal,

     

    Estou quebrando a cabeça aqui e não encontro uma solução para meu problema.

     

    É o seguinte: Hoje uso o Exchange 2007 SP1 usando um certificado SSL da COMODO (EssentialSSL). Tudo funciona bem, OWA, acesso interno e externo.

    Adquiri alguns Smartphones (2 HTC TyTN II, 1 HTC  Touch e 1 Imate Ultimate 6150 (esse já usava a algum tempo com o Exchange 2003)).

     

    Acontece que não consigo sincronizar de jeito nenhum esses danados. Já fiz de tudo a meu alcance. Quem pode me ajudar?

     

    Atualmente o erro que está dando é:

     

    “Sua conta no Microsoft Exchange Server não tem permissão para sincronizar com as configurações atuais. Entre em contato com o Administrador do Exchange Server”. Código de Suporte: 0x85010004

     

    Sim, ainda uso o ISA2004 EE (4.0.3445.907).

     

    segunda-feira, 24 de novembro de 2008 23:36

Respostas

  • Pessoal,

     

    encontramos a solução para o problema.

     

    Por alguma razão, o diretório virtual do ActiveSync ficou corrompido.

    Seguindo a orientação do engenheiro da Microsoft, utilizamos o Powershell para excluirmos e recriarmos esse diretório.

    O comando para exclusão utilizado foi: Remove-ActiveSyncVirtualDirectory -Identity "<servername>\Microsoft-Server-ActiveSync (Default Web Site)"

    Depois foi executado o comando para recriar: New-ActiveSyncVirtualDirectory

     

    Depois foi resetado o IIS: iisreset

     

    Devem ser utilizados os comandos do powershell e não no IIS Manager para refletir as mudanças também no AD.

     

    É isso. Agora está tudo Ok.

     

    Obrigado a todos!

     

    sexta-feira, 28 de novembro de 2008 14:12

Todas as Respostas

  • Ola JairoMarques,

     

    Algumas questões que podem te ajudar no seu problema?

    1) Certificado é válido, então não seria necessário mas você já tentou importar o mesmo para o smartphone e ver se vai rolar?

    2) Acontece com todos?

    3) O mais provável para mim seria os seus usuários que querem o acesso estarem com o activesync disable ou ainda problema no teu IIS, com a autenticação e também problemas de configuração no ISA. Valide esses pontos e depois poste aqui.

     

    Abs.

     

    terça-feira, 25 de novembro de 2008 00:34
  • Ola Jairo,

     

    Junto com a dica do Rodrigo, olha este site e faz o teste https://www.testexchangeconnectivity.com/ se der erro com certificado ou nao e com isto tu valida e o erro é de certificado ou de configuraçao.

     

     

    terça-feira, 25 de novembro de 2008 01:47
  • Oi Rodrigo,

     

    1) Sim, já tentei importar para os smartphones e nada;

    2) Sim. Com todos.

    3) O Activesync está habilitado no Exchange 2007 com SSL. O usuário está habilitado com uma Policy para Usuários móveis.

     

    terça-feira, 25 de novembro de 2008 12:10
  • Anderson,

     

    Olha o resultado do teste:

     

    Testing Exchange Activesync for host <meu domínio>
      Exchange Activesync test Failed
    Test Steps
     
    Attempting to Resolve the host name <meu domínio> in DNS.
      Host successfully Resolved
    Additional Details
      IP(s) returned: <meu IP>
    Testing TCP Port 443 on host <meu domínio> to ensure it is listening/open.
      The port was opened successfully.
    Testing SSLCertificate for validity.
      The certificate passed all validation requirements.
    Additional Details
      Subject: CN=<meu domínio>, OU=Free SSL, OU=Domain Control Validated, Issuer CN=EssentialSSL CA, O=COMODO CA Limited, L=Salford, S=Greater Manchester, C=GB
    Testing Http Authentication Methods for URL https://<meu domínio>/Microsoft-Server-Activesync/
      Http Authentication Test failed
     
    Tell me more about this issue and how to resolve it
    Tell me more about this issue and how to resolve it
    Additional Details
      Initial Anonymous HTTP(s) request did not fail but Anonymous is not a supported Authentication Method for this scenario

    Alguma sugestão?

    terça-feira, 25 de novembro de 2008 14:17
  •  

    Ola Jairo,

     

    parece que o teu certificado está certo, valide se o teu dispositivo aceita a root CA do teu certificado.

     

    terça-feira, 25 de novembro de 2008 14:53
  • Anderson,

     

    como faço isso? Exportei os 3 .cer do caminho do certificado e importei no smartphone. É assim que deve ser feito?

     

    Tem como verificar isso?

     

    terça-feira, 25 de novembro de 2008 14:59
  • Tem que baixar o certificado da CA e ver se é aceito no teu smartphone, tu temssl no owa? tenta acessar a pagina via smartphone se funcionar é sinalque o certificado nao é problema, se nao funcionar fala com o pessoal do teu dispositivo.

     

     

    terça-feira, 25 de novembro de 2008 15:14
  • Anderson,

     

    acessando o OWA pelo smartphone funciona tudo ok.

     

    Jairo

     

    terça-feira, 25 de novembro de 2008 19:14
  • Ola Jairo,

     

    Valide esse artigo do Bharat da Microsoft que relaciona o seu problema com o ISA 2006:

    http://exchangepedia.com/blog/2007/08/exchange-activesync-isa-2006-and-error.html

     

    Abs.

     

    terça-feira, 25 de novembro de 2008 19:54
  • Rodrigo,

     

    nao consegui acessar o artigo (timeout).

     

    Estou com o caso aberto com a Microsoft e nesse momento estou com dois engenheiros (um de ISA e outro de Exchange) tentando resolver o problema.

     

    Assim que tiver uma resposta e solucionar o problema postarei aqui.

     

    quinta-feira, 27 de novembro de 2008 23:07
  • Pessoal,

     

    encontramos a solução para o problema.

     

    Por alguma razão, o diretório virtual do ActiveSync ficou corrompido.

    Seguindo a orientação do engenheiro da Microsoft, utilizamos o Powershell para excluirmos e recriarmos esse diretório.

    O comando para exclusão utilizado foi: Remove-ActiveSyncVirtualDirectory -Identity "<servername>\Microsoft-Server-ActiveSync (Default Web Site)"

    Depois foi executado o comando para recriar: New-ActiveSyncVirtualDirectory

     

    Depois foi resetado o IIS: iisreset

     

    Devem ser utilizados os comandos do powershell e não no IIS Manager para refletir as mudanças também no AD.

     

    É isso. Agora está tudo Ok.

     

    Obrigado a todos!

     

    sexta-feira, 28 de novembro de 2008 14:12
  • Ola Jairo,

     

    Obrigado pelo feedback!

     

    Abs.

     

    sexta-feira, 28 de novembro de 2008 14:19
  • Ola..

    Trabalho no suporte  HTC e realmente este problema vem ocorrendo frequente mas so com a versão 2007 do exchenge. Também ta ocorrendo com outlook  2007.  E ate os arquivos  .doc e .xls não estão rodando, aparece a mensagem de certificado não valido.

    Gostaria muito de saber uma solução para este problema também.

    Grato;
    sábado, 29 de novembro de 2008 01:00
  • G-xster,

     

    verifique se os certificados da unidade certificadora estão instalados nos smartphones

     

     

    segunda-feira, 1 de dezembro de 2008 20:40
  • Amigo,

     

    No meu caso exportei o certificado do Webmail e importei para o HTC. Após isso, a mensagem de certificado parou de aparecer.

     

     

    Martins

     

    quarta-feira, 3 de dezembro de 2008 23:13