locked
Remoteapp - Funcionando apenas com permissão de administrador RRS feed

  • Pergunta

  • Fala pessoal tudo na paz?

    É minha primeira pergunta na comunidade, vamos lá...rss

    Seguinte, estou configurando o remoteApp no Win2008 R2 Enterprise x64. Ja esta instalado o AD, ja publiquei os aplicativos, porem so consigo acessar a aplicação via TS webAcess quando deixo os usuarios cadastrados no AD com privilegio de administrador. Porem desta forma fica inseguro porque se o usuario acessar pelo TS normal (mstsc.exe) ele tem acesso total no servidor...

    Testei retirando a permissão de administrador e deixando outros grupos e nao funciona de jeito nenhum... Não fui eu quem instalou o serviço, mas pesquisando pela internet vi q no momento da instalação o acesso padrão vai para os administradores e se quiser adicionar outro grupo tambem pode. Mas no meu caso como ja esta instalado será que tem alguma forma de adicionar esse privilegio a um determinado grupo de usuarios que criei?

     

    Obs:Queria que os usuarios tivessem acesso apenas pelo tsweb, não quero que os mesmos tenham acesso a área de trabalho quando conectarem pelo mstsc.exe







    sexta-feira, 8 de abril de 2011 18:19

Respostas

  • Daniel

    Boa noite,

     

    O que você pode fazer é liberar o acesso via tsweb ou através do remoteapp, assim o usuário irá acessar apenas a aplicação (eu particularmente acho o remoteapp até mais pratico), permissões de remote desktop users apenas e crie políticas para garantir que o usuário irá acessar apenas o que precisa, caso alguém tente se logar via mstsc.

    Pelo o que sei, não tem como você bloquear opção de logar no ts, pois ao acessar via remoteapp é utilizado o servidor, mas com permissão apenas de remote desktop users e politicas locais, você consegue deixar o Servidor seguro.

    Links de Gpo´s de TS:

    http://technet.microsoft.com/pt-br/library/cc753697(WS.10).aspx

    RemoteApp:

    http://technet.microsoft.com/pt-br/library/cc730673(WS.10).aspx

     

    Abcs.

    Wilian Betioli

    Se útil, favor classificar

    • Sugerido como Resposta Wilian Betioli sexta-feira, 8 de abril de 2011 21:49
    • Marcado como Resposta Richard Juhasz segunda-feira, 11 de abril de 2011 16:39
    sexta-feira, 8 de abril de 2011 21:49

Todas as Respostas

  • Daniel

    Boa noite,

     

    O que você pode fazer é liberar o acesso via tsweb ou através do remoteapp, assim o usuário irá acessar apenas a aplicação (eu particularmente acho o remoteapp até mais pratico), permissões de remote desktop users apenas e crie políticas para garantir que o usuário irá acessar apenas o que precisa, caso alguém tente se logar via mstsc.

    Pelo o que sei, não tem como você bloquear opção de logar no ts, pois ao acessar via remoteapp é utilizado o servidor, mas com permissão apenas de remote desktop users e politicas locais, você consegue deixar o Servidor seguro.

    Links de Gpo´s de TS:

    http://technet.microsoft.com/pt-br/library/cc753697(WS.10).aspx

    RemoteApp:

    http://technet.microsoft.com/pt-br/library/cc730673(WS.10).aspx

     

    Abcs.

    Wilian Betioli

    Se útil, favor classificar

    • Sugerido como Resposta Wilian Betioli sexta-feira, 8 de abril de 2011 21:49
    • Marcado como Resposta Richard Juhasz segunda-feira, 11 de abril de 2011 16:39
    sexta-feira, 8 de abril de 2011 21:49
  • Wilian obg pelo retorno.

     

    Quando eu tiro o aceso do usuario de Administrator e coloco como remote desktop user, quando tento conectar pelo TSWeb ocorre a seguinte mensagem

    "To log on to this remote computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Administrators group have this right. If you are not a member of the Administrators group or another group that has this right, or if the Administrators group does not have this right, you must be granted this right manually."

     

    Instalei o Win2008 R2 no virtualbox pra fazer uma simulação, e nele se deixar como remote desktop user funciona normal. O problema é que neste servidor que não esta funcionando é um Datacenter e por isso nao queria reinstalar o serviço pq ja esta configurado as licenças...

    Alguem tem ideia de como posso resolver isso?


    segunda-feira, 11 de abril de 2011 17:25
  • Daniel

    Bom dia,

    Em Remote Settings, select users, adicione o usuário manualmente para acesso ao TS e verifica se funciona.

    Obrigado e no agaurdo.

    Wilian Betioli

    quarta-feira, 13 de abril de 2011 14:18