locked
CONECÇÃO COM BANCO DE DADOS RRS feed

  • Pergunta

  • Bom dia Pessoal.

    Sou novato em ambiente SQL Server.

    Desenvolvi um sistema em C#, usando o Banco SQL Server 2005. Terminei o Sistema e tenho que instalar no cliente. Instalei o Sistema, instalei o Banco SQLExpress e parecia que tudo estava indo bem. Porém, quando executei o sistema, começou a apresentar algumas falhas. Na minha máquina onde foi desenvolvido o sistema, está tudo certo. No cliente já começou apresentado erro de conexão. No sistema criei uma string de conecção:

    namespace Notas.DAL1 { public class Dados { public static string StringDeConexao { get { return "Server=SILMARA\\SQLEXPRESS;database=MODEL;Trusted_Connection=True"; // return "Server=PCSERVIDOR\\SQLTRANSP;database=NOTAS;Trusted_Connection=True"; } } } }

    Na linha de baixo é a conexo com o banco na minha máquina. A linha de cima é a conexão na máquina do cliente.

    No momento em que entro no sistema na máquina do cliente aparece a seguinte mensagem:

    O que eu posso está fazendo para solucionar o problema?

    Desde já agradeço pela atenção.

    Garibaldo

    segunda-feira, 22 de outubro de 2012 14:14

Respostas

  • Verifica sua connection string, você ta tentando conectar no MODEL. Verifica nome de servidor/instancia.

    Tente uma Connection String com usuário e Senha especificados na mesma, sem Truted Connection.

    terça-feira, 23 de outubro de 2012 16:35

Todas as Respostas

  • Garibaldo, pelo erro pode ser que o servidor não permita conexões remotas, va na propriedades do servidor, na aba connections e verifique se o checkbox "allow remote connections to this server" esta marcada, se não estiver marque-a.

    Alexandre Matayosi Conde Mauricio. Se esta sugestão for útil, por favor, classifique-a como útil. Se ela lhe ajudar a resolver o problema, por favor, marque-a como Resposta.

    segunda-feira, 22 de outubro de 2012 14:42
  • Também veja, no Configuration Manager (que fica na pastado SQL Server, no menu Iniciar) se o serviço SQL Server Browser está iniciado.

    Roberson Ferreira - Database Developer
    Acesse: www.robersonferreira.com.br
    Email: contato@robersonferreira.com.br

    Se esta sugestão for útil, por favor, classifique-a como útil.
    Se ela lhe ajudar a resolver o problema, por favor, marque-a como Resposta.

    segunda-feira, 22 de outubro de 2012 15:36
  • Boa tarde Alexandre.

    Já verifiquei na aba connections e a checkbox está clicada.

    Gari

    segunda-feira, 22 de outubro de 2012 15:55
  • Boa tarde Roberson,

    Verifiquei o que você falou,  porém,  essa opção SQL Server Browser não consta Nessa versão do SQLEXPRESS. Posso ter instalado o SQL com problemas ou faltando alguma função?

    Gari

    segunda-feira, 22 de outubro de 2012 15:57
  • Oi Roberson, encontrei a opção que você indicou.

    Habilitei e ela encontra-se em Execução.

    É isso mesmo?

    Gari

    segunda-feira, 22 de outubro de 2012 16:04
  • Sim. Isso mesmo.

    Reinicie o serviço do SQL Server (pelo Configuration Manager mesmo) e veja se funciona.


    Roberson Ferreira - Database Developer
    Acesse: www.robersonferreira.com.br
    Email: contato@robersonferreira.com.br

    Se esta sugestão for útil, por favor, classifique-a como útil.
    Se ela lhe ajudar a resolver o problema, por favor, marque-a como Resposta.

    segunda-feira, 22 de outubro de 2012 16:40
  • Roberson, reiniciei e nada, ainda continua com a mensagem de erro.

    Gari

    segunda-feira, 22 de outubro de 2012 19:28
  • Gari Guerreiro,

    Percebi que colocou Trusted Connection, isso força você informar o usuário e senha do SQL Server e onde estão essas informações?


    []'s

    segunda-feira, 22 de outubro de 2012 19:34
  • Fernando boa tarde,

    Obrigado pela dica, porém, só posso testar amanhã, pois, o meu cliente acabou de desligar os computadores.

    Obrigado pessoal, se não der certo estarei aqui de volta amanhã.

    Gari

    segunda-feira, 22 de outubro de 2012 20:03
  • Tenta rodar essa consulta no SQL : 

    sp_configure 'show advanced options', 1
    GO
    RECONFIGURE 
    GO
    sp_configure 'remote access', 1
    GO
    RECONFIGURE 
    GO

    Verifica também essa questão de Trusted Connection, quando você usa esse tipo de acesso o SQL tenta usar o Login Windows do Usuário para acessar o Banco de Dados, se esse usuário não tiver permissão de acesso ao Banco de Dados a conexão será recusada.

    abrs


    terça-feira, 23 de outubro de 2012 12:23
  • Bom dia Pedro,

    Eu fiz o que você me indicou, porém, não funcionou.

    Eu consigo acessar o banco sem nenhum problema. dou manutenção no banco sem nenhum problema, Criei minhas querys sem nenhum problema, porém, no momento de acessar o banco via sistema dá a mensagem.

    Será que tem mais alguma coisa que eu estou deixando sem fazer?

    desde já agradeço.

    Garibaldo

    terça-feira, 23 de outubro de 2012 13:51
  • Guerreiro!

    Abra o Configuration Manager e verifica se os protocolos TCP/IP e Named Pipes estão habilitado para essa instancia.

    Verifica também o Firewall do Windows, desabilite e faça um teste. Caso você possa mante-lo desabilitado OK, mas caso não coloque uma exceção na porta que essa instancia está escutando.

    terça-feira, 23 de outubro de 2012 14:01
  • Oi Pedro,

    Habilitei os protocolos TCP/IP e Named Pipes e nada.

    Desabilitei o Firewall do Windows e nada.

    Guerreiro

    terça-feira, 23 de outubro de 2012 15:45
  • Cara, tem certeza que o meio que o sistema utiliza para a comunicação com o banco está configurado corretamente?

    Exemplo: será que não há um erro na string de conexão.


    Roberson Ferreira - Database Developer
    Acesse: www.robersonferreira.com.br
    Email: contato@robersonferreira.com.br

    Se esta sugestão for útil, por favor, classifique-a como útil.
    Se ela lhe ajudar a resolver o problema, por favor, marque-a como Resposta.

    terça-feira, 23 de outubro de 2012 16:03
  • Verifica sua connection string, você ta tentando conectar no MODEL. Verifica nome de servidor/instancia.

    Tente uma Connection String com usuário e Senha especificados na mesma, sem Truted Connection.

    terça-feira, 23 de outubro de 2012 16:35