none
Erro ao restaurar backup de BD feito no Express R2 para outro Express RRS feed

  • Pergunta

  • Pessoal,

    Hoje de manhã tive que restaurar um backup de um cliente que ta instalado o SQL Server 2008 R2 (express) para o meu (tbm express) e deu erro que a minha versão é anterior.

    A minha não é R2 e a do cliente é. Provavelmente seja por isso.

    Não tem como restaurar o backup, nessas condições? Só por causa do release???

    quarta-feira, 4 de maio de 2011 17:05

Respostas

  • Exato...

    o R2 não é um Service pack do 2008... no entanto que o build dele é 10.50, ou seja é um novo engine!

    Mas no geral vc não deverá ter problemas de compatibilidade com os seus aplicativos

    att.
    Marcelo Fernandes


    MCP, MCDBA, MCSA, MCTS.
    Se útil, classifique!!!
    Me siga no twitter: @marcelodba

    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quarta-feira, 4 de maio de 2011 18:01
    Moderador
  • Julio,

    Eu estou fazendo vários testes de compatibilidade com bases de dados criados no SQL Server 2005 e 2008 no R2 e até o presente momento não tive problemas, foi necessário alguns ajustes na estrutura das tabelas e refazer alguns índices por questões de performance.

    Em uma aplicação desenvolvida a algum tempo estou trabalhando com o banco de dados migrou de forma gradativo do SQL Server 2000 para o 2008 e do 2008 para o R2, e também não estou tendo problemas, sinceramente estou surpreso.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quinta-feira, 5 de maio de 2011 19:09
    Moderador
  • Julio,

     

    Realmente não ha como, bom, como o sql express é free, uma sugestao seria tambem instalar o r2, todo caso, seria necessario criar os scripts, ou fazer o export dos dados.

     

    restoreou attach em uma base destino, só de uma versão igual ou superior a da origem.

     

    E caso por exemplo uma base 2005 seja attachada em sql 2008, a mesma não podera ser desatachada e atachada novamente em uma instancia 2005.


    Oracle OCA11g, MCC 2011!
    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quarta-feira, 4 de maio de 2011 17:10
    Moderador
  • Acho que é simplesmente isso entao..

     

    Sim posso baixar o R2 sem problemas, ja devo ter inclusive, só preciso verificar se é a versão com o Management Studio e/ou advanced tools.

     

    É que tem q ser entendido que o R2 deve ser tratado como uma nova versão do sql server (como se fosse um 201), não simplesmente uma autalização, certo?

     

    Valeu, abraço

    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quarta-feira, 4 de maio de 2011 17:49

Todas as Respostas

  • Julio,

     

    Realmente não ha como, bom, como o sql express é free, uma sugestao seria tambem instalar o r2, todo caso, seria necessario criar os scripts, ou fazer o export dos dados.

     

    restoreou attach em uma base destino, só de uma versão igual ou superior a da origem.

     

    E caso por exemplo uma base 2005 seja attachada em sql 2008, a mesma não podera ser desatachada e atachada novamente em uma instancia 2005.


    Oracle OCA11g, MCC 2011!
    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quarta-feira, 4 de maio de 2011 17:10
    Moderador
  • Acho que é simplesmente isso entao..

     

    Sim posso baixar o R2 sem problemas, ja devo ter inclusive, só preciso verificar se é a versão com o Management Studio e/ou advanced tools.

     

    É que tem q ser entendido que o R2 deve ser tratado como uma nova versão do sql server (como se fosse um 201), não simplesmente uma autalização, certo?

     

    Valeu, abraço

    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quarta-feira, 4 de maio de 2011 17:49
  • Exato...

    o R2 não é um Service pack do 2008... no entanto que o build dele é 10.50, ou seja é um novo engine!

    Mas no geral vc não deverá ter problemas de compatibilidade com os seus aplicativos

    att.
    Marcelo Fernandes


    MCP, MCDBA, MCSA, MCTS.
    Se útil, classifique!!!
    Me siga no twitter: @marcelodba

    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quarta-feira, 4 de maio de 2011 18:01
    Moderador
  • Julio,

    Eu estou fazendo vários testes de compatibilidade com bases de dados criados no SQL Server 2005 e 2008 no R2 e até o presente momento não tive problemas, foi necessário alguns ajustes na estrutura das tabelas e refazer alguns índices por questões de performance.

    Em uma aplicação desenvolvida a algum tempo estou trabalhando com o banco de dados migrou de forma gradativo do SQL Server 2000 para o 2008 e do 2008 para o R2, e também não estou tendo problemas, sinceramente estou surpreso.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    • Marcado como Resposta Julio Costi sexta-feira, 12 de agosto de 2011 03:42
    quinta-feira, 5 de maio de 2011 19:09
    Moderador