none
Vba Excel_Selecionar e destacar linha com resultado iguais RRS feed

  • Pergunta

  • Boa tarde a Todos

    Preciso da ajuda com uma macro para selecionar um resultado da linha destacando apenas os valores da linha que corresponde os valores de uma tabela: exemplo abaixo: na tabela maior tem destacado na linha apenas os valores que corresponde a tabela menor.

    Tabela

    Grato a todos pela ajuda

    Mauro



    • Editado MauroMeira segunda-feira, 18 de abril de 2016 19:44 erro
    segunda-feira, 18 de abril de 2016 19:40

Respostas

  • Boa noite Mauro.

    Suponha sua tabela principal de "A1:E12" e sua tabela menor de "A15:E15".

    Crie uma coluna de apoio, no caso a coluna "F" (pode ficar oculta) e acrescente a fórmula matricial em "F1": {=SE(E(($A1:$E1)=($A$15:$E$15));"Ok";"-")}

    Obs.: as chaves são inseridas pressionando Ctrl + Shift + Enter após finalizar a edição da célula (ao invés de simplesmente Enter).

    Copie e cole a fórmula para "F2:F12" (Ctrl+C normal).

    Selecione toda sua tabela maior começando de "A1" (deve ser a célula ativa); Crie nova regra de formatação condicional baseada em fórmula e acrescente: "=E($F1="Ok";A1<>"")" (sem aspas). Formate como quiser.

    Pronto! Sempre que todas as células da mesma linha coincidirem com o respectivo valor na linha 15 excluindo-se o zero a formatação na linha será aplicada.

    Conseguiu entender?


    Filipe Magno

    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    terça-feira, 19 de abril de 2016 02:42
  • Bom Dia Felipe Magno

    Antes de mais nada gostaria de agradecer por ajudar e desculpe não retornar antes, está fórmula, a 1ª da o seguinte erro, #VALOR!, é normal isso?

    Grato

    MauroMeira


    • Editado MauroMeira quarta-feira, 20 de abril de 2016 12:00 erro
    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    quarta-feira, 20 de abril de 2016 11:59
  • Bom dia Mauro.

    Isso irá acontecer se você não inserir a fórmula como matricial. Para funcionar basta:

    • inserir a fórmula sem as chaves:

    =SE(E(($A1:$E1)=($A$15:$E$15));"Ok";"-")

    • Enquanto edita a célula pressione:

    Ctrl+Shift+Enter

    As chaves serão acrescentadas automaticamente.

    • Copie e cole nas demais células.

    Compreendeu?


    Filipe Magno

    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    quarta-feira, 20 de abril de 2016 12:03
  • Boa Tarde Filipe

    Entendi e deu certo, Obrigado mais uma Vez

    Abraço

    MauroMeira

    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    quarta-feira, 20 de abril de 2016 15:19

Todas as Respostas

  • Boa noite Mauro.

    Suponha sua tabela principal de "A1:E12" e sua tabela menor de "A15:E15".

    Crie uma coluna de apoio, no caso a coluna "F" (pode ficar oculta) e acrescente a fórmula matricial em "F1": {=SE(E(($A1:$E1)=($A$15:$E$15));"Ok";"-")}

    Obs.: as chaves são inseridas pressionando Ctrl + Shift + Enter após finalizar a edição da célula (ao invés de simplesmente Enter).

    Copie e cole a fórmula para "F2:F12" (Ctrl+C normal).

    Selecione toda sua tabela maior começando de "A1" (deve ser a célula ativa); Crie nova regra de formatação condicional baseada em fórmula e acrescente: "=E($F1="Ok";A1<>"")" (sem aspas). Formate como quiser.

    Pronto! Sempre que todas as células da mesma linha coincidirem com o respectivo valor na linha 15 excluindo-se o zero a formatação na linha será aplicada.

    Conseguiu entender?


    Filipe Magno

    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    terça-feira, 19 de abril de 2016 02:42
  • Bom Dia Felipe Magno

    Antes de mais nada gostaria de agradecer por ajudar e desculpe não retornar antes, está fórmula, a 1ª da o seguinte erro, #VALOR!, é normal isso?

    Grato

    MauroMeira


    • Editado MauroMeira quarta-feira, 20 de abril de 2016 12:00 erro
    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    quarta-feira, 20 de abril de 2016 11:59
  • Bom dia Mauro.

    Isso irá acontecer se você não inserir a fórmula como matricial. Para funcionar basta:

    • inserir a fórmula sem as chaves:

    =SE(E(($A1:$E1)=($A$15:$E$15));"Ok";"-")

    • Enquanto edita a célula pressione:

    Ctrl+Shift+Enter

    As chaves serão acrescentadas automaticamente.

    • Copie e cole nas demais células.

    Compreendeu?


    Filipe Magno

    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    quarta-feira, 20 de abril de 2016 12:03
  • Boa Tarde Filipe

    Entendi e deu certo, Obrigado mais uma Vez

    Abraço

    MauroMeira

    • Marcado como Resposta MauroMeira quarta-feira, 20 de abril de 2016 15:19
    quarta-feira, 20 de abril de 2016 15:19