none
Erro ao Executar um "Maintenance Plan" RRS feed

  • Pergunta

  • Galera, boa tarde!

    Estou com um problema, espero que vocês possam me ajudar:

    Estou criando algumas rotinas pelo Maintenance Plans do SQL Server 2008. Porém, que eu rodo o Plano, da erro, independentemente qual for. Um dos Planos que criei é de Backup Full das bases... Se eu rodar o Plano da errado, mas se eu rodar EXATAMENTE a query que está dentro do plano, funciona!

    Erro logado no Agent:

    03/13/2014 15:29:06,Backup Full.Subplan_1,Error,0,SERVERSQL,Backup Full.Subplan_1,(Job outcome),,The job failed.  The Job was invoked by User DOMINIO\administrator.  The last step to run was step 1 (Subplan_1).,00:00:00,0,0,,,,0

    03/13/2014 15:29:06,Backup Full.Subplan_1,Error,1,SERVERSQL,Backup Full.Subplan_1,Subplan_1,,Executed as user: DOMINIO\services.it. Microsoft (R) SQL Server Execute Package Utility  Version 10.0.1600.22 for 32-bit  Copyright (C) Microsoft Corp 1984-2005. All rights reserved.    The SQL Server Execute Package Utility requires Integration Services to be installed by one of these editions of SQL Server 2008: Standard<c/> Enterprise<c/> Developer<c/> or Evaluation. To install Integration Services<c/> run SQL Server Setup and select Integration Services.  The package execution failed.  The step failed.,00:00:00,0,0,,,,0"

    Eu fiz o mesmo procedimento em outros servers da minha rede e funciona.

    quinta-feira, 13 de março de 2014 18:47

Todas as Respostas

  • Qual a versão do SQL você esta utilizando? Express? 

    Tem o Integration instalado? Digo isso pela parte da mensagem de erro:

    " The SQL Server Execute Package Utility requires Integration Services to be installed by one of these editions of SQL Server 2008: Standard<c/> Enterprise<c/> Developer<c/> or Evaluation"

    quinta-feira, 13 de março de 2014 20:39
  • Bruno,

    Certo a query funciona então o problema não esta no código, mas sim no componente que faz uso do mesmo, neste caso, a mensagem de erro informa que o Integration Services não esta instalado, bem como, pode ser uma falta de permissão do usuário que esta executando o Maintenance Plan.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    • Sugerido como Resposta Durval Ramos segunda-feira, 17 de março de 2014 12:40
    sexta-feira, 14 de março de 2014 14:49
    Moderador
  • Senhores,

    Obrigado pelas respostas. O Integration realmente não está instalado, provavelmente é isso. Vou instalar após o expediente e posto o resultado pra vocês.

    Abraços!

    sexta-feira, 14 de março de 2014 16:22