none
Regedit /S RRS feed

  • Pergunta

  • Srs.

    Alguém sabe me informar como faço para executar um arquivo .reg em modo silent. Primeiro quero explicar algumas coisas. Estou com windows 7 professional e não quero desabilitar o UAC. Sei que pela rede consigo consigo efetuar o seguinte comando sem aparece o prompt de confirmação.

    psesexec \\maquina_remota cmd
    regedit.exe /S \\servidor\compartilhamento\arquivo.reg 

    ou seja, se eu executar este comando remotamente através do console c:\psexec e conectar no prompt da máquina remota, o modo silente funciona corretamente.

    Já se eu executar a reg localmente apresenta o prompt de confirmação mesmo inserindo a flag /S

    ex: regedit.exe /S "arquivo.reg"

    Alguém sabe como suprimir o prompt de confirmação mesmo com o mecanismo UAC habilitado ?


    Richard Farias | INFO EVERY DAY

    segunda-feira, 30 de setembro de 2013 13:42

Respostas

  • Está no modo Padrão, e o seu?

    Com outro reg, direcionado a outra chave, ainda pede a confirmação? Se não:

    Verifique as permissões na chave que você está tentando incluir o valor. caso não haja uma permissão setada que permita, inclua o attrib na lista de comandos que você está executando, antes da linha de inclusão do .reg.

    Se com outra chave funcinou, não pediu confirmação, edite seu .reg e veja se não há alguma sequencia que force a confirmação, ou que cancele a flag /s.


    Fabrício G. Wagomacker Rocha Adm. de Rede e Servidores da Verde Brasil Imp. e Exp. de Madeiras

    • Marcado como Resposta Richard Farias quarta-feira, 2 de outubro de 2013 19:02
    terça-feira, 1 de outubro de 2013 14:38

Todas as Respostas

  • Acontece que para executar o psexec em qualquer computador, você já o inicia como administrador, é por isso que você conseguirá executar o comando sem necessitar "pedir" uma permissão para a conta Administrador, afinal você já está como Administrador. Já no PC local é diferente, se você não estiver logado como Adm, o UAC vai forçar ele a pedir permissão de Administrador.

    Tente com o runas. será solicitado confirmação apenas na primeira vez que o comando for utilizado. Apesar que pela sua necessidade, você necessitará só uma vez... ficaria assim:

    runas /user:DOMINIO\Administrador /Savecred "regedit.exe /s arquivo.reg"

    Abraços.


    Fabrício G. Wagomacker Rocha Adm. de Rede e Servidores da Verde Brasil Imp. e Exp. de Madeiras

    segunda-feira, 30 de setembro de 2013 20:15
  • Fabrício,

    Não é bem isto .....Acontece que mesmo logado interativamente como administrador e o UAC habilitado, ao executar uma reg o mesmo pede confirmação se SIM ou NÃO enão pede elevação .... é uma tela de confirmação de gravação no registro só isto. Acontece que acessando via psexec no console CLI este process não é solicitado, já interativamente ele pedi sim, e mesmo inserindo a flag /S a tela de confirmação é apresentada.

    obrigado !


    Richard Farias | INFO EVERY DAY

    terça-feira, 1 de outubro de 2013 13:54
  • Ah sim... havia entendido que o prompt era relativo a elevação de permissão... Eu fiz os testes aqui na mesma maneira que seu comando, e a confirmação foi suprimida... Qual o endereço da chave no registro? as vezes pode ser a permissão de escrita na Hive.

    Fabrício G. Wagomacker Rocha Adm. de Rede e Servidores da Verde Brasil Imp. e Exp. de Madeiras

    terça-feira, 1 de outubro de 2013 14:01
  • Sim, a hive é HKLM.

    Mas no seu caso o UAC habilitado ? se sim, em que nível está ?


    Richard Farias | INFO EVERY DAY


    • Editado Richard Farias terça-feira, 1 de outubro de 2013 14:17 reformulação
    terça-feira, 1 de outubro de 2013 14:04
  • Está no modo Padrão, e o seu?

    Com outro reg, direcionado a outra chave, ainda pede a confirmação? Se não:

    Verifique as permissões na chave que você está tentando incluir o valor. caso não haja uma permissão setada que permita, inclua o attrib na lista de comandos que você está executando, antes da linha de inclusão do .reg.

    Se com outra chave funcinou, não pediu confirmação, edite seu .reg e veja se não há alguma sequencia que force a confirmação, ou que cancele a flag /s.


    Fabrício G. Wagomacker Rocha Adm. de Rede e Servidores da Verde Brasil Imp. e Exp. de Madeiras

    • Marcado como Resposta Richard Farias quarta-feira, 2 de outubro de 2013 19:02
    terça-feira, 1 de outubro de 2013 14:38
  • Fabrício,

    O UAC está no modo padrão também.
    Fizemos um teste em rede e realmente a flag /S suprimiu o prompt de confirmação. Está funconando corretamente. Houve um equivo por minha parte, na verdade este problema foi passado por um analista que trabalhar comigo e não tive tempo de acompanhar, apenas acreditei nele. rs rs rs.

     


    obrigado a Todos do fórum.


    Richard Farias | INFO EVERY DAY

    quarta-feira, 2 de outubro de 2013 19:02
  • Maaaaaaaaaaaaalandro! Esqueceu de colocar a flag e fez nós ficar batendo cabeça a toa aki rsrs... Tudo de bom!

    Fabrício G. Wagomacker Rocha Adm. de Rede e Servidores da Verde Brasil Imp. e Exp. de Madeiras

    quarta-feira, 2 de outubro de 2013 19:16