none
Mundando o conteudo para outra WebApplication e Erro "Page Cannot be found" RRS feed

  • Pergunta

  • Ola!
    Eu estou com um probelma. O Moss estava funcionando bem, até eu desistalar o visual studio na maquina q ele esta instalado. Porém após eu fazer isso, alguns sites importante sairam do ar dando a menssagem :"The page cannot be  found". porém quando crio um novo site collection ele funciona normalmente. Ja rodei o assistente do sharepoint e não resolve. Nem a página do Shared Services esta funcionando. Gostaria de saber o motivo desse erro.
    Eu pensei em criar um novo site collection e apontar para a database dos sites q sairam do ar, mas não sei como se faz isso.
    Alguém poderia me ajudar a resolver esse probelma...?? estou urgentimente precisando desses sites

    Abraços!
    Eduardo REis
    terça-feira, 26 de maio de 2009 20:03

Respostas

  • Em primeiro lugar e necessario manter a calma.
    • Como capitão do barco que és, sabes que o conteudo encontra-se na Base de dados, logo o primeiro passo a realizar será o backup das Base de dados "wss_content..." via SQL server.
    • Segundo, seria pegar no teu manual de Crash e verificar um conjunto de tarefas detalhadas para validar o estado do teu sharepoint.
    • Abrir o IIS e verificar as application Pool e sites e verificar se estao run.
    • Verificar o Identify e associar a conta do dominio que foi instalado o sharepoint.
    • Verificar os serviços de Sharepoint se estão a correr.
    • Verificar se existe desenvolvimentos e se existem a referencia a eles.
    • Verificar se nao foi removido na gac alguma dll com a desinstalação e referencia existente no web.config do site
    • Verificar se existe espaço em disco rigido.
    • Verificar se nao foi alterada nenhuma conta de administrador password incluida.
    • Com o site a dar erro, aceder a pagina de Administraçao do SharePoint e realizar a expançao do site para uma nova Web application e verificar se o site voltou
    • Central Administration > Application Management > Create or Extend Web Application > Extend Web application to another IIS Web Site, selecionar o site em erro e criar nova extençao, se existir funcionalidades devera ser adicionadas no WebConfig.
    • Aceder no IIS ao application pool/sites do shared services e verificar a conta associada a Shared Services e verificar se encontra a correr.
    • Aceder ao Event Viewer e verificar os erros que este retorna, o mesmo com a pasta " C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS", validar e pesquisar os erros.
    • Caso este nao retorne, criar temporariamente uma nova Shared Services e defenir como default, enquanto tentas recuperar o shared Services.
    • Em ultimo caso, so mesmo em ultimo caso, criar um nova Web application via pagina de adminstraçao, aceder a Central Administration> Application Management > Content Database Remover Content Database e adicionar a linha "stsadm -o addcontentdb -url http//[URL] -databasename WSS_content" da base de dados a recuperar.
    Isto sao dicas, segue as que considerares as mais adequadas e que consigas recuperar, o mais importante e teres sempre o backup das Base de dados.
    Boa sorte, cumprimentos.

    André Lage Microsoft SharePoint and CRM Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/
    • Marcado como Resposta Richard Juhasz sexta-feira, 18 de novembro de 2011 18:56
    terça-feira, 26 de maio de 2009 22:15
    Moderador