none
Após a instalação do Dynamics CRM 4.0, tento abrir o console e a página fica em branco RRS feed

  • Pergunta

  • Boa tarde a todos,
    Fiz a instalação do CRM 4.0 em nosso servidor sem problemas, porém ao tentar acessar o console de administração (http://localhost), a página do IE fica em branco e não aparece nada.
    Já fiz a instalação em um Server 2003 e 2008, porém o problema persiste, alguém saberia informar o que pode ser?
    Agradeço a todos pelo suporte.
    Abraços,

    segunda-feira, 26 de julho de 2010 18:33

Respostas

  • Bom Dia Amigos,

     

    Entre varios problemas que ja tive ou que ouvi relatos, esse parecia não haver outras referencias iguais. Tive um problema identico ao Instalar o CRM 4 em um Windows Server 2008 com IIS 7, em outras instalações nunca tive problema de autenticação de usuários.

    Depois de algumas pesquisas, acabei encontrando a Resolução em um "KB" da Microsoft criado para o CRM 3.0, por isso não achamos referencias de soluções para o problema ou ate de KB´s Microsoft quando pesquisamos esse erro para o CRM 4.

    Segue link do KB logo abaixo.

    http://support.microsoft.com/kb/917818

    Espero ter contribuido e ajudado.

    Cordialmente.

     

    Ewerton Castro  | MCTS - Dynamics CRM 4.0 |

    • Sugerido como Resposta Tarcisio Gambin quinta-feira, 7 de outubro de 2010 14:40
    • Marcado como Resposta RicardoAlves segunda-feira, 11 de outubro de 2010 18:41
    quinta-feira, 7 de outubro de 2010 14:04

Todas as Respostas

  • HRESTOM,

     

    Não entendi muito bem o seu problema, poderia dar mais algum detalhe?

    O console de administração que você diz, seria o IIS Manager? Ou o CRM?

     

    Abraço,

     


    Ricardo Alves
    ricardoalves.me
    segunda-feira, 26 de julho de 2010 19:07
  • Fala Ricardo tudo bem?

    O "Console de administração" seria a tela principal do Dynamics. Após a instalação tentei acessar o sistema através do IE mas não aparece nada.

    Desculpa a minha ignorancia, é o meu primeiro contato esta ferramenta hehehe.

    Abraços e obrigado pelo suporte,

    HUGO RESTOM

    segunda-feira, 26 de julho de 2010 21:50
  • Opá,

     

    Que nada... primeiro, você lembra se na instalação você não colocou o acesso por uma porta especifica?

     

    Normalmente colocamos na 5555... ficando http://localhost:5555.

     

    Abraço,

     


    Ricardo Alves
    ricardoalves.me
    segunda-feira, 26 de julho de 2010 21:56
  • Boa dia Ricardo,

    Fiz o teste e aparece a mensagem de erro abaixo:

    Invalid User Authorization
    The user authentication passed to the platform is not valid.

    Uma dúvida, na última opção de instalação "E-mail router server name", eu digitei o nome de nosso servidor Exchange e não uma conta de e-mail de nosso domínio, é correto né?

    Abraços e obrigado pelo help.

    HUGO RESTOM

    terça-feira, 27 de julho de 2010 14:37
  • Ok Hugo,

     

    Sobre o email router está correto, é o nome do servidor Exchange.

     

    Você instalou os rollups? Senão, instale nesta ordem e reinicie o servidor:

    rollup 7

    http://www.microsoft.com/downloads/details.aspx?FamilyID=A4893988-7804-4E23-AB58-740441CC696E&displaylang=ja&displaylang=en

     

    rollup 11

    http://www.microsoft.com/downloads/details.aspx?FamilyID=f84f2bfb-393d-4b90-bf1b-300a82ec6083&displaylang=en

     

    Abraço,

     


    Ricardo Alves
    ricardoalves.me
    terça-feira, 27 de julho de 2010 16:50
  • Ricardo boa tarde,

    Baixei o rollup 7 e tentei atualiza-lo e dá o seguinte erro:

    "Falha na ação Microsoft.CRM.UpdateWrapper.DBUpdateAction.
    Object reference not set to an instance of an object."

    Para efetuar a instalação do Dynamics CRM, fiz os seguintes steps:
    - Instalação do Server 2008 R2
    - Habilitar a feature de Index Services
    - Instalação do IIS Manager
    - Instalação do SQL Server 2008
    - Instalação do Dynamics CRM (DynamicsCRMServer_1046_i386.exe de 39Mb), até este ponto não houve nenhuma falha na instalação.
    - Atualização Rollup 7 (CRMv4.0-KB971782-i386-Server-PTB.exe de 16Mb (aonde ocorre o erro informado acima.

    Abraços e obrigado,

    HUGO RESTOM

    terça-feira, 27 de julho de 2010 20:00
  • Estranho...

     

    O suporte da Microsoft, indica instalar o rollup 7, mesmo tendo uma versão mais nova (sendo que, segundo eles os pacotes são acumulativos).

     

    Então Hugo, tente instalar o rollup 11 e reinicie o servidor...

     

    Abraço,

     

     


    Ricardo Alves
    ricardoalves.me
    terça-feira, 27 de julho de 2010 20:20
  • Fala Ricardo, tudo bem?

    Agora deu o erro: "HTTP Error 401.2 - Unauthorized: Access is denied", Acho que já estamos quase lá hehehe.

    Para executar o serviço do CRM estou utilizando o Network Services, e já dei permissão no IIS para este usuário, como modify, oque poderia ser?

    Abraços


    HUGO RESTOM

    terça-feira, 27 de julho de 2010 21:09
  • rsrs...

     

    Na instalação, você teve que indicar um usuário do AD para ser administrador do CRM... Tente se logar com ele...

     


    Ricardo Alves
    ricardoalves.me
    terça-feira, 27 de julho de 2010 21:15
  • Ricardo bom dia,

    Criei um usuário em nosso AD como ServerAdmin chamado _crm. Voltei o snapshot da máquina (Trabalhamos com VM), e refiz a instalação do Dynamics com a seguintes configurações:

    Organization name: TESTE
    Organization display name: TESTE
    Organization base currency: Real (BRL - R$)
    Server Role: Full Server Installation
    License type: Trial License
    Installation directory: d:\Program Files\Microsoft Dynamics CRM
    Web site: Setup will create the Web site Microsoft Dynamics CRM ( :5555:)
    Reporting Services Report Server: Setup will connect to the existing Reporting Services Report Server
    http://SERVERCRM/ReportServer
    SQL Server: SERVERCRM
    SQL Server collation: Latin1_General_CI_AI
    Organizational unit: CRM (OU=CRM,OU=Security,OU=Groups,DC=DOMAIN,DC=com)
    Security account for Microsoft Dynamics CRM services: DOMAIN\_crm
    Security account for the ASP.NET service: DOMAIN\_crm
    Incoming Microsoft Dynamics CRM E-mail Router server: EXCHANGE.DOMAIN.COM.BR

    Após a instalação, reiniciei o servidor e instalei o rollup 11, reiniciei novamente o servidor. E ao seu retorno, fiz um teste acessando http://localhost:5555 e aparece o seguinte erro:

    HTTP Error 401.2 - Unauthorized
    You are not authorized to view this page due to invalid authentication headers.

    Detailed Error Information
    Module IIS Web Core
    Notification AuthenticateRequest
    Handler PageHandlerFactory-ISAPI-2.0
    Error Code 0x80070005

    Requested URL http://sszscrm01:5555/default.aspx
    Physical Path C:\Program Files\Microsoft Dynamics CRM\CRMWeb\default.aspx
    Logon Method Not yet determined
    Logon User Not yet determined

    Achei um artigo na internet referente a este erro, que pede para fazer o seguinte procedimento abaixo, com a conta administrador do CRM (DOMAIN\_crm):

    setspn -a http/SiteName.DomainName.com Domain \User
    setspn -a http/SiteName:5555 Domain\User

    Cara já instalei várias soluções Microsoft, mas essa está sendo a pior de todas hehehe.

    Aguardeço novamente pela ajuda, abraços

    HUGO RESTOM

    quarta-feira, 28 de julho de 2010 13:00
  • Eu também vi... neste forum:

    http://social.microsoft.com/Forums/en-US/crmdeployment/thread/c1f0665f-756c-4f49-bb5c-14de979adbfb

     

    Acho que não custa nada tentar...

     


    Ricardo Alves
    ricardoalves.me
    quarta-feira, 28 de julho de 2010 14:30
  • Olá Hugo, alguma novidade?

     

    Abraço,


    Ricardo Alves
    ricardoalves.me
    quarta-feira, 28 de julho de 2010 21:10
  • Fala Ricardo tudo bem contigo?

    Acabei me enrolando com outras tarefas e não consegui testar. Na verdade estou criando uma nova VM com 2003 para ver se funcionará na outra versão.

    Até amanhã atarde lhe darei um retorno.

    Obrigado pelo suporte e pelo interesse em me ajudar, abraços

     

    HUGO RESTOM

    quinta-feira, 29 de julho de 2010 11:53
  • Olá Hugo, tudo bem?

     

    Apenas para complementar o help do Ricardo, como best practice (não sei se voce já está fazendo desta forma), tente realizar a instalação do CRM com a opção de atualização de arquivos online, do qual ele faz a atualização de alguns arquivos do setup.

    E também de instalar utilizando uma conta de administrador de domínio, embora isto não seja recomendado no quesito segurança, porém assegura que todos os requisitos necessários, como criação de grupos de usuário do CRM no AD, admin do SQL, IIS e admin local do servidor do CRM sejam atendidos.

     

    Quando puder, favor postar alguma novidade!

    Grande abraço,


    Tarcísio Gambin | MCP, MCBMSS
    "O conhecimento é livre. Compartilhe você também!"
    quinta-feira, 5 de agosto de 2010 17:37
  • Tarcísio/Ricardo boa tarde, tudo bem?

    Primeiramente gostaria de agradecer a ajuda e o empenho de vocês na solução do problema.

    Recriei o servidor com Server 2003 R2 e instalei todos os pré-requisitos necessários. Preenchi todas as informações necessárias para instalação, e após a checagem dos requisitos antes da instalação, ocorre um erro no seguinte item:

    Microsoft CRM Server user Input: Verify Domain User account SPN for the Microsoft Dynamics CRM ASP.NET Application Pool account.

     

    Antes este problema não acontecia por que eu selecionava o NETWORK SERVICE para autenticação do serviço, porém agora estou utilizando um usuário do AD. Este usuário do AD é Server Admin e também possui permissão full no IIS.

     

    Achei alguns artigos na net que pedem para configuar o SPN, eu também já fiz isso através dos comandos:

    setspn -a http/SiteName.DomainName.com Domain\User

    setspn -a http/SiteName Domain\User

    setspn -a http/SiteName:555 Domain\User

    setspn -a http/SiteName.DomainName.com:555 Domain\User

     

    Na documentação também mostra como configurar o SPN pelo Support Tools do 2003, etapa 2 da documentação de instalação, vide instruções:

    Etapa 2: Configurar o Active Directory

    Configure o Active Directory criando uma conta para executar o serviço de CRMAppPool e use um SPN (Nome Principal de Serviço). Isso será necessário caso os Serviços de Informações da Internet (IIS) 6.0 sejam executados em um ambiente de cluster ou de balanceamento de carga de rede. O SPN identifica com exclusividade uma instância de um serviço em execução. O Active Directory usa o SPN para realizar autenticação mútua de uma instância de serviço, o que permite que a instância do serviço autentique corretamente quando acessa recursos localizados em outros computadores do membro de domínio. Para obter mais informações, consulte o artigo do MSDN Nomes Principais de Serviço (em inglês).

    Para criar SPNs é necessário instalar as seguintes ferramentas, as quais integram as ferramentas de suporte do Windows localizadas na pasta Support\Tools do CD do Windows Server 2003:

    ·         adsiedit.msc. Esta ferramenta snap-in do Console de Gerenciamento Microsoft (MMC) pode ser usada para inserir valores de SPN em um computador específico ou uma conta de usuário. Essa ferramenta requer o arquivo adsiedit.dll.

    ·         search.vbs. Esse script é usado para determinar se o valor SPN é usado em algum outro local.

    Para configurar o SPN, siga estas etapas.

    1.  Abra Usuários e Computadores do Active Directory.

    2. Crie uma conta de usuário para executar a ferramenta de aplicativo CRMAppPool no IIS. Para isso, recomendamos a utilização de um nome que descreva a finalidade da conta, como CRMService.

     

    Importante   Essa conta de usuário deve ser membro do grupo Usuários do Domínio.

     

    3. Feche Usuários e Computadores do Active Directory.

    4. Abra o Windows Explorer e localize a pasta Arquivos de Programas\Ferramentas de Suporte.

    5. Clique duas vezes em adsiedit.msc.

    6. Expanda o domínio, expanda o nó que começa com DC= e, em seguida, expanda CN=Users.

    7. Clique com o botão direito do mouse na conta de usuário criada na etapa anterior, como CRMService, e depois clique em Propriedades.

    8. Na lista Atributos, role para baixo, selecione servicePrincipalName e clique em Editar.

    9. Na caixa de diálogo Valor a ser adicionado, digite HOST/CRMNLBName.FQDN e clique em Adicionar. Onde CRMNLBName é o nome do cluster de NLB e FQDN é o nome de domínio totalmente qualificado. Por exemplo, o nome CRMNLBName.FQDN pode ser CRMNLBCluster.contoso.com.

     

     

    Não sei mais oque fazer, todas as configurações já foram feitas, se tiverem alguma idéia me avisem por favor.

    Obrigado e abraços,

     

    HUGO RESTOM

    quarta-feira, 11 de agosto de 2010 21:14
  • Olá Hugo!

     

    Este é realmente um problema "daqueles" né?

    Pelo que parece há algum problema de permissão/autenticação entre o AD e o IIS.

    Sobre os requisitos mínimos, tanto de hardware como de software, aconselho o download do Implementation Guide do CRM 4, disponível em Portugues. No arquivo Microsoft_Dynamics_CRM_IG_Planejamento.doc, vá até a página 3-22, onde voce poderá encontrar informações atualizadas sobre os requisitos de software do CRM.

    Sobre os comandos que voce comentou, certifique-se que as portas utilizadas estão corretas (ou voce utilizou as portas 555, ao invés de 5555?).

    Sobre sua última instalação, se voce a fizer com usuário de domínio para inicialização de serviços, ela chega a concluir? Se não, instale com o network services mesmo e copie o log de instalação neste thread para que possamos verificar se há algum erro (geralmente o log fica em C:\Documents and Settings\USUARIO\Application Data\Microsoft\MSCRM\Logs\).

    Há também casos (um pouco mais extremos) em que as mídias podem estar com problemas, como em um dos threads do fórum, onde o problema de instalação do CRM foi resolvido com a troca da mídia do CRM.

     

    Quando puder, favor postar o resultado pra gente!

    Grande abraço,


    Tarcísio Gambin | MCP, MCBMSS
    "O conhecimento é livre. Compartilhe você também!"
    quinta-feira, 12 de agosto de 2010 04:58
  • Olá Hugo,

     

    Alguma novidade?

     

    Abraço,

     


    Ricardo Alves
    www.ricardoalves.me

    Se for útil, por favor marque ;)
    sábado, 21 de agosto de 2010 14:46
  • Bom Dia Amigos,

     

    Entre varios problemas que ja tive ou que ouvi relatos, esse parecia não haver outras referencias iguais. Tive um problema identico ao Instalar o CRM 4 em um Windows Server 2008 com IIS 7, em outras instalações nunca tive problema de autenticação de usuários.

    Depois de algumas pesquisas, acabei encontrando a Resolução em um "KB" da Microsoft criado para o CRM 3.0, por isso não achamos referencias de soluções para o problema ou ate de KB´s Microsoft quando pesquisamos esse erro para o CRM 4.

    Segue link do KB logo abaixo.

    http://support.microsoft.com/kb/917818

    Espero ter contribuido e ajudado.

    Cordialmente.

     

    Ewerton Castro  | MCTS - Dynamics CRM 4.0 |

    • Sugerido como Resposta Tarcisio Gambin quinta-feira, 7 de outubro de 2010 14:40
    • Marcado como Resposta RicardoAlves segunda-feira, 11 de outubro de 2010 18:41
    quinta-feira, 7 de outubro de 2010 14:04