none
Problema em abrir programa Erro: Access Violation RRS feed

  • Pergunta

  • Tem um programa de uma empresa que esta instalado no servidor onde 3 estações abrem o programa, cada estação tem um BDE, tudo funcionando até que um dia o servidor mais duas estações geram um erro (Exception EAccessViolation in module AFABAN1.exe at 0009633E. Access violation at address 0049633E in module 'AFABAN1.exe. Read of address 60000010.

    O estranho é que em modo de segurança com rede ele funciona, já entrei no msconfig e desabilitei todos os programas, e nada, já procurei vírus (nada), desinstalei o antivírus (nada), fiz limpeza de disco (nada), salvei a configuração do bde da maquina que ta funcionando e passei para que não estava e nada. To ficando sem ideia, o programa esta funcionando, funciona porem só funciona em modo de segurança.

    Alguém pode ajudar?

    OBS: O SO é Windows XP SP3


    André de Oliveira Cunha Bueno
    sexta-feira, 18 de março de 2011 02:06

Respostas

  • Um deles era a configuração do BDE, ai tudo bem, porem o outro que esta me deixando encucado, eu fiquei horas fazendo varias coisas, até que entre no msconfig removi a seleção de todos os serviços, reiniciei e o programa funcionou, procurando que serviço estava impedindo o software de abrir descobri que era o Spool de impressão, depois descobri ainda que o programa funcionava normalmente, apenas não precisava deixar a impressora local como padrão, pensei em fazer um script que iria para o spooler, abrir o programa a iniciar novamente, porem tem alguma outra solução sem script e sem trocar a impressora?


    André de Oliveira Cunha Bueno
    Vamos trabalhar com o ambiente Quase-ideal se a voce ficar fazendo ajuste-técnico para o que não esta funcionando funcionar de uma forma menos pior, isso pode se prolongar mais do que se voce se dedicar a deixar o ambiente como padrão em todas as máquinas pois imagina, voce terá que criar um procedimento pra uma máquina que funciona adaptar para máquina que funcionar +/- e por a vai.
    Post aqui o erro que da no Spool ou mesmo no processo que fica de certa forma Dependente do Spool Vamos trabalhar nele e verificar o que esta acontecendo.
    Remova todos os drivers desnecessários, depois poste aqui o resultado.
    att

    Microsoft Certified Professional - Windows 2003 Server
    • Marcado como Resposta Richard Juhasz segunda-feira, 4 de abril de 2011 19:09
    segunda-feira, 28 de março de 2011 17:31

Todas as Respostas

  • Olá André,

     

    você fez alguma atualização recente no servidor? como service pack ?se fez alguma atualização reverta as mesmas e volte a testa,pode estar havendo conflito.

    abs

    sexta-feira, 18 de março de 2011 11:24
    Moderador
  • Olá André,

     

    você fez alguma atualização recente no servidor? como service pack ?se fez alguma atualização reverta as mesmas e volte a testa,pode estar havendo conflito.

    abs

    Verifique se a base do bde esta integra, depois se tudo tiver ok.

    reinstale o BDE administrator.

    eu tive um problema similar com um usuário que nao me perguntem o porque ele corrompia uma tabela X do banco de dados depois de alguns horas logado.

    eu tive que recriar o usuário do cara e fazer a reinstalação do driver de acesso.

     


    Microsoft Certified Professional - Windows 2003 Server
    • Sugerido como Resposta Ton Merlot sexta-feira, 18 de março de 2011 13:32
    sexta-feira, 18 de março de 2011 13:32
  • Um deles era a configuração do BDE, ai tudo bem, porem o outro que esta me deixando encucado, eu fiquei horas fazendo varias coisas, até que entre no msconfig removi a seleção de todos os serviços, reiniciei e o programa funcionou, procurando que serviço estava impedindo o software de abrir descobri que era o Spool de impressão, depois descobri ainda que o programa funcionava normalmente, apenas não precisava deixar a impressora local como padrão, pensei em fazer um script que iria para o spooler, abrir o programa a iniciar novamente, porem tem alguma outra solução sem script e sem trocar a impressora?


    André de Oliveira Cunha Bueno
    sexta-feira, 18 de março de 2011 21:08
  • Um deles era a configuração do BDE, ai tudo bem, porem o outro que esta me deixando encucado, eu fiquei horas fazendo varias coisas, até que entre no msconfig removi a seleção de todos os serviços, reiniciei e o programa funcionou, procurando que serviço estava impedindo o software de abrir descobri que era o Spool de impressão, depois descobri ainda que o programa funcionava normalmente, apenas não precisava deixar a impressora local como padrão, pensei em fazer um script que iria para o spooler, abrir o programa a iniciar novamente, porem tem alguma outra solução sem script e sem trocar a impressora?


    André de Oliveira Cunha Bueno
    Vamos trabalhar com o ambiente Quase-ideal se a voce ficar fazendo ajuste-técnico para o que não esta funcionando funcionar de uma forma menos pior, isso pode se prolongar mais do que se voce se dedicar a deixar o ambiente como padrão em todas as máquinas pois imagina, voce terá que criar um procedimento pra uma máquina que funciona adaptar para máquina que funcionar +/- e por a vai.
    Post aqui o erro que da no Spool ou mesmo no processo que fica de certa forma Dependente do Spool Vamos trabalhar nele e verificar o que esta acontecendo.
    Remova todos os drivers desnecessários, depois poste aqui o resultado.
    att

    Microsoft Certified Professional - Windows 2003 Server
    • Marcado como Resposta Richard Juhasz segunda-feira, 4 de abril de 2011 19:09
    segunda-feira, 28 de março de 2011 17:31