none
Configurar Switchs para Duas internets com ips distintos RRS feed

  • Pergunta

  • Pessoa boa tarde! Gostaria de uma ajuda nesse tópico, avalie o seguinte cenário:
    Possuo dois Switchs gerenciáveis 
    1º HP Aruba 2920-48G-POE+
    2º HP JG977A

    O 1º Switch está em uma sala, onde tenho um firewall físico (PFsense) que recebe internet de uma operadora com IP Fixo.

    O 2º Switch está em outra sala, onde está instalado fisicamente o modem de outra operadora (GVT) de internet com IP Fixo também.

    O 2º Switch está ligado por um cabo diretamente ao 1º Switch e se comunicam normalmente; o que ocorre é que preciso fazer com que meu Firewall e 1º encontrem o modem da outra operadora (GVT), sei onde estão conectadas as portas devidamente, e que teria de criar uma VLAN pra isso, mas, meu conhecimento é pouco nessa parte, alguém poderia me ajudar nisso? Grato!

    terça-feira, 12 de fevereiro de 2019 21:02

Todas as Respostas

  • Bom dia,

    Você poderia criar uma Vlan no Switch 2 com duas portas sento 1 para o Link vindo do modem e outra para o Switch 1(O Switch 1 pode ter uma Vlan para tratar este link e alimentar no Firewall ou entrar direto no Firewall Pfsense em uma interface).

    Após definir estas configurações você precisara de uma porta ligando os 2 Switch(assim terá comunicação entre os Switchs e o firewall controlara seus 2 links).

    • Sugerido como Resposta Pedro Belliato segunda-feira, 8 de abril de 2019 19:47
    segunda-feira, 18 de fevereiro de 2019 14:04
  • Bom dia,

    Você poderia criar uma Vlan no Switch 2 com duas portas sento 1 para o Link vindo do modem e outra para o Switch 1(O Switch 1 pode ter uma Vlan para tratar este link e alimentar no Firewall ou entrar direto no Firewall Pfsense em uma interface).

    Após definir estas configurações você precisara de uma porta ligando os 2 Switch(assim terá comunicação entre os Switchs e o firewall controlara seus 2 links).

    Bom dia Pedro, fico muito agradecido pela resposta, queria te dizer que essas Vlans já estão configuradas, porém houve um problema no Siwitch Principal o 1º o que fez com que ele fosse substituido pela HP, no momento do problema eu coloquei um switch comum para a empresa não ficar sem rede, porém não me atentei ao posicionamento dos cabos, coloquei a configuração das Vlans novamente e consigo encontrar o Modem da GVT normalmente, porém quando eu no meu Firewall coloco a internet para trafegar pela Interface da GVT a loja fica simplesmente sem internet, inclusive no Firewall me mostra a internet no ar e pingando par a o Ip 8.8.8.8 normalmente, vou colocar abaixo o config do 1º Switch e se houver algo a me dizer eu ficaria grato.

      ip address dhcp-bootp
       member 1
          ip address dhcp-bootp
          exit
       exit
    vlan 1
       name "DEFAULT_VLAN"
       no untagged 1/13,1/18
       untagged 1/1-1/12,1/14-1/17,1/19-1/48
       ip address 192.168.0.20 255.255.255.0
       exit
    vlan 15
       name "GVT"
       tagged 1/1,1/14
       no ip address
       exit
    vlan 101
       name "Caixas"
       tagged 1/1,1/8,1/12
       ip address 192.168.101.20 255.255.255.0
       exit
    vlan 102
       name "Setores"
       tagged 1/1,1/8,1/12,1/14
       ip address 192.168.102.20 255.255.255.0
       exit
    vlan 103
       name "WIFI"
       tagged 1/1,1/8,1/12
       no ip address
       exit
    vlan 104
       name "TI"
       untagged 1/13,1/18
       tagged 1/1,1/12,1/14
       ip address 192.168.104.20 255.255.255.0
       exit
    spanning-tree
    no tftp server
    no autorun
    no dhcp config-file-update
    no dhcp image-file-update

    terça-feira, 19 de fevereiro de 2019 19:00
  • Boa tarde Diogo,

    Pode ser alguma configuração de rotas no seu firewall(Pfsense), faça o teste defina este link como seu Gateway padrão e tente realizar a navegação através do seus hosts.

    Em algum host da sua rede execute um tracert site_desejado e veja se esta saindo pelo link definido. 

    terça-feira, 19 de fevereiro de 2019 20:42
  • Boa tarde Pedro! Fiz o que me pedistes, e aparentemente está ok, testei para o site da google.

    Tá difícil aqui, de qualquer forma quando eu altero no PFsense para a Wan2 ser a principal, a latência fica enorme e a internet para de funcionar. 

    quarta-feira, 20 de fevereiro de 2019 17:53
  • Diogo,

    Você executou o tracert direto do seu firewall? na imagem o mesmo esta saindo corretamente pelo gw 192.168.25.1(GVT), verifica direto de um host conectado no switch post aqui a saída, 

    tracert google.com e tracert 8.8.8.8 

    quinta-feira, 21 de fevereiro de 2019 21:05
  • Opa! Boa tarde! Pedro, sim eu fiz o tracert direto do Firewall, segue imagens de um host que está conectado diretamente no Switch 1º


    sexta-feira, 22 de fevereiro de 2019 17:16
  • Boa tarde Diogo,

    Pela imagem que postou esta saindo pelo link da GVT e está chegando no site do Google.

    Não tem nenhuma configuração de proxy ativo ou transparente ativado no seu firewall e apontado no navegador.



    sexta-feira, 22 de fevereiro de 2019 20:57
  • Boa tarde Diogo,

    Pela imagem que postou esta saindo pelo link da GVT e está chegando no site do Google.

    Não tem nenhuma configuração de proxy ativo ou transparente ativado no seu firewall e apontado no navegador.



    Não tem proxy transparente ativo, veja o que acontece quando eu mudo para a WAN2 GVT

    sábado, 23 de fevereiro de 2019 12:46
  • Diogo,

    ideal é abrir um chamado no fórum do pfsense, acho que conseguiram auxiliar melhor neste problema.

    https://forum.netgate.com/category/13/portuguese

    segunda-feira, 25 de fevereiro de 2019 18:32
  • Diogo,

    ideal é abrir um chamado no fórum do pfsense, acho que conseguiram auxiliar melhor neste problema.

    https://forum.netgate.com/category/13/portuguese

    Bom dia Pedro! Não me pergunte como, mas, eu reiniciei o roteador da GVT e tudo ficou funcionando, esqueci de postar aqui. Imagino que as configurações estejam todas OK, não houve mais problemas.
    quinta-feira, 28 de fevereiro de 2019 13:57