none
Conferir sequência de números RRS feed

  • Pergunta

  • Boa noite.

    Preciso de um fórmula que me dê o seguinte resultado:

    tenho uma sequencia de 5 números, um em cada célula.

    e tenho do outra lado 4 sequencias de números.

    preciso de uma formula que me diga em qual dos quatros blocos os cinco números se repetem ou se eles se repetem em mais de um bloco.

    Exemplo:

      na primeira linha os números se repetem no bloco 1 e no bloco 2

      na segunda linha os números se repetem no bloco 3 e no bloco 4

    1- 50 -43- 4- 5   1 2 3 4 5 6 7 8 9 10   1 2 3 4 5 6 7 8 9 10
    51- 11 -20- 59 -60   21 22 23 24 25 26 27 28 29 30   31 32 33 34 35 36 37 38 39 40
      41 42 43 44 45 46 47 48 49 50   41 42 43 44 45 46 47 48 49 50
      61 62 63 64 65 66 67 68 69 70   71 72 73 74 75 76 77 78 79 80

      11 12 13 14 15 16 17 18 19 20   11 12 13 14 15 16 17 18 19 20
      31 32 33 34 35 36 37 38 39 40   21 22 23 24 25 26 27 28 29 30
      51 52 53 54 55 56 57 58 59 60   51 52 53 54 55 56 57 58 59 60
      71 72 73 74 75 76 77 78 79 80   61 62 63 64 65 66 67 68 69 70







    segunda-feira, 24 de novembro de 2014 02:06

Todas as Respostas

  • Olá colega!

    Não consegui compreender a sua necessidade, pois não ficou claro com o exemplo que você deu.

    Quando você diz sequência 1, 2 ou 3 você está se referindo aos 4 blocos de números com 4 linhas em cada? Se sim, a ordem seria da esquerda para a direita:

    BLOCO1 BLOCO2

    BLOCO3 BLOCO4

    é isso?

    Porque se for isso, onde estão os 5 números (51-11-20-59-60) no bloco1 que você está citando no exemplo? E como estão arranjados os números na planilha?

    Estou confuso com sua questão. 


    Rafael Kamimura


    segunda-feira, 24 de novembro de 2014 10:49
  • Boa noite,

    Rafael Kamimura mofiquei a pergunta,

    realmente estou me referindo aos blocos.

    Quero apenas saber em qual dos blocos os cinco números se repetem, sem necessidade de ser na mesma sequência.

    domingo, 30 de novembro de 2014 23:28
  • Olá! Para realizar este tipo de análise de forma rápida, você pode utilizar uma fórmula matricial. Observe a imagem:

    Tente baixar o arquivo deste exemplo:

    https://drive.google.com/file/d/0B4utYM3AOedCMVJWbndXaUZvZFE/view?usp=sharing

    Você pode incrementar a fórmula com um SE para caso conte 5 apareça uma mensagem personalizada na célula, como por exemplo, OK.

    Exemplo:

    =SE(SOMA(SE(CONT.SE($K$3:$T$6;A3:E3)>0;1;0))=5;"OK";"NO")

    Este tipo de fórmula é matricial e só funciona corretamente se entrada com CRTL + SHIFT + ENTER.

    Abraços!


    Rafael Kamimura


    segunda-feira, 1 de dezembro de 2014 10:43