none
Substituir a fórmula por outra que apresente o mesmo resultado. RRS feed

  • Pergunta

  • Bom dia!

    Solicito a sua ajuda para resolver o problema.

    Como posso substituir essa fórmula,

    =SOMA(A15:A1048576) por outra que retorne o mesmo resultado.

    Grato - GENECI.

    sexta-feira, 30 de dezembro de 2016 11:15

Todas as Respostas

  • Olá Geneci!

    Tudo bem? Qual é o seu problema de fato? Poderia explicar melhor?

    Se você está utilizando todas as linhas da planilha, provavelmente não está fazendo a coisa da maneira mais eficiente.

    Se o problema é assegurar que a fórmula pegue todos os valores de uma coluna iniciando na linha 15, minha dica é converter o intervalo no formato de "Tabela" do Excel, disponível na aba "Inserir". Quando um intervalo está convertido em tabela, ele passa a ter um sistema de referência diferenciado para construir as fórmulas, que facilita muito o desenvolvimento. Eu escrevi algumas coisas sobre o tema há um tempo atrás no meu blog, acesse Entendendo a estrutura das fórmulas e veja no final do artigo algumas orientações de como trabalhar com elementos de tabela.

    Só como exemplo, suponha que a sua tabela se chame "tab_vendas" e a coluna A possui o título de cabeçalho de "Vendas", a fórmula de soma da coluna ficaria "=SOMA(tab_vendas[Vendas])". Neste caso você não precisa se preocupar em expandir a fórmula, pois cada linha inserida já é englobada na tabela.

    Abraços!


    Rafael Kamimura - http://excelmaniacos.com

    sexta-feira, 30 de dezembro de 2016 12:24
  • Bom dia! Rafael Kamimura

    Tudo bem?

    Obrigado por responder a minha solicitação.

    Agora tenho certeza que tenho a resposta que preciso.

    Consulto sempre http://excelmaniacos.com

    Vamos lá, quero somar todos os valores que estão contidos em determinada coluna após determinada célula.

    Exemplo: Quero somar todos os valores da coluna A após a célula A15, até a última célula da coluna A.

    Então vou usar a fórmula =SOMA(A15:A1048576)

    Existe algum método que eu possa substituir o intervalo final no caso A1048576 por um endereço que o excel entende que é para somar até o final da coluna A.

    Outra sugestão se você fosse somar o intervalo em questão, qual fórmula você usaria?

    E por fim posso fazer contato no seu e-mail.

    Grato - GENECI.

    sexta-feira, 30 de dezembro de 2016 13:00
  • Então,

    Sempre haverá formas de otimizar fórmulas.

    No seu caso, o ideal seria ver a planilha para sugerir o melhor caminho.

    Em geral, a melhor maneira de se trabalhar com dados em que não se sabe a ultima linha, é trabalhar com o recurso de tabela, pois com o intervalo de tabela a fórmula será sempre a mesma independente de quantas linhas tenham a tabela, ex: =SOMA(tabela1[Venda])

    Agora, há outras fórmas como utilizar a função INDIRETO, DESLOC, fórmulas matriciais, intervalos nomeados...

    Vou mostrar um método para definir o intervalo da coluna A partindo da linha 15 até a última linha com valor:

    1) Pressione CTRL+F3 para abrir o gerenciador de nomes.

    2) Clique em "novo" e em "Nome:" digite "Intervalo_Valores_Col_A" e no campo "Refere-se a:" cole a fórmula: =INDIRETO("A15:A"&MÁXIMO(SE(Plan1!$A:$A<>"";LIN(Plan1!$A:$A))))

    3) Confirme com OK.

    4) Agora, na célula onde deseja somar os valores de A, digite a formula: =SOMA(Intervalo_Valores_Col_A)

    Se quiser me encaminhe por email que tento ver melhor o seu cenário.

    Abraços!


    Rafael Kamimura - http://excelmaniacos.com

    • Sugerido como Resposta GENECIOFICIAL sábado, 31 de dezembro de 2016 15:21
    sexta-feira, 30 de dezembro de 2016 16:21
  • Boa tarde!

    Mais uma dentre várias dúvidas você conseguiu resolver.

    Muito obrigado.

    Feliz ano novo.

    Grato - Geneci

    sábado, 31 de dezembro de 2016 15:21