none
Simplesmente não inicia - Hyper-V Server 2012 RRS feed

  • Pergunta

  • Sinistro galera!!!

    Ambiente Resumido: Dell PE-T420 com Hyper-V Server 2012, ingressado em domínio. Aconteceu o seguinte: já tinha 01 VM funcionando sem problemas. Transferi uma VM de outro server. Só que essa nova VM não iniciou de forma alguma. Tentei de várias maneiras. Foi até reiniciar o servidor. Quando voltou, o serviço VMMS (Gerenciador de VMs, o prinicipal serviço) não iniciou. Dando a seguinte mensagem: O sistema não pode encontrar o arquivo especificado. Simplesmente do nada o principal serviço não inicia mais. Acho que vou ter que reinstalar o Hyper-V ou não né, depois desse susto. Sorte que o server ainda não estava em produção.

    Alguém já passou por isso? Alguém sabe o que pode ser?

    Valeu!!!


    .

    terça-feira, 14 de maio de 2013 22:55

Todas as Respostas

  • Juliano, é o hyper-v server 2012 mesmo, a versão gratuita, server core, correto? Qual erro foi apresentado quando você tentou iniciar esta VM pela primeira vez? Esta VM veio de outro servidor também com o hyper-v 2012, ou com o 2008?

    O serviço que você comentou que não inicia, é no host, na máquina física correto? Mesmo se as VMs forem configuradas para não iniciar automaticamente com o host, os serviços do hyper-v não são carregados corretamente?

    quarta-feira, 15 de maio de 2013 04:13
  • É tudo isso mesmo Ilberto.

    O erro quando não subia a VM não lembro exatamente, mas era porque o serviço Gerenciamento da Máquina Virtual do Hyper-V não estava funcionando. Quando tentava iniciar o serviço dava o Erro 2: O sistema não pode encontrar o arquivo especificado. Só que o arquivo correspondente ao serviço estava lá no local correto (C:\Windows\System32\vmms.exe). Estranho também, era que durante toda essas tentativas (antes de reiniciar o host), 01 VM estava funcionando normalmente. Ela não subiu após reiniciar o Host.

    Consegui resolver, ou melhor, contornar a situação, removendo a Feature Hyper-V e instalando-a novamente. Agora fica o mistério: O que será que causou isso?


    .

    quarta-feira, 15 de maio de 2013 13:11
  • O log de eventos do windows pode conter detalhes maiores sobre o que estava de fato ocorrendo...
    quarta-feira, 15 de maio de 2013 15:28
  • Qual antivírus você utiliza? Usou as recomendações de exclusão para Hyper-V?

    Segue o Link http://social.technet.microsoft.com/wiki/contents/articles/2179.hyper-v-anti-virus-exclusions-for-hyper-v-hosts.aspx

    Atenciosmente,

    KOLARIK


    Nelson Kolarik - Brasília - DF

    quarta-feira, 15 de maio de 2013 16:10
    Moderador
  • Sem Antivirus.

    Estava analisando os logs e vi que ao tentar reiniciar o serviço Gerenciamento de Máquinas Virtuais as seguintes mensagens foram registradas:

    Em Logs do Windows >> Sistema

    Evento 7023: O serviço Gerenciamento da Máquina Virtual do Hyper-V terminou com o erro: 
    O sistema não pode encontrar o arquivo especificado.

    Em Log de Aplicativos e Serviços >> Microsoft >> Hyper-V-VMMS

    Evento 17040: O repositório de autorização não pôde ser inicializado: 'msxml://C:\ProgramData\Microsoft\Windows\Hyper-V\InitialStore.xml'. Erro: O sistema não pode encontrar o arquivo especificado. (0x80070002).

    Provavelmente era algum problema com o arquivo InitialStore.xml. Como eu disse que removi a Feature do Hyper-V e a reinstalei, esse arquivo, com certeza, foi recriado e voltou a funcionar.

    quarta-feira, 15 de maio de 2013 18:06