none
Erro mudança de contexto sql server 2008 R2 RRS feed

  • Pergunta

  • Olá galera, alguém já se deparou com a mensagem de erro abaixo:

    Changed database context to 'my_database'.

    Agradeço desde já!

    quinta-feira, 22 de outubro de 2015 13:56

Respostas

  • Essa mensagem acontece no ODBC, e não está relacionada a permissão de acesso.

    Olha esse KB ele explica e orienta sobre o erro.

    KB 143339

    "

    Quando um aplicativo ODBC chama SQLError() depois de obter SQL_SUCCESS_WITH_INFO, ele deve esperar as seguintes mensagens: 
    1. Uma mensagem de 5701 mostrando SQL Server inicialmente colocar o contexto do usuário no banco de dados padrão definido no servidor para a identificação de logon usada na conexão.
    2. Uma mensagem 5703 mostrando o idioma que está sendo usado no servidor.
    3. Se a fonte de dados ODBC possui um banco de dados padrão especificado, ou se o aplicativo especificado no banco de dados = palavra-chave em SQLDriverConnect() ou SQLBrowseConnect(), então haverá um segundo 5701 mensagem mostrando o contexto do usuário sendo alternado para o banco de dados solicitado.

    "

    Full Connect:
    
          szSqlState = "01000", *pfNativeError = 5701,
          szErrorMsg="[Microsoft][ODBC SQL Server Driver][SQL Server]
                 Changed database context to 'master'."
          szSqlState = "01000", *pfNativeError = 5703,
          szErrorMsg="[Microsoft][ODBC SQL Server Driver][SQL Server]
                 Changed language setting to 'us_english'."
          szSqlState = "01000", *pfNativeError = 5701,
          szErrorMsg="[Microsoft][ODBC SQL Server Driver][SQL Server]
                 Changed database context to 'pubs'."
    
       Successfully connected to DSN 'ab60def'.


    Flávio Farias
    "May the Force be with you"
    Se foi resolvido clique "Marcar como resposta" e se foi útil "Votar como Útil"

    quinta-feira, 22 de outubro de 2015 14:45

Todas as Respostas

  • Jeferson,

    Em que momento você está vendo isso? Você está usando o SQLCMD?

    []'s!


    /* Logan Destefani Merazzi - DBA | @LoganMerazzi | http://www.merazzi.eti.br
    Se a resposta for útil, vote nela. Se resolveu, marque-a como resposta. */

    quinta-feira, 22 de outubro de 2015 14:00
  • Jeferson bom dia,

    Cara possivelmente o usuários que esta tentando se conectar na base possivelmente não tem acesso na base.

    Valide a questao do acesso na base.


    Se a resposta foi útil por favor classifique. Tiago Neves - @tiagolneves - acesse o meu blog http://www.tiagoneves.net

    quinta-feira, 22 de outubro de 2015 14:12
  • Essa mensagem acontece no ODBC, e não está relacionada a permissão de acesso.

    Olha esse KB ele explica e orienta sobre o erro.

    KB 143339

    "

    Quando um aplicativo ODBC chama SQLError() depois de obter SQL_SUCCESS_WITH_INFO, ele deve esperar as seguintes mensagens: 
    1. Uma mensagem de 5701 mostrando SQL Server inicialmente colocar o contexto do usuário no banco de dados padrão definido no servidor para a identificação de logon usada na conexão.
    2. Uma mensagem 5703 mostrando o idioma que está sendo usado no servidor.
    3. Se a fonte de dados ODBC possui um banco de dados padrão especificado, ou se o aplicativo especificado no banco de dados = palavra-chave em SQLDriverConnect() ou SQLBrowseConnect(), então haverá um segundo 5701 mensagem mostrando o contexto do usuário sendo alternado para o banco de dados solicitado.

    "

    Full Connect:
    
          szSqlState = "01000", *pfNativeError = 5701,
          szErrorMsg="[Microsoft][ODBC SQL Server Driver][SQL Server]
                 Changed database context to 'master'."
          szSqlState = "01000", *pfNativeError = 5703,
          szErrorMsg="[Microsoft][ODBC SQL Server Driver][SQL Server]
                 Changed language setting to 'us_english'."
          szSqlState = "01000", *pfNativeError = 5701,
          szErrorMsg="[Microsoft][ODBC SQL Server Driver][SQL Server]
                 Changed database context to 'pubs'."
    
       Successfully connected to DSN 'ab60def'.


    Flávio Farias
    "May the Force be with you"
    Se foi resolvido clique "Marcar como resposta" e se foi útil "Votar como Útil"

    quinta-feira, 22 de outubro de 2015 14:45
  • Valeu parceiros, aparentemente parece que o problema se resolveu com as dicas. 

    Abraços!

    quarta-feira, 9 de dezembro de 2015 00:15