none
Meu server 2003 IIS somente roda com windows/mobile, o que estou fazendo de errado ? RRS feed

  • Pergunta

  • Olá,

    tenho instalado um servidor 2003 IIS e tenho uma aplicação em asp.net que dá entrada nos pedidos de vendas atrávés de smartphones com windows mobile que funciona normalmente.

    porém, agora estou fazendo alguns testes com outro smartphone com android e agora a aplicação passou a não executar alguns comandos (botões) !    

    testei também com chrome em um desktop e também dá o mesmo problema, e com IE funciona normal. 

    procurei muito na net atrás de alguma solução, já fiz vários testes progredi em alguns pontos, porém não consegui resolver totalmente o problema.

    Gostaria se possível a ajuda de vocês.

    obrigado

     

    sexta-feira, 27 de janeiro de 2012 12:54

Respostas

  • A sua aplicação foi desenvolvida para funcionar apenas com o IE, por isso em outros browsers ele não funciona. Isso acontece bastante, será necessário efetuar algumas alterações na aplicação e não no IIS. O Visual Studio possui opções para testar com outros browsers.


    Pablo Weyne
    Blog - http://www.iishelp.com.br
    Twitter - @pabloweyne
    sábado, 28 de janeiro de 2012 13:17

Todas as Respostas

  • A sua aplicação foi desenvolvida para funcionar apenas com o IE, por isso em outros browsers ele não funciona. Isso acontece bastante, será necessário efetuar algumas alterações na aplicação e não no IIS. O Visual Studio possui opções para testar com outros browsers.


    Pablo Weyne
    Blog - http://www.iishelp.com.br
    Twitter - @pabloweyne
    sábado, 28 de janeiro de 2012 13:17
  • Pablo, obrigado pelo retorno

    conversei com o pessoal que desenvolveu a aplicação e eles estão afirmando que o problema é com o meu servidor IIS.

    como eu poderia ter certeza disso ? sobre o teste com o Visual Studio e os outros browsers, qual o nome da aplicação/módulo que eu devo procurar ?

    muito obrigado

     

     

     

    segunda-feira, 30 de janeiro de 2012 16:05
  • Esse site faz isso:

     

    http://browsershots.org/


    Pablo Weyne
    Blog - http://www.iishelp.com.br
    Twitter - @pabloweyne
    segunda-feira, 30 de janeiro de 2012 17:07
  • Outra coisa, o IIS não trabalha diferente para os tipos de browser, ele entrega a página de acordo como ele foi desenvolvida, a interpretação é feita no browser, se em alguns não abre, tem que adaptar o desenvolvimento para isso.

    Eu trabalho com Hosting, tenho experiência nisso já tem 10 anos. 


    Pablo Weyne
    Blog - http://www.iishelp.com.br
    Twitter - @pabloweyne
    segunda-feira, 30 de janeiro de 2012 17:21
  • Pablo,

    estou tentando testar o link que você me passou, porém não estou conseguindo, o meu servidor IIS pede login/senha para autenticação de acesso.

    A página fica tentando se conectar e depois de um tempo "me parece" que a página e o servidor cai (não tenho certeza disso).

    Não estou podendo testar em horário comercial, porque o site está em produção, assim que possível vou fazer mais testes.

    Caso tenha mais alguma sugestão, por favor me envie.

    Obrigado

     

     

     

     

     

     

     

    terça-feira, 31 de janeiro de 2012 15:58
  • Olá, novidades?

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com

    sexta-feira, 10 de fevereiro de 2012 14:01
    Moderador
  • Pablo,

    acertou na mosca, a pessoa que desenvolveu a aplicação está me dizendo que a aplicação foi feita para rodar em windows mobile e me aconselhou a baixa o iexplorer p/ android.

    Andei pesquisando e não existe ie p/ android oficial, somente uma versão "alternativa" preciso testar.

    Assim que eu tiver alguma resposta continuo trazendo aqui.

    Grato.

    segunda-feira, 13 de fevereiro de 2012 18:03
  • Eu disse. Como era esse o problema, é melhor encerrar essa thread.

    Pablo Weyne
    Blog - http://www.iishelp.com.br
    Twitter - @pabloweyne

    segunda-feira, 13 de fevereiro de 2012 19:51