none
Arredondamento de hora RRS feed

  • Pergunta

  • Tenho uma célula onde se o valor for superior a 07:55 e inferior a 08:05, por exemplo, ela deve mostrar e valer 08:00. Qual a fórmula para proceder?

    Obrigado

    quarta-feira, 18 de janeiro de 2017 16:11

Todas as Respostas

  • Olá,

    Veja se ajuda

    Na célula A1 digite 07:55:00

    Na célula B1, digite =CONVERTER(MARRED(A1;"0:30");"hr";"hr")

    quarta-feira, 18 de janeiro de 2017 16:26
  • Não muito. Qualquer valor que eu digitar será arredondado para 8:00. O que eu preciso é que, se digitar 07:54, por exemplo, ou 08:06, estes valores sejam aceitos. A conversão para 8:00 somente deverá ocorrer se os valores estiverem entre 07:55 e 08:05. Exemplo: 07:58 = 8:00; 8:02 = 8:00; 7:50 = 7:50; 8:10 = 8:10. Mesmo assim, agradeço a tentativa.
    quarta-feira, 18 de janeiro de 2017 18:23
  • Neste caso faça um condição usando a função SE:

    =SE(E(A1>=VALOR("7:55");A1<=VALOR("8:05"));"8:00";A1)


    Rafael Kamimura - http://excelmaniacos.com

    • Sugerido como Resposta Edvaldo A quinta-feira, 19 de janeiro de 2017 18:55
    quarta-feira, 18 de janeiro de 2017 18:59
  • Agora está dando certo o que eu queria. Obrigado pela ajuda. Abraço.
    quarta-feira, 18 de janeiro de 2017 19:24