none
Não é possível montar a base Exchange 2010 RRS feed

  • Pergunta

  • Depois de um pico de Luz, uma das bases do Exchenge não subiu.

    Executei o eseutip /p, com a seguinte conclusão: "Repair completed. Database corruption has been repaired!

    Mas ao tentar montar a base. Recebo a seguinte mensagem de erro:

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'xxxxxxx'.

    Avancados
    Failed
    Error:
    Couldn't mount the database that you specified. Specified database: Avancados; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorAttachedDatabaseMismatch: Unable to mount database. (hr=0x80004005, ec=-1216)
    . [Database: Avancados, Server: SRV6.xxxxx.net].

    An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorAttachedDatabaseMismatch: Unable to mount database. (hr=0x80004005, ec=-1216)
    . [Database: Avancados, Server: SRV6.xxxxx.net]

    An Active Manager operation failed. Error: Operation failed with message: MapiExceptionJetErrorAttachedDatabaseMismatch: Unable to mount database. (hr=0x80004005, ec=-1216)
    . [Server: SRV6.xxxxx.net]

    MapiExceptionJetErrorAttachedDatabaseMismatch: Unable to mount database. (hr=0x80004005, ec=-1216)





    --------------------------------------------------------
    OK
    --------------------------------------------------------

    Alguém poderia ajudar?

     

    terça-feira, 13 de março de 2018 21:52

Todas as Respostas

  • Cleidson, boa noite!

    Nunca tive esse problema, mas já tentou voltar um backup desse database?

    Também pesquisei um pouco e achei esse link interessante, veja se te ajuda.

    http://www.stellarservertools.com/blog/fix-exchange-jet-error-1216-1018/

    quarta-feira, 14 de março de 2018 00:57
  • Ola Cleidison,

    O primeiro ponto é entender; depois que fez o eseutil /p, a base voltou para o status de clean shutdown? Pois se continua em durty shutdown, realmente não vai ser possível montá-la.

    O segundo ponto é; se tu chegou a verificar com o parâmetro /ml a consistência das logs transacionais?

    Por último, faça sempre também o defrag com o parâmetro /d após o repair. Segue um link explicativo de database recovery para te auxiliar: http://msexchangeguru.com/2009/07/12/exchange-database-recovery-using-eseutil-commands/

    De qualquer forma, em paralelo, sempre de andamento do restore de teu último bakup válido, pois independente de ter reparado a base ou não, jamais a mantenha de novo em produção, uma base reparada nunca mais terá a mesma consistência.

    Para fazer o “merge” entre a base restaurada e os e-mails enviados após o último backup, utilize as logs transacionais da database problemática e faça um processo chamado Dial Tone Recovery.

    Se em ultimas das opções tu não conseguir nem reparar a base corrompida, e nem haver um backup integro, dê uma olhada em uma ferramenta que se chama Kernel for Exchange. Essa ferramenta ela “abre” a base e oferece a possibilidade de exportar mailboxes para PST. Em alguns casos consegue até recuperar base corrompida.

    Abraços.


    MCSE: Messaging | MCSA: Windows Server 2012 | MS: Virtualization | VCP-DCV 6 | ITIL v3 | Blog: signorellidenis.wordpress.com | Portal MCP: www.mycertprofile.com/Profile/996021735 | Lembre-se, caso a dica lhe foi útil, marcar como resposta. Assim mantemos a organização no fórum, e incentivamos aos demais que continuem ajudar a quem necessite.

    quarta-feira, 14 de março de 2018 08:26