none
Autenticação DCOM RRS feed

  • Pergunta

  • Bom dia,

    Tenho uma aplicação que recebe comunicações externas através de DCOM, utilizando o DCOMCNFG realizarmos a configuração em uma DCOM específica de permissão e as opções de Identity utilizando a opção This User para o usuário iit-rpm\userpi, informando sua senha de maneira correta.

    A comunicação roda perfeitamente, porém com o tempo essa comunicação para com a mensagem de Bad password ou username e gera o event viewer 10006 "Dcom got error 1385 and was unable to logon iit-rpm\userpi in order to run the server", consigo resolver o problema repassando a senha na DCOM configurada, porém a senha não foi alterada a configuração não foi perdida, coloco a mesma senha que estava antes.

    Minha pergunta seria o que poderia alterar essa senha na DCOM? Poderia ser alguma GPO? tenho percebido que o problema ocorre com mais frequencia quando tenho algum evento na minha rede, como por exemplo uma simples troca de porta no switch, porém não é sempre que ocorre, pois tentei gerar o problema para realizar os testes e nem sempre consigo.

    Encontrei na minha pesquisa outro tipo de problema de autenticação com relação a rede (não era DCOM) relacionada a opção da placa de rede IPV4 Large Send Offload, no qual a solução era desabilitar essa opção, ainda não realizei teste, pois não tenho conhecimentos sobre essa opção, será que poderia ter alguma relação? Posso ter algum efeito colateral?

    Esse problema ocorre tanto no Windows 10 como no Windows Server 2016.

    Alguém teria alguma idéia sobre esse fato, pois essa comunicação não pode ter interrupção por se tratar de chão de fábrica.

    Obrigado.

    Wellington Moreira


    Wellington Moreira




    sábado, 25 de agosto de 2018 13:16

Respostas

  • Boa tarde,

    Por falta de retorno essa thread está encerrada.

    Se necessário favor abrir uma nova thread.

    Atenciosamente,

    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta IgorFKModerator sexta-feira, 31 de agosto de 2018 12:43
    • Não Marcado como Resposta WellingtonMoreira terça-feira, 4 de setembro de 2018 14:48
    • Marcado como Resposta IgorFKModerator quinta-feira, 20 de setembro de 2018 12:18
    sexta-feira, 31 de agosto de 2018 12:43
    Moderador

Todas as Respostas

  • Bom dia Wellington Moreira, tudo bem?

    Uma das possíveis causas para este problema pode ser uma senha expirada no AD, experimente trocar a senha no AD e veja se o problema ainda persiste.

     

    Outro cenário com uma causa diferente onde este problema ocorre é descrito neste artigo (juntamente com passos para correção do mesmo): https://www-01.ibm.com/support/docview.wss?uid=swg21429662 

     

    Este problema é também discutido nesta thread, experimente executar os procedimentos sugeridos lá: https://social.technet.microsoft.com/Forums/en-US/96572b96-18a6-4d0c-a722-075e4bf0e8b0/dcom-error-event-10006?forum=smallbusinessserver 

     

    Espero que ajude. Atenciosamente, 


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.


    segunda-feira, 27 de agosto de 2018 14:20
    Moderador
  • Na placa de rede (na configuração padrão do driver) a taxa de transferência de dados costuma estar em harf-duplex ou em automático, muda para full-duplex.  E verifica na sua placa qual é a velocidade de dados que está configurada, costuma estar no automático, muda para 100mbps (placas antigas) ou muda para 1000mbps  (placas novas).


    Ana Mercedes Gauna | Microsoft Partner | Skype: @amgauna | Twitter: @amgauna | Blog: anagauna.wordpress.com | Site: www.anagauna.eti.br | www.amgauna.com.br | If I helped you, mark the answer as useful

    segunda-feira, 27 de agosto de 2018 15:11
  • Boa tarde,

    Por falta de retorno essa thread está encerrada.

    Se necessário favor abrir uma nova thread.

    Atenciosamente,

    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta IgorFKModerator sexta-feira, 31 de agosto de 2018 12:43
    • Não Marcado como Resposta WellingtonMoreira terça-feira, 4 de setembro de 2018 14:48
    • Marcado como Resposta IgorFKModerator quinta-feira, 20 de setembro de 2018 12:18
    sexta-feira, 31 de agosto de 2018 12:43
    Moderador
  • Boa tarde,

    As informações de Username e password estão corretas, tanto que menciono que o problema é resolvido temporariamente entrando com o password novamente.

    O usuário não está como não está como senha expirada ou algum outro atributo errado.

    Desabilitamos uma GPO que realiza algumas configurações de segurança, porém ainda não consegui descobrir qual seria a configuração que pudesse causar esse probrema.

    Estou inserindo um HTML com as GPO´s configuradas, caso alguém possa me ajudar a descobrir.

    Obrigado Igor pela ajuda.

    Wellington Moreira


    Wellington Moreira

    terça-feira, 4 de setembro de 2018 14:55
  • O HTML da GPO está muito grande para o Post, como posso disponibilizar aqui para me ajudarem?

    Wellington Moreira

    terça-feira, 4 de setembro de 2018 15:15
  • Bom dia WellingtonMoreira,

    Houve alguma atualização no seu caso? Conseguiu descobrir mais alguma informação útil?

    Atenciosamente, 


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 10 de setembro de 2018 12:34
    Moderador
  • Bom dia,

    Não, apenas descobri que seria uma policy que desabilitei e o problema não ocorreu novamente, porém preciso voltar com essas policy mas não posso, pois não descobri o que acontece. Tentei colocar aqui o HTML dessa policy porém excede os 6000 caracteres.

    Obrigado.


    Wellington Moreira

    segunda-feira, 10 de setembro de 2018 12:45
  • Achei no Google artigos de como consertar erros DCOM, verifica se algum dos procedimentos te ajuda. 

    https://msdn.microsoft.com/pt-br/library/2dbesfyx.aspx

    https://msdn.microsoft.com/pt-BR/library/7fex01a8.aspx

    https://msdn.microsoft.com/pt-br/library/x1719157.aspx

    https://msdn.microsoft.com/pt-br/library/windows/desktop/7fex01a8(v=vs.120).aspx

    https://msdn.microsoft.com/pt-br/library/aa910590.aspx

    https://msdn.microsoft.com/pt-br/library/windows/apps/xaml/7fex01a8(v=vs.140).aspx

    https://msdn.microsoft.com/pt-br/library/2dbesfyx.aspx


    Ana Mercedes Gauna | Microsoft Partner | Skype: @amgauna | Twitter: @amgauna | Blog: anagauna.wordpress.com | Site: www.anagauna.eti.br | www.amgauna.com.br | If I helped you, mark the answer as useful

    segunda-feira, 10 de setembro de 2018 15:47
  • Boa noite Ana,

    O problema não está na configuração da DCOM, está em alguma politica aplicada.

    Agradeço a ajuda.


    Wellington Moreira

    sexta-feira, 14 de setembro de 2018 02:18
  • Boa noite Ana,

    O problema não está na configuração da DCOM, está em alguma politica aplicada.

    Agradeço a ajuda.


    Wellington Moreira

    Você sabe especificar qual GPO está com este problema?

    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 14 de setembro de 2018 13:00
    Moderador