none
Erro HyperV Replica RRS feed

  • Pergunta

  • Ola Amigos,

    Utilizamos o Hyper V Replica em nosso ambiente, tudo funciona perfeitamente. Porem apos uma reinicialização de manutenção

    todas as replicas do servidor estavam paradas, como se nunca tivessem sido habilitadas. Ao fazer a reconfiguração da mesma (replica) a seguinte mensagem (abaixo) é exibida, como se ainda ela guardasse algum vinculo com a maquina de replica anterior.

    Esse numero de ID é o mesmo da maquina de replica, já busquei alguma forma por powershell para "quebrar" esse vinculo mas sem sucesso. Outra coisa que tentei fazer, foi habilitar a replica para outro servidor, porem a mesma mensagem foi exibida.

    Alguém já se deparou com esse tipo de problema?

    Utilizado o comando enabled-vmreplication

    enable-vmreplication : Não foi possível habilitar a replicação de 'Foco'. (ID
    da máquina virtual A77BED3C-E848-4628-BFCC-7FB53019CEBF)
    A tarefa de replicação 'Habilitar Replicação' não pode ser executada quando a
    replicação está no estado 'Não habilitado' para a máquina virtual 'Foco'. (ID
    da máquina Virtual A77BED3C-E848-4628-BFCC-7FB53019CEBF)
    Operação não permitida para a máquina virtual 'Foco' porque o estado do
    Hyper-V ainda não foi inicializado na configuração de máquina virtual. Tente
    novamente em alguns minutos. (ID da máquina virtual
    A77BED3C-E848-4628-BFCC-7FB53019CEBF).
    A operação não poderá ser executada enquanto a máquina virtual estiver no
    estado atual. O nome da máquina virtual é Foco e sua ID é
    a77bed3c-e848-4628-bfcc-7fb53019cebf.
    No linha:1 caractere:1
    + enable-vmreplication foco hyperv-server02.companhiadasletras.com.br 80
    kerberos

    quarta-feira, 3 de outubro de 2018 21:26

Respostas

  • Ola Igor,

    Consegui resolver o problema reiniciando o serviço de gerenciamento do HyperV, provavelmente na reinicialização de manutenção do servidor esse serviço deve ter travado o estado da replicas. Pois logo a apos, as replicas recomeçaram normalmente (Ressincronização). Tive uma ou outra que dava erro, mas a grande maioria voltou normalmente. 

    Agradeço os retornos e o apoio!

    Att,

    • Marcado como Resposta Paulo Alves P sexta-feira, 5 de outubro de 2018 18:13
    sexta-feira, 5 de outubro de 2018 18:12

Todas as Respostas

  • Bom dia Paulo Alves, tudo bem?

    "A operação não poderá ser executada enquanto a máquina virtual estiver no estado atual."...  em qual estado a máquina estava durante esta tentativa? ela estava desligada?

    Atenciosamente, 


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 4 de outubro de 2018 13:39
    Moderador
  • Bom dia Igor,

    Todas as VMs encontram-se no estado de replica "Não habilitado" e o status de Integridade de Replicação "Não Aplicável".

    Tentei habilitar a replica tanto para VMs desligadas quanto para em execução, e ocorre o mesmo erro. Com a unica diferença no numero de ID das VMS de replica.

    Suspeito que algum serviço do HyperV tenha travado, no momento estou fazendo uma investigação nesse sentido.

    Att,

    quinta-feira, 4 de outubro de 2018 14:04
  • Você poderia checar a integridade da role do Hyper-V através de alguns comandos e depois testar novamente.

    É possível para você no momento estar desabilitando a role do Hyper-V temporariamente?

    Se sim, experimente desabilita-la, executar os comandos abaixo, habilita-la novamente e testar se o problema foi resolvido:

    Dism /Online /Cleanup-Image /ScanHealth 
    Dism /Online /Cleanup-Image /CheckHealth  
    sfc /scannow 

     

    Espero que ajude. Atenciosamente,


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 4 de outubro de 2018 20:43
    Moderador
  • Ola Igor,

    Consegui resolver o problema reiniciando o serviço de gerenciamento do HyperV, provavelmente na reinicialização de manutenção do servidor esse serviço deve ter travado o estado da replicas. Pois logo a apos, as replicas recomeçaram normalmente (Ressincronização). Tive uma ou outra que dava erro, mas a grande maioria voltou normalmente. 

    Agradeço os retornos e o apoio!

    Att,

    • Marcado como Resposta Paulo Alves P sexta-feira, 5 de outubro de 2018 18:13
    sexta-feira, 5 de outubro de 2018 18:12
  • Muito obrigado.

    Me ajudou.

    sexta-feira, 2 de outubro de 2020 14:57