none
Adicionando um DC 2008 em um dominio 2003. RRS feed

  • Pergunta

  • Olá.
    Estou adicionando um Windows 2008 Std e tentando promove-lo a DC em um dominio 2003 em um w2k3 std r2.

    Já elevei os niveis funcionais do dominio e da floresta para windows 2003.
    Quando executo o ADPREP, O tradicional c que temos que pressionar para continuar, não aparece.
    entao aperto c mesmo sem aparecer nada e o adprep continua.

    na pasta de logs do ad prep, tenho o seguinte:

    Connecting to "servidor.NomeDominio.LOCAL"
    Logging in as current user using SSPI
    Importing directory from file "C:\WINDOWS\debug\adprep\logs\20090316001537\.001.ldf"
    Loading entries
    VARIAS ENTRADAS E O ERRO...

    There is a syntax error in the input file
    Failed on line 169.  The last token starts with ','.
    23 entries modified successfully.
    An error has occurred in the program

    executei o schupgr.exe e a versão do Schema é a 44. Que é o schema do 2008.

    Mas quando tento adicionar o controlador de dominio adicional com o server 2008, no dcpromo, ele ainda fala que tenho que executar o domain prep.
    Quando executo o DCDiag, passo em todos os testes.
    Estou em todos os grupos necessarios, schema admins, enterprise admin...
    Todas as Funções estão nesse DC que é o unico DC do dominio.
    Já fiz os testes com o replmon.

    O problema é esse. Preciso executar o DCpromo no 2008....Mas estão ocorrendo as não conformidades acima... E o schema ainda diz ser o do 2008?
    Alguma idéia?

     

    segunda-feira, 16 de março de 2009 04:12

Respostas

  • Eu gostaria de agradecer ao pessoal que tentou ajudar.

    Durante minhas pesquisas eu ví vários problemas semelhantes quando muitas pessoas tentavam Atualizar o schema do Server 2003 para acomodar o R2.

    Após muito quebrar a cabeça e fazer muitos testes... Eu acho que é um problema que pode acontecer quando você tenta migrar de um R2 para o 2008. SABE-SE LÁ por qual motivo isso acontece. Varri o schema que nem um louco, li logs e etc.

    Quem por ventura tiver o mesmo problema, atenção a solução.
    Eu não achei ser a solução ideal e nem elegante, mas resolveu. Acho que tudo deveria ser resolvido sem um agente externo.
    Agente externo?
    Isso mesmo.
    Coloquei um Server 2003 no dominio, transferi as roles FSMO, global catalog e schema para esse novo servidor.
    Nele executei o adprep e o domainprep sem problemas.
    Executei o dcpromo no 2008 e ele localizou o AD.

    Problema Resolvido.
    sexta-feira, 20 de março de 2009 01:33

Todas as Respostas

  •  Bom Dia

    Remova o server 2008 do dominio.

    Delete a conta de computador do A.D do server 2008 removido

    Ingressar novamente o servidor e seguir os passas abaixo. com credenciais de administrador.


    Para migrar o seu dominio basta usar dos passos que estão na guia de pre-instalação do windows 2008.

     

    copiar os arquivos do cd do 2008 server chamado  source para um diretorio do seu servidor:

    entrar pela linha de comando no diretorio

    e executar os passos de preparação do dominio.

    adprep /forestprep

    esse é para preparar a floresta

    e o segundo é

    adprepr /domainprep /gpprep



    sds

     

    Marlon Cavalli

     

    segunda-feira, 16 de março de 2009 10:58
  • Eu já havia feito isso tudo.
    Fiz novamente, só que dessa vez removi o servidor 2008 do dominio. antes de executar o DCPROMO.
    Como eu já imaginava, Mesma coisa. O problema persiste.

    Mesmo com o schema alterado para  44 após o adprep no meu AD 2003.
    O DCPROMO não localiza a alteração no schema.
    E fica pedindo pra executar o adprep /forestprep.
    segunda-feira, 16 de março de 2009 16:04
  • Quanto executo net helpmsg 8467

    A versão do esquema do serviço de diretório da floresta de origem não é compativel com a versão do serviço de diretório nesse computador.

    Lembrando que estou executando um Server 2003 R2 Std onde já executei o adprep /forestprep e o /Domainprep...

    • Editado Luiz Eduardo quarta-feira, 18 de março de 2009 16:46
    segunda-feira, 16 de março de 2009 16:13
  •  Estranho...
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters
    A Dword
    Schema Version é 44 do 2008...
    E a Dword
    System Schema version é 31 do SBS 2003 R2.

    Noschupgr aparece o seguinte:

    Opened Connection to SERVIDOR
    SSPI Bind succeeded
    Found Naming Context DC=DOMINIO,DC=LOCAL
    Found Naming Context CN=Schema,CN=Configuration,DC=DOMINIO,DC=LOCAL
    Found Naming Context CN=Configuration,DC=DOMINIO,DC=LOCAL
    Current Schema Version is 44
    Upgrading schema to version 44
    The schema has already been upgraded. Rerun setup to upgrade this DC

    Re-executar o setup???
    Esta sinistro mesmo....

    segunda-feira, 16 de março de 2009 18:10
  • Pois é.
    Nada do DCPROMO do 2008 reconhecer o novo schema no DC 2003.
    Alguem pode ajudar?

    terça-feira, 17 de março de 2009 14:26
  • Boa Noite

    Pode ser um problema de permissao do administrador:


    execute a reset de senha do administrador local do windows 2008  via linha de commando:

    Ja resolvi problemas de dcpromo desta forma:

    Quando um Server 2008 é instalado ele pede em um dos primeiros passos para setar uma senha de administrador

    Por algum motivo pode ter ocorrido um erro e so reseta a senha via linha de commando:


    http://www.linhadecodigo.com.br/ArtigoImpressao.aspx?id=2125




    sds

    Marlon Cavalli
    quarta-feira, 18 de março de 2009 00:05
  • Ainda não funcionou...
    Será que eu deveria importar os arquivos ldf que vem na pasta do adprep com ldifde.exe ?

    Ou pode dar M?

    Bem o schema esta 44 no DC, mesmo que o adprep mostre o erro que exibi acima:

    There is a syntax error in the input file
    Failed on line 169.  The last token starts with ','.
    23 entries modified successfully.
    An error has occurred in the program

    acho que isso não impediria o 2008 de executar o adprep.

    quarta-feira, 18 de março de 2009 16:43
  • Eu gostaria de agradecer ao pessoal que tentou ajudar.

    Durante minhas pesquisas eu ví vários problemas semelhantes quando muitas pessoas tentavam Atualizar o schema do Server 2003 para acomodar o R2.

    Após muito quebrar a cabeça e fazer muitos testes... Eu acho que é um problema que pode acontecer quando você tenta migrar de um R2 para o 2008. SABE-SE LÁ por qual motivo isso acontece. Varri o schema que nem um louco, li logs e etc.

    Quem por ventura tiver o mesmo problema, atenção a solução.
    Eu não achei ser a solução ideal e nem elegante, mas resolveu. Acho que tudo deveria ser resolvido sem um agente externo.
    Agente externo?
    Isso mesmo.
    Coloquei um Server 2003 no dominio, transferi as roles FSMO, global catalog e schema para esse novo servidor.
    Nele executei o adprep e o domainprep sem problemas.
    Executei o dcpromo no 2008 e ele localizou o AD.

    Problema Resolvido.
    sexta-feira, 20 de março de 2009 01:33
  • Da uma olhada neste post;

    http://social.technet.microsoft.com/forums/en-US/winserverDS/thread/9931e32f-6302-40f0-a7a1-2598a96cd0c1/

    []'s


    Thiago Pereira | http://thiagoinfrat.spaces.live.com
    sexta-feira, 20 de março de 2009 04:48
    Moderador
  • Obrigado Thiago, eu já havia visto esse post no dia em que o problema ocorreu.
    Fiz o descrito ali mas também não havia adiantado.
    Realmente eu só costumo postar em forum depois de muito pesquisar e esgotar todas as minhas opções. Mas nem sempre conseguimos cobrir tudo. Logo eu poderia ter deixado essa passar.

    Mas é como eu disse, felizmente o problema já esta resolvido.
    Abraço e obrigado novamente.
    sexta-feira, 20 de março de 2009 13:50