locked
Instalar drive nativo do SQL Server RRS feed

  • Pergunta

  •  

    Caros colegas, tenho uma estação de trabalho e nela precisa criar uma conexão com o SQL Server através do BDE. Só que quando abro o BDE e mando criar uma nova conexão, o drive MSSQL(o drive nativo do SQL) não aparece na lista, aparece somente o drive SQL Server que é para ODBC. Alguém sabe me dizer como instalar esse drive nativo do SQL Server.

    Obs.: O mais curioso é que nesta estação de trabalho tem uma versão do SQL Server 2000 Personal instalado, tanto a parte client como a parte server.

     

    Grata!!!

    quarta-feira, 26 de novembro de 2008 10:12

Todas as Respostas

  • Lara,

     

    É necessário instalar o client do SQL Server nesta máquina para que o driver nativo do SQL Server, o MSSQL apareça.

    quarta-feira, 26 de novembro de 2008 10:32
    Moderador
  •  

    Mas eu não só instalei o client como instalei o SQL Server completo .
    quarta-feira, 26 de novembro de 2008 11:44
  • Olá Lara, quando você vai no Data Source ODBC, Drivers, você lê  SQL Server Versão 2000 , é isto ?

     

    Se a resposta for sim, é porque você tem instalado o SQL Server 2000 e não SQL Server 2005, pois o SQL Native Client somente aparece na versão 2005.

     

     

    De uma olhada no seu MDAC qua a versão se estiver desatualizado.

     

    http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=en

     

     

     

    SDS

    quarta-feira, 26 de novembro de 2008 12:41
  • Boa Tarde,

     

    Não sei se o milenar BDE contemplará esses drivers mais novos.

    Até onde sei a Borlando tinha intenções de descontinuá-lo.

    Se isso for verdade, não veremos muitas atualizações para novos drives.

     

    [ ]s,

     

    Gustavo

    quarta-feira, 26 de novembro de 2008 18:50
  • Consegui resolver o problema. Instalei uma versão mais nova do BDE, a versão 5.2, e ele reconheceu o drive nativo do SQL Server(MSSQL). O mais curioso é que em várias outras máquinas, tenho a versão 5.01 e também reconhece. Mas tudo bem, o fato é que foi a instalação de uma versão mais recente que resolveu o problema.

     

    Grata!!!

    quinta-feira, 27 de novembro de 2008 11:22