none
Perda de conexão com impressora partilhada RRS feed

  • Discussão Geral

  • Temos uma rede com 3 postos com Windows XP Pro, anexados a um Domain Controller de Windows 2008. Um dos PC's possui uma impressora ligada via USB que se encontra partilhada. Todos os users são Administradores locais dos PC's. A rede já funciona assim há já alguns anos e só recentemente notou-se a perda de comunicação com a impressora, dos outros 2 PC's. Por vezes quando os users imprimem, a grande maioria dos documentos são impressos (de sites da Web, de aplicativos de gestão, do Office) mas por vezes obtém-se o erro do Windows de que não foi possível imprimir o documento. Quando abrimos a pasta de impressoras, a impressora partilhada surge como «A abrir...» e por fim muda para «Acesso negado» ou  «Não foi possivel estabelecer a comunicação». A impressora continua activa no PC em que está ligado, encontra-se ON-LINE e partilhada. As impressões neste posto funcionam sem problema e sem falhas. Dos outros postos, quando surgem as falhas de conexão, conseguimos «pingar» o posto que possui a impressora, mas não o conseguimos abrir (quando está tudo normal, conseguimos aceder ao PC). Já desactivamos a firewall do Windows, a do antivírus, já alternamos entre ambas, ora activando uma, ora activando a outra, e mesmo o antivírus desactivado; as permissões sobre a partilha da impressora são todas (Imprimir, Gerir Impressoras, Gerir Documentos). Em algumas ocasiões quando tentamos aceder ao PC que possui a impressora, o mesmo pede-nos o login (age como se nunca tivesse sido conectado antes), validamos e memorizamos o login e fica tudo a funcionar, porém o problema volta a surgir após algumas impressões. Todos os postos encontram-se conectados ao Domain Controller. Na maioria dos casos resolvemos estas falhas com o reparar da ligação de rede nos postos que perdem a comunicação, mas quando não resulta, reiniciamos o PC que perdeu a conexão. Todas as poupanças de energia (USB e Rede) estão desactivados. 

    Agradecíamos alguma ajuda para resolver este problema.

    Obrigado.

    Nélio Abreu

    terça-feira, 9 de setembro de 2014 15:58

Todas as Respostas

  • Boa tarde Nélio. Tentou verificar a possibilidade de Vírus/Spyware/Warm ? Devido ao fato dos seus usuários estarem como administrador local dos seus computadores ?


    João Carlos Xavier de Macedo Specialist Platforms Microsoft MCP,MCT,MCSA,MCTS,MCITP, ENTERPRISE VIRTUALIZATION WINDOWS SERVER 2008 R2,MCSE WINDOWS SERVER 2012

    terça-feira, 9 de setembro de 2014 17:43
  • Boa tarde João Carlos,

    Os equipamentos estão protegidos com Kaspersky Endpoint Security, não há infecções detectadas, foi inclusive rodado o Malwarebytes, nada detectou. Estas operações foram logo de inicio rodadas quando se detectou as primeiras falhas. Há a salientar que o PC que possui a impressora partilhada, estava inicialmente como Debug User, e foi alterado para Administrador logo que se detectou as primeiras falhas, e que as permissões da impressora estavam apenas em Imprimir. Tudo foi alterado a partir do momento em que se notou as primeiras falhas: Permisões da impressora (de Imprimir para Imprimir + Gerir Impressoras + Gerir Documentos); Firewall alternada entre Kaspersky e Windows; por fim desactivação de todas as firewalls; desactivação temporária do antivírus; mudança do user de Debug para Administrador. Nada disso adiantou.

    Nélio Abreu

    quarta-feira, 10 de setembro de 2014 16:27