none
Configurar "executar como" RRS feed

  • Pergunta

  • Olá pessoal, tudo bem?

    Estou com um problema aqui que parece ser simples, mas não consigo encontrar a solução em lugar algum.

    Preciso rodar um executável, mas não está funcionando corretamente. O windows parece que tem algum problema com meu programa.

    Mas ok, para solucionar isso, achei como solução clicar com o botão direito do mouse e selecionar "executar como".
    E na caixa que abre, desmarcar a opção "Proteger meu computador..."

    http://img185.imageshack.us/img185/8484/execcomo.jpg

     

    Se eu fizer isso, meu programa funciona perfeito.
    Só que meus usuários não vão querer fazer isso, não é prático.

    Existe alguma forma de fazer isso por linha de comando ou configuração?
    Lembrando que não é preciso executar como administrador, só é preciso desmarcar aquela opção de segurança.

    Eu tentei com o comando "runas", mas ele não consegue executar o programa no drive de rede mapeado.

    Tentei resumir bem, mas se precisarem de mais detalhes, favor perguntar.
    Qualquer ajuda é bem vinda!

     

    Abraços
    Fabio Schunig

    segunda-feira, 4 de outubro de 2010 20:29

Respostas

  • Olá pessoal

    Primeiramente, agradeço a ajuda

    Alexandre: o meu windows é XP Professional. Mas esse atalho tem que rodar em várias versões de windows (vista, 7, XP, etc), pois são ambientes de produção dos meus clientes.


    Como mencionei no 1º post, o comando "runas" não funciona.
    Acho que deveria funcionar, mas ele me retorna o seguinte erro:

    "O sistema não pode encontrar o caminho especificado."

    O cenário é o seguinte:
    1- tenho um drive mapeado (Z:) que contém um executável (programa.exe)

    2- faço um atalho apontando para o executável:
    runas /user:fabio\administrador "z:\metasis.exe"

    3- me retorna o seguinte:
    Digite a senha para fabio\administrador:
    Tentando iniciar z:\metasis.exe como usuário "fabio\administrador" ...
    ERRO RUNAS:  não é possível executar - z:\metasis.exe
    3: O sistema não pode encontrar o caminho especificado.

     

    Como podem ver, nem com o usuário "administrador" consigo rodar.

    Alguma outra sugestão?

    Abraços
    Fabio Schunig

    Olá amigo,

    Já tentou trocar o caminho mapeado pelo caminho completo

    (ex:runas /user:fabio\administrador \\nomedopc\compartilhamento\metasis.exe), embora possa parecer estar correto, muitas vezes o comando simplesmente não acha o caminho especificado (embora não devesse). Vc tbm pode verificar as permissões do arquivo se estão configuradas corretamente, embora esteja parecendo erro de sintaxe.  Tente também usar o caminho no formato 8.3 (tipo MS-DOS, se tiver nomes longos).

    Espero ter ajudado.

    []'s

    • Marcado como Resposta Fabio Schunig terça-feira, 5 de outubro de 2010 20:29
    terça-feira, 5 de outubro de 2010 14:26
  • Fabio,

         Faça da seguinte forma. O script 1 vai chamar o script 2 que vai mapear no usuário que esta sendo executado o RUNAS. Faça o teste e ponha o resultado.

    1 script:

    @echo off
    set programaexe= "cmd /K CALL \\servidor\programa\sistema.bat"
    runas /user:fabio\administrador %programaexe%

    2 script: Esse é o sistema.bat e salva na pasta do sistema.

    @ echo off
    net use z: \\servidor\programa\sistema.bat
    z:\sistema.exe


    Leonardo Sousa

    MCP-MCDST-MCSA-MCSE-MCTS-MCITP
    Analista de TI
    • Marcado como Resposta Fabio Schunig terça-feira, 5 de outubro de 2010 20:28
    terça-feira, 5 de outubro de 2010 17:39
  • Boa tarde

    Com algumas modificações funcionou:

    1 script:
    @echo off
    set programaexe= "cmd /K CALL \\servidor\programa\sistema.bat"
    runas /user:fabio\administrador %programaexe%

    2 script:
    @ echo off
    net use z: \\servidor\programa\
    z:
    z:\sistema.exe
    exit

     

    Precisei mudar o diretório atual para o drive mapeado (Z:) no 2º script, para que achasse os arquivos de configuração.
    E dar "exit" no final para não ficar o prompt aberto após fechar o programa.


    Mesmo funcionando, ainda não responde minha dúvida inicial, que era saber o parâmetro para rodar o executável sem o flag de segurança. Se alguém souber, favor avisar, pois ficaria bem mais simples.


    No mais, agradeço a vocês Leonardo, Alexandre e fmaquino pela ajuda e atenção!
    Acredito que isso já vai me ajudar a resolver o problema ;)

    Abraços
    Fabio Schunig


    • Marcado como Resposta Fabio Schunig terça-feira, 5 de outubro de 2010 20:29
    terça-feira, 5 de outubro de 2010 20:28

Todas as Respostas

  • Boa Noite Amigo,

    A sua versão do windows é mesmo Windows Xp?

    Mas independente disso, faça a criação de seu atalho conforme descrito no link abaixo:

    http://technet.microsoft.com/pt-br/library/cc781769%28WS.10%29.aspx

    Espero ter ajudado.

    Abraços


    Se Útil, Por Favor Marque Como Resposta - Alexandre Falcão - http://azfalcao.spaces.live.com/ - @alexandrezera - Microsoft Certified Professional
    terça-feira, 5 de outubro de 2010 00:41
  • Fabio,

      Tente executar o script em bat abaixo. Cole o código em um bloco de notas e salve com a extensão bat.
      Os usuários só vão entrar com a senha do usuário deles.

    @echo off
    set programexe= Caminho do executavel
    runas /user:%username%@%userdnsdomain% %programexe%

     

    Espero ter ajudado.
    Se útil classifique.


    Leonardo Sousa

    MCP-MCDST-MCSA-MCSE-MCTS-MCITP
    Analista de TI
    terça-feira, 5 de outubro de 2010 00:49
  • Olá pessoal

    Primeiramente, agradeço a ajuda

    Alexandre: o meu windows é XP Professional. Mas esse atalho tem que rodar em várias versões de windows (vista, 7, XP, etc), pois são ambientes de produção dos meus clientes.


    Como mencionei no 1º post, o comando "runas" não funciona.
    Acho que deveria funcionar, mas ele me retorna o seguinte erro:

    "O sistema não pode encontrar o caminho especificado."

    O cenário é o seguinte:
    1- tenho um drive mapeado (Z:) que contém um executável (programa.exe)

    2- faço um atalho apontando para o executável:
    runas /user:fabio\administrador "z:\metasis.exe"

    3- me retorna o seguinte:
    Digite a senha para fabio\administrador:
    Tentando iniciar z:\metasis.exe como usuário "fabio\administrador" ...
    ERRO RUNAS:  não é possível executar - z:\metasis.exe
    3: O sistema não pode encontrar o caminho especificado.

     

    Como podem ver, nem com o usuário "administrador" consigo rodar.

    Alguma outra sugestão?

    Abraços
    Fabio Schunig

    terça-feira, 5 de outubro de 2010 13:11
  • Fabio,

          Ao executar o RUNAS o programa será executado em um outro perfil, a melhor solução é você aportar para o executável pelo caminho da rede em vez do mapeamento.

     

     


    Leonardo Sousa

    MCP-MCDST-MCSA-MCSE-MCTS-MCITP
    Analista de TI
    terça-feira, 5 de outubro de 2010 14:23
  • Olá pessoal

    Primeiramente, agradeço a ajuda

    Alexandre: o meu windows é XP Professional. Mas esse atalho tem que rodar em várias versões de windows (vista, 7, XP, etc), pois são ambientes de produção dos meus clientes.


    Como mencionei no 1º post, o comando "runas" não funciona.
    Acho que deveria funcionar, mas ele me retorna o seguinte erro:

    "O sistema não pode encontrar o caminho especificado."

    O cenário é o seguinte:
    1- tenho um drive mapeado (Z:) que contém um executável (programa.exe)

    2- faço um atalho apontando para o executável:
    runas /user:fabio\administrador "z:\metasis.exe"

    3- me retorna o seguinte:
    Digite a senha para fabio\administrador:
    Tentando iniciar z:\metasis.exe como usuário "fabio\administrador" ...
    ERRO RUNAS:  não é possível executar - z:\metasis.exe
    3: O sistema não pode encontrar o caminho especificado.

     

    Como podem ver, nem com o usuário "administrador" consigo rodar.

    Alguma outra sugestão?

    Abraços
    Fabio Schunig

    Olá amigo,

    Já tentou trocar o caminho mapeado pelo caminho completo

    (ex:runas /user:fabio\administrador \\nomedopc\compartilhamento\metasis.exe), embora possa parecer estar correto, muitas vezes o comando simplesmente não acha o caminho especificado (embora não devesse). Vc tbm pode verificar as permissões do arquivo se estão configuradas corretamente, embora esteja parecendo erro de sintaxe.  Tente também usar o caminho no formato 8.3 (tipo MS-DOS, se tiver nomes longos).

    Espero ter ajudado.

    []'s

    • Marcado como Resposta Fabio Schunig terça-feira, 5 de outubro de 2010 20:29
    terça-feira, 5 de outubro de 2010 14:26
  • Boa tarde pessoal

    Realmente, se eu colocar pelo caminho de rede o comando acha o arquivo executável.
    Ficou assim:
    @echo off
    set programaexe= "\\servidor\programa\sistema.exe"
    runas /user:fabio\administrador %programaexe%


    Mas (pra variar) acontece outro problema: dentro da pasta do executável, existe arquivos de configuração, dlls, e afins.

    Se eu uso dessa maneira, o executável não consegue acessar esses arquivos.
    Mesmo que eu coloque o comando em um atalho normal, e configure o campo "iniciar em", não está conseguindo achar.

    Sabem se existe alguma maneira de configurar o diretório que o executável vai iniciar?

    Abraços
    Fabio Schunig

    terça-feira, 5 de outubro de 2010 17:28
  • Fabio,

         Faça da seguinte forma. O script 1 vai chamar o script 2 que vai mapear no usuário que esta sendo executado o RUNAS. Faça o teste e ponha o resultado.

    1 script:

    @echo off
    set programaexe= "cmd /K CALL \\servidor\programa\sistema.bat"
    runas /user:fabio\administrador %programaexe%

    2 script: Esse é o sistema.bat e salva na pasta do sistema.

    @ echo off
    net use z: \\servidor\programa\sistema.bat
    z:\sistema.exe


    Leonardo Sousa

    MCP-MCDST-MCSA-MCSE-MCTS-MCITP
    Analista de TI
    • Marcado como Resposta Fabio Schunig terça-feira, 5 de outubro de 2010 20:28
    terça-feira, 5 de outubro de 2010 17:39
  • Coloque esse executavel com execao do DEP (prevencao de execucao de dados)

    Botao direito sobre meu computador

    Propriedades>desempenho>ABA prevencao de execucao de dados

    opcao

    Ativar DEP para todos os programas exceto

    clique em ADICIONAR

    e escolha o executavel

    e aplique

    e veja se funciona

    espero ter lhe ajudado


    Enderson Valente Teixeira - Coordenador de Informática
    terça-feira, 5 de outubro de 2010 19:56
  • Boa tarde

    Com algumas modificações funcionou:

    1 script:
    @echo off
    set programaexe= "cmd /K CALL \\servidor\programa\sistema.bat"
    runas /user:fabio\administrador %programaexe%

    2 script:
    @ echo off
    net use z: \\servidor\programa\
    z:
    z:\sistema.exe
    exit

     

    Precisei mudar o diretório atual para o drive mapeado (Z:) no 2º script, para que achasse os arquivos de configuração.
    E dar "exit" no final para não ficar o prompt aberto após fechar o programa.


    Mesmo funcionando, ainda não responde minha dúvida inicial, que era saber o parâmetro para rodar o executável sem o flag de segurança. Se alguém souber, favor avisar, pois ficaria bem mais simples.


    No mais, agradeço a vocês Leonardo, Alexandre e fmaquino pela ajuda e atenção!
    Acredito que isso já vai me ajudar a resolver o problema ;)

    Abraços
    Fabio Schunig


    • Marcado como Resposta Fabio Schunig terça-feira, 5 de outubro de 2010 20:29
    terça-feira, 5 de outubro de 2010 20:28
  • Coloque esse executavel com execao do DEP (prevencao de execucao de dados)

    Olá Enderson

    Agradeço a ajuda, mas não é bem isso que estou procurando.
    Não é o DEP que está incomodando meu programa. Mas, por precaução, fiz o teste que você sugeriu e o problema continua.

    O que resolveria meu problema é conseguir desmarcar aquela proteção automaticamente.
    Deve haver um parâmetro para isso.

    Vou continuar procurando, se algum dia encontrar eu coloco aqui para referência.

    Abraços
    Fabio Schunig

    quarta-feira, 6 de outubro de 2010 17:28