none
Erro no IIS para instalação do limitlogin RRS feed

  • Pergunta

  • Bom dia a todos,

    Estou tendo um problema com a instalação do limitlogin, meu erro é que o IIS não esta funcionando como deveria, eu habilitei a opção "Integrated Windows Athentication", porem quando tento abrir o browser ele me da o erro:

    "You are not authorized to view this pageYou do not have permission to view this directory or page using the credentials that you supplied because your Web browser is sending a WWW-Authenticate header field that the Web server is not configured to accept. HTTP Error 401.2 - Unauthorized: Access is denied due to server configuration. Internet Information Services (IIS)"

    Sendo que ele nem pediu nenhuma authenticação.

    tenho que acertar isso antes de continuar a instalação do limitlogin.

    Fico no aguardo.

    Desde já agradeço.


    Franklin Alves de Oliveira Analista de Sistemas Operacionais. MCP, MCDST.

    quinta-feira, 31 de maio de 2012 13:03

Respostas

  • Já tive o mesmo problema, resolvi alterando a permissão de execução do Site da seguinte forma:

    No Console do IIS clique na Instancia do Servidor > Application Pool > POOL_DA_APLICAÇÂO

    Depois clique com o botão direito em cima do Pool da aplicação e selecione a opção "Advance Settings"

    Nas configurações do Process Model procure pelo parâmetro Identity e altere para LocalSystem 

    No Console do IIS clique na Instancia do Servidor > Sites > NOME_DO_SITE > Authentication

    Nas configurações de Authentication clique com o botão direito em cima da opção "Anonymous Authentication" e selecione Edit...

    Selecione a opção Application Pool identity e clique em OK

    Esta foi a unica solução que encontrei para o erro 401.2, isso também é um requisito para rodar o Crystal Reports no IIS.

    Espero ter lhe ajudado.

    Atenciosamente

    João Paulo de Andrade

    terça-feira, 5 de junho de 2012 17:42

Todas as Respostas

  • Cara, quando você criou o site ou a aplicação, você setou um usuário que tem permissão pra acessar a pasta desse site ou aplicação?

    Pode ser esse o problema que você ta tendo, as vezes nem é relacionado ao limit login...

    segunda-feira, 4 de junho de 2012 13:35
  • Kelson,

    Ta com permissão full control para everyone...

    ja não sei mais oq faço, ja esgotei todas as ideias...

    fico aqui no aguardo da ajuda de vcs.

    Obrigado galera.


    Franklin Alves de Oliveira Analista de Sistemas Operacionais. MCP, MCDST.

    terça-feira, 5 de junho de 2012 12:24
  • Franklin, você ta usando internet explorer pra testar esse acesso? Ja verificou com outros navegadores?

    Pode ser que o IE esteja configurado, nas opções de segurança, pra não exibir a caixa de autenticação. Claro, se estiver usando IE.

    terça-feira, 5 de junho de 2012 13:02
  • Já tive o mesmo problema, resolvi alterando a permissão de execução do Site da seguinte forma:

    No Console do IIS clique na Instancia do Servidor > Application Pool > POOL_DA_APLICAÇÂO

    Depois clique com o botão direito em cima do Pool da aplicação e selecione a opção "Advance Settings"

    Nas configurações do Process Model procure pelo parâmetro Identity e altere para LocalSystem 

    No Console do IIS clique na Instancia do Servidor > Sites > NOME_DO_SITE > Authentication

    Nas configurações de Authentication clique com o botão direito em cima da opção "Anonymous Authentication" e selecione Edit...

    Selecione a opção Application Pool identity e clique em OK

    Esta foi a unica solução que encontrei para o erro 401.2, isso também é um requisito para rodar o Crystal Reports no IIS.

    Espero ter lhe ajudado.

    Atenciosamente

    João Paulo de Andrade

    terça-feira, 5 de junho de 2012 17:42