locked
MSExchangeSA para depois arranca RRS feed

  • Pergunta

  • Primeiro da-me este erro

    The MAD Monitoring thread was unable to connect to WMI, error '0x80041014'.

    depois  arranca

    The MAD Monitoring thread is initializing.

    esta situação esta a contecer depois de a maquina ter tres shutdown´s inesperados por falta de energia fix restore do system state e sistema porem periodicamente aparecem-me esse erro no event viwer o que posso fazer para resolucionar esta situação

    quinta-feira, 25 de janeiro de 2007 00:05

Respostas

  • Ola Thunder,

    Cara vc não está com debug enable nestes servidores? O kb é para o teu exchange server (versão)?

    so.. quanto ao serviço dê uma olhada aqui http://technet.microsoft.com/en-us/library/bb124644.aspx

    Tente analisar o contexto geral, só existe este erro, houve alguma modificação, é que trabalhar com apenas um erro sem contexto pode nos levar a direções erradas de resolução de problema.

    quando isto começou a ocorrer?

    quinta-feira, 25 de janeiro de 2007 13:50
  • Visto que para mim esta situação foi nova e dificil de ultrapassar e porque pode acontecer a mais alguem, o procedimento que utilizei para corrigir o problema foi.

    Verifiquei que ao correr o comando C:\WINDOWS\system32\wbem>mofcomp.exe exwmi.mof referido no KB http://support.microsoft.com/default.aspx?scid=kb;en-us;Q288590 indicado pelo Anderson dava erro:

    C:\WINDOWS\system32\wbem>mofcomp.exe exwmi.mof
    Compilador MOF a 32 bits da Microsoft (R) versão 5.2.3790.1830
    Copyright (c) Microsoft Corp. 1997-2001. Todos os direitos reservados.
    A analisar o ficheiro MOF: exwmi.mof
    O ficheiro MOF foi analisado com êxito
    A armazenar dados no repositório...
    Ocorreu um erro ao abrir o espaço de nomes para o objecto 1 definido nas linhas
    10 - 13:
    Erro n·mero: 0x80041014, Recurso: WMI
    DescriþÒo: Falha na inicializaþÒo
    Erro devolvido pelo compilador 0x80041014
    C:\WINDOWS\system32\wbem>


    como é perceptivel , e ao analisar o mesmo deparei-me com a informação de erro a bolt, logo o problema já deriva do WMI "WinMgmt", e como verificar.

    EventViwer verificar se temos o erro.WinMgmt Event ID 27
    WinMgmt could not open the repository file. This could be due to insufficient security access to the "<%SystemRoot%>\System32\WBEM\Repository", insufficient disk space or insufficient memory.

    Porem a informação acima pode ser relativa visto o espaço em disco estar disponivel bem como a memoria, mesmo assim e para despistar defenitivamente seguir as indicações em baixo.

    Ir a My computer lado direito do rato sobre este,  Manage ir até Services and Applications WMI lado direito do rato properties se este fizer loading e mostrar informação principalmente no tab security optimo , se não mostrar temos problema e ai temos a certeza que deriva do
    WMI "WinMgmt que foi o que me aconteceu.

    Para solucionar esta questão:

    Ir a C:\WINDOWS\system32\wbem\Repository

    Renomear o directório Repository para
    Repository_BCK e fazer reboot á maquina, assim o sistema faz o rebuid deste directorio, assim o erro WinMgmt foi corrigido.

    voltei a executar o

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q288590 referido pelo anderson

    e output já foi diferente

    Microsoft (R) 32-bit MOF Compiler Version 1.50.1085.0007
    Copyright (c) Microsoft Corp. 1997-1999. All rights reserved.

    Parsing MOF file: exwmi.mof
    MOF file has been successfully parsed
    Storing data in the repository...
    Done!
    depois desta fase ainda executei os dois comandos descritos no KB

    mofcomp.exe -n:root\cimv2\applications\exchange wbemcons.mof

    mofcomp.exe -n:root\cimv2\applications\exchange smtpcons.mof

    Fiz reboot á maquina e FINALMENTE tenho e EventViwer Limpinho.

    ps: Obrigado Anderson como sempre pela dica do KB

    Espero que este Post possa vir a ser util.
    quarta-feira, 31 de janeiro de 2007 10:28

Todas as Respostas

  • Ola Thunder,

    Tudo tranquilo? Experimente este kb http://support.microsoft.com/default.aspx?scid=kb;en-us;Q288590

    quinta-feira, 25 de janeiro de 2007 00:41
  • Tudo em cima anderson, segui o KB a pasta encontra-se no systemroot\wbem passo para o 4 passo e executo o comando o pior é que este não acaba com sucesso recebo o seguinte output

    C:\WINDOWS\system32\wbem>mofcomp.exe exwmi.mof
    Compilador MOF a 32 bits da Microsoft (R) versão 5.2.3790.1830
    Copyright (c) Microsoft Corp. 1997-2001. Todos os direitos reservados.
    A analisar o ficheiro MOF: exwmi.mof
    O ficheiro MOF foi analisado com êxito
    A armazenar dados no repositório...
    Ocorreu um erro ao abrir o espaço de nomes para o objecto 1 definido nas linhas
    10 - 13:
    Erro n·mero: 0x80041014, Recurso: WMI
     DescriþÒo: Falha na inicializaþÒo
    Erro devolvido pelo compilador 0x80041014
    C:\WINDOWS\system32\wbem>

     

     o que possa fazer agora isto porque no KB não me parece que eles estejam á espera que aconteça o que aconteceu no descrito.

    pergunta o MSExchangeSA serve exactamente para q ???????

    quinta-feira, 25 de janeiro de 2007 13:26
  • Ola Thunder,

    Cara vc não está com debug enable nestes servidores? O kb é para o teu exchange server (versão)?

    so.. quanto ao serviço dê uma olhada aqui http://technet.microsoft.com/en-us/library/bb124644.aspx

    Tente analisar o contexto geral, só existe este erro, houve alguma modificação, é que trabalhar com apenas um erro sem contexto pode nos levar a direções erradas de resolução de problema.

    quando isto começou a ocorrer?

    quinta-feira, 25 de janeiro de 2007 13:50
  • Boas anderson o debug??? ajuda-me o que é onde se activa???

     

    o Meu exchange é o 2003 ainda com serviçe pack 1, se colocar o serviçe pack 2 achas que pode resolver?

     
    O contesto ou a causa para estar com este problema é o facto da maquina servidor ter feito shutdown 3 vezes seguidas.... pois eu sei nºao tenho UPS

    quinta-feira, 25 de janeiro de 2007 17:15
  • Visto que para mim esta situação foi nova e dificil de ultrapassar e porque pode acontecer a mais alguem, o procedimento que utilizei para corrigir o problema foi.

    Verifiquei que ao correr o comando C:\WINDOWS\system32\wbem>mofcomp.exe exwmi.mof referido no KB http://support.microsoft.com/default.aspx?scid=kb;en-us;Q288590 indicado pelo Anderson dava erro:

    C:\WINDOWS\system32\wbem>mofcomp.exe exwmi.mof
    Compilador MOF a 32 bits da Microsoft (R) versão 5.2.3790.1830
    Copyright (c) Microsoft Corp. 1997-2001. Todos os direitos reservados.
    A analisar o ficheiro MOF: exwmi.mof
    O ficheiro MOF foi analisado com êxito
    A armazenar dados no repositório...
    Ocorreu um erro ao abrir o espaço de nomes para o objecto 1 definido nas linhas
    10 - 13:
    Erro n·mero: 0x80041014, Recurso: WMI
    DescriþÒo: Falha na inicializaþÒo
    Erro devolvido pelo compilador 0x80041014
    C:\WINDOWS\system32\wbem>


    como é perceptivel , e ao analisar o mesmo deparei-me com a informação de erro a bolt, logo o problema já deriva do WMI "WinMgmt", e como verificar.

    EventViwer verificar se temos o erro.WinMgmt Event ID 27
    WinMgmt could not open the repository file. This could be due to insufficient security access to the "<%SystemRoot%>\System32\WBEM\Repository", insufficient disk space or insufficient memory.

    Porem a informação acima pode ser relativa visto o espaço em disco estar disponivel bem como a memoria, mesmo assim e para despistar defenitivamente seguir as indicações em baixo.

    Ir a My computer lado direito do rato sobre este,  Manage ir até Services and Applications WMI lado direito do rato properties se este fizer loading e mostrar informação principalmente no tab security optimo , se não mostrar temos problema e ai temos a certeza que deriva do
    WMI "WinMgmt que foi o que me aconteceu.

    Para solucionar esta questão:

    Ir a C:\WINDOWS\system32\wbem\Repository

    Renomear o directório Repository para
    Repository_BCK e fazer reboot á maquina, assim o sistema faz o rebuid deste directorio, assim o erro WinMgmt foi corrigido.

    voltei a executar o

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q288590 referido pelo anderson

    e output já foi diferente

    Microsoft (R) 32-bit MOF Compiler Version 1.50.1085.0007
    Copyright (c) Microsoft Corp. 1997-1999. All rights reserved.

    Parsing MOF file: exwmi.mof
    MOF file has been successfully parsed
    Storing data in the repository...
    Done!
    depois desta fase ainda executei os dois comandos descritos no KB

    mofcomp.exe -n:root\cimv2\applications\exchange wbemcons.mof

    mofcomp.exe -n:root\cimv2\applications\exchange smtpcons.mof

    Fiz reboot á maquina e FINALMENTE tenho e EventViwer Limpinho.

    ps: Obrigado Anderson como sempre pela dica do KB

    Espero que este Post possa vir a ser util.
    quarta-feira, 31 de janeiro de 2007 10:28
  • Ola Thunder,

    perfeito! Muito bom, agora com este tip de problema no fórum o pessoal já vai utilizar este teu step-by-step para resolver o problema. Já marquei também como válido teu post :)

    Obrigado

    quarta-feira, 31 de janeiro de 2007 10:48