none
Acentos em scripts vbs RRS feed

  • Pergunta

  • Senhores,

     

    Surgiu a necessidade de um cliente de adicionar um determinado grupo do dominio na maquina local. Até ai tudo bem o script que tenho faz esse serviço, porém quando tento incluir o grupo do dominio no grupo usuários avançados da maquina local não rola acredito que é por causa do acento e a cedilha pois com grupos que não tenha esses caracteres funciona na boa, ja tentei com SID do grupo usuários avançados que é universal mas sem resultado.

    Alguem poderia me ajudar?

    quarta-feira, 26 de setembro de 2007 14:10

Respostas

  • Tenta o script abaixo, este funciona! Apenas não esqueça de mudar o que está em vermelho.

     

    Code Snippet

    Set wshNetwork = WScript.CreateObject( "WScript.Network")
    strComputer = WshNetwork.ComputerName
    Set objGroup = GetObject("WinNT://" & strComputer & "/Usuários Avançados,group")

    Set objUser = GetObject("WinNT://" & strComputer & "/UsuarioTeste,user")
    objGroup.Add(objUser.ADsPath)

     

     


    quarta-feira, 26 de setembro de 2007 19:08

Todas as Respostas

  • Tenta o script abaixo, este funciona! Apenas não esqueça de mudar o que está em vermelho.

     

    Code Snippet

    Set wshNetwork = WScript.CreateObject( "WScript.Network")
    strComputer = WshNetwork.ComputerName
    Set objGroup = GetObject("WinNT://" & strComputer & "/Usuários Avançados,group")

    Set objUser = GetObject("WinNT://" & strComputer & "/UsuarioTeste,user")
    objGroup.Add(objUser.ADsPath)

     

     


    quarta-feira, 26 de setembro de 2007 19:08
  •  

    Cara muito obrigado, mas descobri algumas funções que estavam erradas no meu vbs. e deu certo.

    Muito obrigado.

    quinta-feira, 27 de setembro de 2007 14:50
  • Classifica o assunto para finalizar.

     

    quinta-feira, 27 de setembro de 2007 14:55