none
RECURSO SQL SERVER EM CLUSTER NÃO SOBE RRS feed

  • Pergunta

  • Boa noite,

    Após uma migração, estou tendo problemas para iniciar o recurso SQL SERVER em um dos nós em ambiente cluster (Instância nomeada); alguém já passou por algo parecido? a única maneira que conseguimos fazer o recurso ficar online novamente foi desabilitando o protocolo via e iniciando o serviço na mão ao invés do cluster admin..

    Obrigado!!
    segunda-feira, 7 de setembro de 2009 02:04

Respostas

  • Olá Sergio... se a mensagem é exatamente igual, muito possivelmente a solução é a mesma que citei no artigo. NO meu caso o problema estava relacionado a um erro na digitação das portas TCPIP em Portas, que acabei colocando ; no lugar de , .

    Notei que vc disse estar usando um instância nomeada certo? Então neste caso fique atendo para no ponto onde remove a entrada para "/MSSQL.1/MSSQLServer" vc deve informar não MSSQLServer mas sim o nome da sua intância nomeada, ou ainda exatamente conforme aparece na lista quando vc executar


    C:/>cluster res "SQL Server" /checkpoints

    abraços
    Nilton Pinheiro
    Está com dúvida de Infra, acesse o TechNet - http://forums.microsoft.com/Technet-BR/default.aspx
    segunda-feira, 7 de setembro de 2009 23:09
    Moderador

Todas as Respostas

  • Sergio você já verificou se no evento do windows teu sql não estourou nenhum erro não? Já peguei pepino assim, e tive que deixar realmente o protocolo via disable, isto ocorreu por problema internos na rede do cliente, dai , disabilitou protocolo tpc ip e automaticamente subiu o via? isto verifiquei pelo evento do windows. O que eu fiz: " disable o via e enable o tcp ip e tudo ficou lindamente", verifique se ninguém alterou via configuration manager algo ok? Ou se por  outro motivo mexeram na configuração da sua lan ;), isto ocorre muitas vezes por este motivo. Outro teste legal é você fazer teste via assistente do cluster você pode achar seu problema , seguindo os parâmetros acima cidados.


    Espero ter ajudado, abraços do amigo Maycon Alves...
    Maycon Alves D. Costa - GEMSPE - www.gemspe.com
    segunda-feira, 7 de setembro de 2009 12:27
  • Boa noite Maycon,

    As mensagens de erro são idênticas ao artigo do Nilton Pinheiro (muito bom por sinal) no link http://www.mcdbabrasil.com.br/modules.php?name=News&file=article&sid=475 ; porém, os passos recomendados por ele não resolveram no meu caso. Aparentemente o problema é mesmo no protocolo VIA, o problema é que quando se tenta iniciar o recurso SQL pelo cluster admin ele habilita o protocolo VIA e falha para iniciar..

    Obrigado!

    Att.
    Sérgio Duarte
    segunda-feira, 7 de setembro de 2009 22:32
  • Olá Sergio... se a mensagem é exatamente igual, muito possivelmente a solução é a mesma que citei no artigo. NO meu caso o problema estava relacionado a um erro na digitação das portas TCPIP em Portas, que acabei colocando ; no lugar de , .

    Notei que vc disse estar usando um instância nomeada certo? Então neste caso fique atendo para no ponto onde remove a entrada para "/MSSQL.1/MSSQLServer" vc deve informar não MSSQLServer mas sim o nome da sua intância nomeada, ou ainda exatamente conforme aparece na lista quando vc executar


    C:/>cluster res "SQL Server" /checkpoints

    abraços
    Nilton Pinheiro
    Está com dúvida de Infra, acesse o TechNet - http://forums.microsoft.com/Technet-BR/default.aspx
    segunda-feira, 7 de setembro de 2009 23:09
    Moderador
  • Sérgio,

    Você configurou o SQL Server sobre o Windows Cluster de que forma?


    Você realizou alguma alteração no nome da instância?
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    terça-feira, 8 de setembro de 2009 14:20
    Moderador