none
ComboFix retirou a "default instance" do sql server 2000, o que fazer? RRS feed

  • Pergunta

  • Seguinte, o software de remoção de malwares "ComboFix", ao executar e consequentemente voltar de uma reinicialização, aparece a seguinte mensagem (e toda vez que se inicia o windows volta a aparecer esta mensagem):

    Free Image Hosting at www.ImageShack.us

    E consequentemente, não se tem acesso às bases de dados. Em "Sql Server Service Manager" (ao lado do relógio), o campo "Server" aparece em branco.
    Na minha opinião ele apagou a instância principal, e teria que criar uma nova instância principal, estou certo?

    O que fazer???

    Um grande abraço a todos!
    • Editado José Wagner sábado, 4 de julho de 2009 00:02
    • Movido Gustavo Maia Aguiar sábado, 4 de julho de 2009 14:47 (De:SQL Server - Desenvolvimento Geral)
    sábado, 4 de julho de 2009 00:00

Todas as Respostas

  • Bom Dia,

    Acho que ele nao apagou, acho apenas que o servico do SQL Server nao esta iniciado.
    Va em ferramentas administrativas, servicos e inicie o servico do SQL Server.

    Estou movendo a duvida, pois, ela nao esta relacionada a desenvolvimento - SQL Server

    [ ]s,

    Gustavo Maia Aguiar
    http://gustavomaiaaguiar.spaces.live.com

    O que é Cross Database Ownership Chaining ? - Parte I
    http://gustavomaiaaguiar.spaces.live.com/blog/cns!F4F5C630410B9865!620.entry


    Classifique as respostas. O seu feedback é imprescindível
    sábado, 4 de julho de 2009 14:47
  • Infelizmente não funcionou.

    Free Image Hosting at www.ImageShack.us

    Então, fui neste serviço cliquei em iniciar e deu a mesma mensagem acima.
    Era este o serviço???

    Talvez realmente seja instancia não?!

    Um grande abraço e muito obrigado!
    segunda-feira, 6 de julho de 2009 11:29
  • Bom Dia José,

    Infelizmente a rede em que estou não acessar o ImageShacks. A menos que alguém responda, irei verificar sua dúvida posteriormente.

    [ ]s,

    Gustavo Maia Aguiar
    http://gustavomaiaaguiar.spaces.live.com

    Certificados, Cross Database Ownership Chaining e Segurança
    http://gustavomaiaaguiar.spaces.live.com/blog/cns!F4F5C630410B9865!622.entry


    Classifique as respostas. O seu feedback é imprescindível
    segunda-feira, 6 de julho de 2009 12:19
  • Tranquilo Gustavo!
    Vou digitar a mensagem de erro que dá ao ligar o computador e ao inicar o serviço (clicar no botão de iniciar) do MSSQLSERVER (ferramentas administrativas -> servicos):

    SQL Server could not find the default instance (MSSQLSERVER) - please specify the name of an existence instance on the invocation of sqlservr.exe.
    If you believe that your installation is corrupt or has been tampered with, uninstall then re-run setup to correct this problem.
    (botáo de OK)

    E consequentemente, não se tem acesso às bases de dados. Em "Sql Server Service Manager" (ao lado do relógio), o campo "Server" aparece em branco.

    Será que tem solução?
    Isso é uma situação que todo mundo que um dia virá a utilizar o software de remoção de malwares: (combofix) irá passar!

    segunda-feira, 6 de julho de 2009 16:08
  • Olá José,

    Bem, essa mensagem já é mais grave do que as que eu esperava encontrar.

    - Você pode confirmar se a chave HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server existe na registry ? Qual o valor da entrada InstalledInstances ?

    - E o que tem na pasta Program Files\Microsoft SQL Server ? Quais são as subpastas ?

    [ ]s,

    Gustavo Maia Aguiar
    http://gustavomaiaaguiar.spaces.live.com

    Certificados, Cross Database Ownership Chaining e Segurança
    http://gustavomaiaaguiar.spaces.live.com/blog/cns!F4F5C630410B9865!622.entry


    Classifique as respostas. O seu feedback é imprescindível
    segunda-feira, 6 de julho de 2009 16:15
  • Bom dia,

    Estou com o mesmo problema do Sr. José Wagner.

    Posso continuar?

    Na chave citada o valor q aparece é: MSSQLSERVER

    Também meu SQL parou d funcionar com o uso do ComboFix.

    Muito Obrigado,

    José Fernando
    quinta-feira, 22 de outubro de 2009 10:40