none
Não consigo colocar o Office Sharepoint Server Search a funcionar RRS feed

  • Pergunta

  • Boas Pessoal,

     

    Será que alguém me consegue ajudar em resolver este problema que tenho com o serviço Office Sharepoint Server Search?

     

    Tenho a seguinte estrutura:

     

    DC1 -> Como domain controller, com active directory e com SQL 2005.

     

    DC2 -> sem ser domain controller e com o CA do Sharepoint, aqui apenas tenhos os serviços "Windows SharePoint Services Web Application" e "Windows SharePoint Services Help Search" como started.

     

    DC3 -> sem ser também domain controller e apenas com o papel de indexador, mas sempre que tento arrancar com o serviço "Office Sharepoint Server Search" a arrancar dá-me o seguinte erro:"An unhandled exception occurred in the user interface.Exception Information: The request failed with HTTP status 401: Unauthorized"

     

    No event viewer o erro do evento é:

     

    Event ID: 5000

    EventType ulsexception12, P1 w3wp.exe, P2 6.0.3790.3959, P3 45d6968e, P4 microsoft.office.server.search, P5 12.0.4518.0, P6 45439dcc, P7 2833, P8 183, P9 webexception, P10 837w.

     

    Event ID: 8193

    Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x800401f0.

     

    Já pesquisei várias formas de resolver, mas não funciona. Verifiquei updates, permissões e nada. Será que alguém pode dar umas dicas??

     

    Saudações

    Miguel

     

     

    quarta-feira, 20 de agosto de 2008 14:14

Respostas

  • Boas Pessoal,

     

    O objectivo deste serviço é devido ao querer fazer com que um dos servidores tenha o papel de indexador. Sei que também dá por outra maneira.

     

    Entretanto já se encontra resolvido. Reinstalei novamente o sharepoint nesse server e resolveu o problema.

     

    Saudações

    Miguel

    sexta-feira, 22 de agosto de 2008 15:10

Todas as Respostas

  • Olá Miguel,

    Qual seu objetivo em "arrancar" esse serviço? Imagino que esse serviço seja necessário na estrutura do SharePoint. Já verificou se isso não "passa por cima" das boas práticas da tecnologia?

    Abraços.

    --

    SharePoint Professional

    MCTS: .NET  | WSS 3.0 | MOSS 2007

    MCPD: Web Developer

    Microsoft Profissional 5 Estrelas

    MSF & SCRUM Practitioner

    --

    wa.amorim@hotmail.com

    http://waamorim.spaces.live.com/

     

    sexta-feira, 22 de agosto de 2008 09:06
  • Boas Pessoal,

     

    O objectivo deste serviço é devido ao querer fazer com que um dos servidores tenha o papel de indexador. Sei que também dá por outra maneira.

     

    Entretanto já se encontra resolvido. Reinstalei novamente o sharepoint nesse server e resolveu o problema.

     

    Saudações

    Miguel

    sexta-feira, 22 de agosto de 2008 15:10
  •  

    Miguel,

     

     

    Antes de vc ter instalado o moss novamente, vc olhou em Services on Server se todos os serviços estavam rodando normalmente? no canto superior esquerdo da tela de administration do sharepoint se estava apresentando alguma mensagem em vermelho? Verifique também, se foi criado um User para fazer APENAS o search e index na base de dados do SQL.

     

    Qualquer dúvida estou a disposição.

     

     

    Att,

    terça-feira, 2 de setembro de 2008 03:35
  •  

    Boas Fabio,

     

    Na altura cheguei a olhar para os serviços, mas não conseguia colocar o serviço de search em modo started, dava um erro de código. Mas com actualizações resolveu o problema.

     

    Obrigado.

    quinta-feira, 11 de setembro de 2008 15:41