none
Problema do INSTALLSHAREDDIR, existe solução para instalar, e para desinstalar??? RRS feed

  • Pergunta

  • Olá a todos

    Estou com um problema complicado aqui.

    Removi uma versão do SQL Server 2005 num servidor windows 2008 64 que tenho aqui e instalei a versão do SQL Server 2008 com o Reporting Services.

    Durante a instalação deu o erro do INSTALLSHAREDDIR que tem vários tópicos no fórum da Microsoft sobre ele.

    Fiz a instalação executando o setup indicando as variáveis, como no exemplo abaixo:

    setup.exe /action=Repair /INSTALLSHAREDWOWDIR="C:\Program Files (x86)\Microsoft SQL Server" /INSTALLSHAREDDIR="C:\Program Files\Microsoft SQL Server"

    Agora o problema é o seguinte, não sei porque motivo, mas o reporting services não funciona. Esta dando um erro de ASP.NET no Event Viewer.

    Então, iria tentar uma reinstalação completa, porém, não consigo remover o SQL Server porque ocorre este mesmo erro do INSTALLSHAREDDIR.

    Já achei posts em inglês sobre este problema, mas sem solução.

    Vocês tem alguma idéia?

    Ahhh, existem informações de que no SQL Server 2008 R2 esse problema estaria corrigido, mas não. A versão que instalei foi a R2.

    Obrigado

    Fábio

    sexta-feira, 12 de novembro de 2010 18:48

Todas as Respostas

  • Fábio,

    Qual é a mensagem de erro relacionada ao Reporting Services?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    domingo, 14 de novembro de 2010 00:38
    Moderador
  • Olá Júnior, obrigado pela resposta.

    Segue abaixo o erro:

    Log Name:      Application
    Source:        ASP.NET 2.0.50727.0
    Date:          12/11/2010 17:15:48
    Event ID:      1334
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      xyz
    Description:
    Failed to initialize the AppDomain:ReportManager_MSSQLSERVER_0

    Exception: System.Configuration.ConfigurationErrorsException

    Message: Unrecognized element 'folderLevelBuildProviders'. (C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config line 349)

    StackTrace:    at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
       at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)
       at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ASP.NET 2.0.50727.0" />
        <EventID Qualifiers="49152">1334</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-11-12T19:15:48.000Z" />
        <EventRecordID>114408</EventRecordID>
        <Channel>Application</Channel>
        <Computer>www2</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Failed to initialize the AppDomain:ReportManager_MSSQLSERVER_0

    Exception: System.Configuration.ConfigurationErrorsException

    Message: Unrecognized element 'folderLevelBuildProviders'. (C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config line 349)

    StackTrace:    at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
       at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
       at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)
       at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)</Data>
      </EventData>
    </Event>

    Mas agora já não sei mais o que fazer. Fui tentar desinstalar o SQL Server e segui uma sugestão para usar o "Windows Install Clean Up", mas.... só piorou a situação.

    Acho isso um absurdo, acho que vou ter que reinstalar o sistema operacional por conta do SQL Server. Não consigo acreditar nisso... e o servidor está em produção.

    Ou, a outra alternativa é "tentar" achar alguma documentação da Microsoft com todas as chaves no registro que são inseridos na instalação e tentar remover manualmente, mas já vi posts de pessoas que tentaram remover desta forma e não conseguiram...

    Qualquer ajuda é valida!!! heheh

    Obrigado

    Fábio

    terça-feira, 16 de novembro de 2010 19:06