none
Erro de acesso ao fazer backup na rede RRS feed

  • Pergunta

  • Boa tarde Srs,

    estou tentando fazer backup pela rede, mas esta dando "Acesso Negado".

    Obs: o usuário que executa a rotina esta como adm(domínio), acessei o servidor de banco com o mesmo usuário e executei na mão e fez normalmente sem da erro. Alguém ja viu isso ?

    segunda-feira, 9 de maio de 2011 17:44

Respostas

  • Bom dia,

    consegui achar o problema, meu backup Full estava como "COPY_ONLY", quando tentava rodar o backup de Log, ele não achava o Full e não deixava fazer o backup de log, mas a mensagem ajudou pra caramba "Acesso Negado '-- " a mensagem não tem nada a ver com o problema...

    Obrigado a todos que deram uma luz no meu problema

    • Marcado como Resposta Andre_Bel quinta-feira, 12 de maio de 2011 13:59
    quinta-feira, 12 de maio de 2011 13:58

Todas as Respostas

  • Andre,

     

    A conta que executa o SQL Server tem permissão de acesso ao diretório da rede utilizado para o backup?

     

    Abraço


    Erickson Ricci SQL Server DBA @ BB Mapfre Email: ericksonfabricio@gmail.com Blog: ericksonricci.wordpress.com Twitter: @EricksonRicci TS: Microsoft SQL Server 2008, Database Development TS: Microsoft SQL Server 2008, Implementation and Maintenance TS: Microsoft SQL Server 2005, Implementation and Maintenance
    segunda-feira, 9 de maio de 2011 17:59
  • Boa tarde Erickson,

    tem acesso total.

    segunda-feira, 9 de maio de 2011 18:04
  • Andre, boa tarde. Qual é a mensagem exata que é gerada?
    segunda-feira, 9 de maio de 2011 19:08
  • Segue Vinicius,


    Executed as user: Usuário. Cannot open backup device '\\LOCAL\FACNEW1_D0705_H1700.trn'. Operating system error 67(O nome da rede não foi encontrado.). [SQLSTATE 42000] (Error 3201)  BACKUP LOG is terminating abnormally. [SQLSTATE 42000] (Error 3013).  The step failed

    segunda-feira, 9 de maio de 2011 19:19
  • Andre, e você consegue acessar esse caminho normalmente via windows?
    segunda-feira, 9 de maio de 2011 20:04
  • Sim...

    se me logar no server do banco de dados com o login que irá executar a rotina, e rodar manualmente ele faz o backup normalmente, porém se criar um JOB e mandar rodar ele da o erro:

    Executed as user: Usuário. Cannot open backup device '\\LOCAL\FACNEW1_D0705_H1700.trn'. Operating system error 67(O nome da rede não foi encontrado.). [SQLSTATE 42000] (Error 3201)  BACKUP LOG is terminating abnormally. [SQLSTATE 42000] (Error 3013).  The step failed

    segunda-feira, 9 de maio de 2011 20:48
  • André, bom dia. Qual conta de usuário está vinculado nos serviços (agent e sql)?
    terça-feira, 10 de maio de 2011 12:15
  • Bom dia Vinicius,

    é um usuário do domínio com permissões de administrador.

    terça-feira, 10 de maio de 2011 13:51
  • André, antes você conseguia realizar o backup sem problema? Não sei, foi alterado alguma configuração, a pasta está compartilhada corretamente? Sl, no compartilhamento, além de deixar as permissões para os usuários administradores, tente colocar o nome especifico deste usuário na pasta. Pelo erro, só parece ser algo nas permissões mesmo.
    terça-feira, 10 de maio de 2011 14:08
  • Foi a primeira vez que criei a rotina de backup nesse server. Sim esta compartilhado corretamente, conferi todas as permissões, dei permissão direto para o usuário. Mas continua o mesmo erro.
    terça-feira, 10 de maio de 2011 14:37
  • André,

    Nas propriedades do seu Job, você configurou a conta Administrador como Owner?

    Faça o seguinte, deixe este compartilhamento de rede mapeado neste servidor e tente executar o backup.

    Mesmo não sendo a solução mais indicada ou correta uma alternativa seria criar um Backup Device especificando este caminho de rede nas propriedades do Backup Device e tentar realizar o backup.

    Outra alternativa fora do SQL Server seria criar um rota direta entre estes servidores através do endereço IP fazendo uso do comando Route Add.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quarta-feira, 11 de maio de 2011 13:32
    Moderador
  • Andre, envie o script que você está colocando no JOB.

    quarta-feira, 11 de maio de 2011 16:10
  • Bom dia,

    consegui achar o problema, meu backup Full estava como "COPY_ONLY", quando tentava rodar o backup de Log, ele não achava o Full e não deixava fazer o backup de log, mas a mensagem ajudou pra caramba "Acesso Negado '-- " a mensagem não tem nada a ver com o problema...

    Obrigado a todos que deram uma luz no meu problema

    • Marcado como Resposta Andre_Bel quinta-feira, 12 de maio de 2011 13:59
    quinta-feira, 12 de maio de 2011 13:58
  • Nossa! Essa mensagem ajudou mesmo. Mas oq eu achei estranho foi que você comentou que manualmente o backup era realizado sem problemas. Manualmente você usou o mesmo script? Bem pelo menos o problema foi resolvido.
    quinta-feira, 12 de maio de 2011 14:31
  • por incrivel que pareça, utilizei o mesmo... rsrs... valeu pela força

    quinta-feira, 12 de maio de 2011 20:55