none
não consigo conexão remota no sql server 2005 RRS feed

  • Pergunta

  • Bom dia a todos, já li todos os post a respeito do assunto e tentei todas as dicas, porém não consigo me conectar remotamente, dá a seguinte mensagem "Sql server especificado não encontrado"

    o sql server 2005 está instalado em um windows 2000 professional,

    1)não há firewall nesta máquina,

    2)consigo pingar o servidor

    3)consigo dar um telnet na porta 1433,

    4)fixei a porta no protocolo TCP/IP para 1433,

    5)desabilitei todos os protocolos deixando apenas o TCP, habilitei todos também

    6)segui também passo a passo o manual postado pelo Ilustre André Hass (Posts679)

    Obs1: o estranho é que quando instalei o sql 2005 eu consegui conectar remotamente, e não sei o porque não estou mais conseguindo

    Obs2: Nessa minha máquina tenho também instalado o sql 2000, porém o mesmo está parado, não sei se há alguma influência.

    Qualquer diga agradeço

    Enio.

    • Movido Gustavo Maia Aguiar segunda-feira, 27 de junho de 2011 17:44 (De:SQL Server - Desenvolvimento Geral)
    terça-feira, 8 de agosto de 2006 13:30

Respostas

  • Olá Tiago,

    Minha sugestão é que vc deixe a porta 1433 na instância que vc utiliza com maior frequência? Na dúvida, deixa a 1433 para o SQL Server 2000, coloque 14330 no SQL Server 2005 e suba o serviço SQL Server Browser, ele fará o mapeamento da porta\ instância no SQL Server 2005.

    Um abraço
    Nilton Pinheiro
    www.mcdbabrasil.com.br

    Ps: Foi útil para vc? Então marque o psot como útil!

    sexta-feira, 9 de fevereiro de 2007 00:29
  • Bruno,

     

    Voce disse que efetuou um checkList de conexão, porem se possivel de uma olhada neste link e veja se existe algum step que voce não fez.

    http://fabrizziocaputo.wordpress.com/2011/06/08/conexoes-no-sql-server/

    Outra coisa, voce disse 3 meses, bom, voce estava utilizando um versão licenciada ou versão trial?


    Oracle OCA11g, MCTS SQL Server 2008, MCC 2011! Dicas e novidades: www.fabrizziocaputo.wordpress.com http://www.tripletech.com.br/blog/ Twitter: @FabrizzioCaputo
    segunda-feira, 27 de junho de 2011 16:49
    Moderador

Todas as Respostas

  • Nesse seu caso pode ser um conflito na propria porta sql server 2000 e 2005 usam por default a mesma porta , faz um teste tenta mudar a porta padrão que é a tcp 1433 e tente fazer a conexão.

    Espero ter ajudado.

    terça-feira, 8 de agosto de 2006 13:48
  • Já tentou também parar o serviço do SQL Server 2000 e testar fazer a conexão com o SQL Server 2005?

     

    terça-feira, 8 de agosto de 2006 14:34
    Moderador
  • Como o SQL 2000 também está instalado neste servidor vc não teria
    instalado o SQL 2005 em outra instância? Tente conectar usando
    servidor\nome da instância (ex: server\sql2005)

    terça-feira, 8 de agosto de 2006 14:47
  • veja tambem no surface area connection, se esta habilitado para conexoes remotas.

     

    Abs;

    terça-feira, 8 de agosto de 2006 14:50
  • Enio,

    Completando a resposta do Colla.

    Verifique se esta habilitado para o protocolo TCP/IP, a opção de conexões locais e remotas, através da ferramenta de configuração Surface Área Configuration do SQL Server 2005.

    terça-feira, 8 de agosto de 2006 16:23
    Moderador
  • Caro José Ricardo, o nome da instância é analista_02\sql2005, como já mencionei antes eu já consegui me conectar remotamente, o problema é que parou e não sei o que aconteceu.Tá sendo um mistério isso.
    terça-feira, 8 de agosto de 2006 16:25
  •  

     tente sqlcmd -Sanalista_02\sql2005 -E -- no prompt de comandos remoto e no console para testar e depois retorne.

     

    Abs;

    terça-feira, 8 de agosto de 2006 16:29
  • Olá tudo bem?

    Seguinte eu sei que o problema é o conflito na porta 1344 que é do tcp/ip, mas eu quero saber qual a porta que eu mudo tipo o numero mesmo e em qual sql server 2000 ou 2005?

     

     

    disculpa a minha ignorância e obrigado pela atenção

    quinta-feira, 8 de fevereiro de 2007 19:36
  • Olá Tiago,

    Minha sugestão é que vc deixe a porta 1433 na instância que vc utiliza com maior frequência? Na dúvida, deixa a 1433 para o SQL Server 2000, coloque 14330 no SQL Server 2005 e suba o serviço SQL Server Browser, ele fará o mapeamento da porta\ instância no SQL Server 2005.

    Um abraço
    Nilton Pinheiro
    www.mcdbabrasil.com.br

    Ps: Foi útil para vc? Então marque o psot como útil!

    sexta-feira, 9 de fevereiro de 2007 00:29
  • Estou com o mesmo problema aqui ...

    Instalei há alguns meses o SQL Server 2005 , e por inicio, durante uns 3 meses, utilizei acesso remoto com exito. Em um belo dia, para ser mais exato quarta-feira passada, parou do nada a conexao. Sem mais nem menos, não conecta de geito algum .... Ja verifique portas, configuraçao para acesso remoto do sql em si, portas do modem..., está tudo ok! .

    Seguindo a sugestão do nosso amigo Marcelo Colla, ao digitar no DOS  sqlcmd -SERVIDOR\sql2005 -E, (SERVIDOR é o nome do server), aparece o seguinte erro:

    HResult 0x35, Level 16, State 1
    Named Pipes Provider: Could not open a connection to SQL Server [53].
    Error: Microsoft SQL Native Client : An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections..

    Error: Microsoft SQL Native Client : Login timeout expired.

     

    Por favor, me ajudem.

     

    Desde já agradeço,

     

    Obrigado.

    segunda-feira, 27 de junho de 2011 16:46
  • Bruno,

     

    Voce disse que efetuou um checkList de conexão, porem se possivel de uma olhada neste link e veja se existe algum step que voce não fez.

    http://fabrizziocaputo.wordpress.com/2011/06/08/conexoes-no-sql-server/

    Outra coisa, voce disse 3 meses, bom, voce estava utilizando um versão licenciada ou versão trial?


    Oracle OCA11g, MCTS SQL Server 2008, MCC 2011! Dicas e novidades: www.fabrizziocaputo.wordpress.com http://www.tripletech.com.br/blog/ Twitter: @FabrizzioCaputo
    segunda-feira, 27 de junho de 2011 16:49
    Moderador