none
Copia Arquivos da Pasta Full e Não Copia da Pasta Master usando XCOPY RRS feed

  • Pergunta

  • Olá companheiros, gostaria de solicita a ajuda de vocês pra solucionar o seguinte mistério, no qual ainda me incomoda.

    Estou com esses dois scripts abaixo:

    XCOPY /s /e /i D:\"Backups PastaBak"\FULL\full\*.bak \\10.10.0.1\Bkp$\BkpPasta\full
    
    XCOPY /s /e /i D:\"Backups PastaBak"\FULL\master\*.bak \\10.10.0.1\Bkp$\BkpPasta\master

    Ambas as pastas tem em seu conteúdo arquivos de backups dos bancos de dados como descrito acima de uma determinada instância. Configurei um job e adicionei o mesmo no plano de rotina de backup. No job adicionei esses dois scripts e ai que vem o mistério. A execução do job ocorre sem erro, porém somente os arquivos do primeiro script é copiado e do segundo não. Ambas as pastas encontrasse no mesmo volume D:\.

    Alguém teria uma sugestão do que poderia está ocorrendo?

    Agradeço desde já!

    sexta-feira, 10 de janeiro de 2014 14:35

Respostas

  • Jerfeson,

    Tente utilizar o aplicativo robocopy, veja este artigo: 


    Fonte: http://www.linhadecodigo.com.br/artigo/1342/copiando-dados-com-o-robocopy.aspx

    Atenciosamente,


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    sexta-feira, 10 de janeiro de 2014 14:54

Todas as Respostas

  • Jerfeson,

    Tente utilizar o aplicativo robocopy, veja este artigo: 


    Fonte: http://www.linhadecodigo.com.br/artigo/1342/copiando-dados-com-o-robocopy.aspx

    Atenciosamente,


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    sexta-feira, 10 de janeiro de 2014 14:54
  • Jerfeson, o link ajudou? novidade?

    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    quinta-feira, 16 de janeiro de 2014 23:55
  • Grande Edinaldo, 

    quero agradecer primeiramente pelo apoio e atenção na solução de minha dúvida.

    Conseguir resolver o problema alterando a definição do tipo de subsistema de "Operating System (cmdExec)" pra "PoweShell" usado no job do SQL Server.

    Usei o link pra me inteirar melhor sobre o comando e as opções de recursos disponíveis, inclusive utilizar em alguns jobs pra exportar arquivos.

    Agradeço a indicação.

     

    terça-feira, 21 de janeiro de 2014 13:04
  • Que bom que ajudou...abraço!

    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    terça-feira, 21 de janeiro de 2014 13:05
  • Edinaldo, só uma pequena dúvida que me surgiu esses dias.

    Estou fazendo a exportação dos arquivos .bak do banco master, msdb, model e da Base de Produção. Os arquivos das bases de sistemas estão sendo exportado normalmente, porém do Banco de produção dar o seguinte retorno de erro:

    E:\>robocopy "B:\Backups Base\FULL\Base" "\\10.10.0.2\Bkpbase$\Bkpbase\FULL" *.bak /E /V /R:10/W:30

    -------------------------------------------------------------------------------
       ROBOCOPY     ::     Robust File Copy for Windows

    -------------------------------------------------------------------------------

      Started : Sun Feb 09 21:32:07 2014

    2014/02/09 21:32:07 ERROR 3 (0x00000003) Getting File System Type of Source B:\B
    ackups Base\FULL\Base\
    The system cannot find the path specified.

       Source - B:\Backups Base\FULL\Base\
         Dest : \\10.10.0.2\Bkpbase$\Base\FULL\

        Files : *.bak

      Options : /V /S /E /COPY:DAT /R:10 /W:30

    ------------------------------------------------------------------------------

    2014/02/09 21:32:07 ERROR 3 (0x00000003) Accessing Source Directory B:\Backups Base\FULL\Base\
    The system cannot find the path specified.

    Ressalto que os scripts foram criados no mesmo job e somente o de produção não está sendo exportado. Achei que pudesse ser algo relacionado ao tamanho do arquivo que chega a 80GB, mas o retorno do erro não justificava minha suspeita.

    Agradeço desde já!




    segunda-feira, 10 de fevereiro de 2014 01:11
  • Parece que deu algum erro na rede...

    The system cannot find the path specified.

       Source - B:\Backups Base\FULL\Base\
         Dest : \\10.10.0.2\Bkpbase$\Base\FULL\

    Faz um teste salvando localmente...


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    segunda-feira, 10 de fevereiro de 2014 11:33