locked
Fila SMTP - Demora no envio - grande qtd de mensagens RRS feed

  • Pergunta

  • Olá, tenho um Windows Small Business Server com Exchange 2003 instalado e funcionando.
    Tenho todos os filtros de mensagens configurados e funcionando no Exchange e ainda tenho um ScanMail da Trend Micro rodando no server.

    O que ocorre é um demora no envio de e-mails de dentro para fora da empresa. Recebo alguns alertas do serviço da alertas do Small Business sobre o tamanho da fila.
    Estou com alguns problemas de alocação de momória por que meu hardware ainda não está com toda a memória instalada.

    Gostaria de saber pra onde posso partir pra tentar resolver esse problema, a alocação de memória pode estar influenciando muito?

    Obrigado pela ajuda.

    terça-feira, 1 de agosto de 2006 15:29

Respostas

Todas as Respostas

  • Ola Max Carvalho,

    Resolução DNS deste servidor para internet está tranquila? qual erro apresentado no eventviewer?

    Rode um exbpa neste servidor para validar se está tudo ok.

     

    terça-feira, 1 de agosto de 2006 17:08
  • Aparentemente a minha resolução DNS está OK. Meu provedor de hospedagem faz um apontamento dos registros MX pro meu IP externo. Mas isso nunca deu problema, meu servidor é configurado como o primario.

    Se vc quiser, e puder, fazer um teste, meu IP é esse 200.207.52.95, domínio engendrar.com.br

    Não há nda no Event Viewer, nada sobre a fila remota de SMTP. Mas os meus e-mails não estão saindo.
    Enviei um e-mail hoje, as 8 da manhã, e ela ainda não foi enviado. Isso não estava acontecendo até pouco tempo atrás!

    Obrigado

    terça-feira, 1 de agosto de 2006 17:58
  • O Best Pratice Analyser Tool não gerou nenhum erro relacionado.
    Somente:

    "HeapDeCommitFreeBlock Threshold" not set
    Server XXXXX has 1GB or more of memory, accommodates 25 mailboxes, and the "HeapDeCommitFreeBlock Threshold" paramter has not been set to 262144. Virtual memory mjay become quickly fragmented and system instantly may occur.

    Não sei se isso teria algo a ver com o problema.

    terça-feira, 1 de agosto de 2006 18:24
  • Ola Max,

    Esta mensagem que vc enviou nao aparece nas queues do Exchange? como está o teu envio? Um smtp connector para fora?

    Olhe no Message tracking e nos passe estes logs para verificar se conseguimos identificar o problema.

     

    quarta-feira, 2 de agosto de 2006 17:20
  • Anderson, meu Default SMTP Virtual Server está usando a resolução de DNS local, assim como o SMTP Connector. o DNS está funcioando perfeitamente(não há erros no Event Viewer).

    No momento, eu desinstalei o ScanMail e as mensagens começaram a sair mais rapidamente. Até aí acho que o problema de alocação de memoria que eu citei estava influenciando.

    Meu Relay está fechado.
    Na Queue eu verifiquei que algums mensagens estão com ícones VERDES e estão saindo normalmente, outras estão com ícones AZUIS e dão a seguinte informação:

    The remote server did not respond to a connection attempt.

    E são domínios grandes, de clientes como SEW Motors.

    No link abaixo está uma imagem da minha Queue:

    www.engendrar.com.br/queue.gif

    quarta-feira, 2 de agosto de 2006 18:36
  • Olá Max,

    Tive um problema parecido com o seu, meu hardware tbem é com apenas 1GB de memoria e resolvi da seguinte forma:

    1º verifique se o seu IP não consta em nenhuma Blacklist veja: www.spamcop.net , isto faz com que muitos emails permanecam na fila até um determinado tempo, solicite a remoção do mesmo.

    2º muitos dominios hoje utilizam sistema de AntiSPAM que não aceitam nenhum tipo de msg de dominios que não tenham um DNS REVERSO para saber se o IP ja tem um veja: www.dnsstuff.com

    3º solicite para seu hospedar para criar um registro do tipo smtp-gw.seudominio.com.br (padrão locaweb) apontando para seu registro SMTP

    4º solicite para a operadora que te fornece a conexao criar um DNS Reverso com o nome citado acima. assim vc utiliza o DNS do seu hospedar para resolver algumas querys de dns

    5º aconselho vc a criar um registro tipo SPF veja: www.spf.pobox.com assim vc melhora a eficiencia / segurança dos seus emails pois será dificil entrar em uma lista de SPAM.

    Utilize um filtro de email conheço a empresa CTI que faz este tipo de serviço apenas desviando o seu MX para eles, e com isso vc ainda ganha um serviço de contingencia de emails ;-)
    veja:www.cti.com.br

    Na versão 2003 + SP2 vc consegue fazer mta coisa no Exchange portanto se vc ainda não utiliza o SP2 tente atualizar o mais depressa possivel veja este site MS para mensagem  segura: http://www.microsoft.com/securemessaging/default.mspx 

    Maiores informações:
    http://www.microsoft.com/technet/prodtechnol/exchange/downloads/2003/imf/default.mspx 

    Microsoft Exchange Server TechCenter
    http://www.microsoft.com/technet/prodtechnol/exchange/default.mspx

    TechNet Virtual Lab: Exchange
    http://www.microsoft.com/technet/traincert/virtuallab/exchange.mspx

    Anti-Spam Framework Overview
    http://www.microsoft.com/exchange/evaluation/features/antispam_framework.mspx

    Antispam Capabilities in Exchange Server 2003
    http://www.microsoft.com/exchange/evaluation/features/antispam.mspx

    espero que o seu problema seja parecido com o meu e assim minha dica tenha te ajudado.

    Fábio 

    • Marcado como Resposta Richard Juhasz quarta-feira, 5 de janeiro de 2011 18:17
    quarta-feira, 2 de agosto de 2006 19:29
  • Max,

    1- Verifique se o Antivírus do SO está configurado corretamente com todas as exclusões necessárias (este artigo vale para qualquer antivírus) http://esupport.trendmicro.com/support/viewxml.do?ContentID=EN-118716&id=EN-118716 .

    2- Rode o Exbpa para verificar o seu ambiente Exchange.

    http://www.microsoft.com/technet/prodtechnol/exchange/downloads/2003/analyzers/default.mspx

    3- Rode o MPSReports de Setup, AD e Exchange para verificar a saúde do SO, AD e Exchange.

    http://www.microsoft.com/downloads/details.aspx?familyid=cebf3c7c-7ca5-408f-88b7-f9c79b7306c0&displaylang=en

    4- Faça testes e verifique se a demora ocorre internamente, externamente, se for externa quais os domínios e etc.

    5- Faça testes de captura de protocolo com o Netmon ou Ethereal para verificar o que acontece na sua rede.

    http://support.microsoft.com/?id=310875

    http://www.ethereal.com/

    Boa sorte!

    • Marcado como Resposta Richard Juhasz quarta-feira, 5 de janeiro de 2011 18:17
    sexta-feira, 4 de agosto de 2006 13:36