none
Outlook 2007 e exchange 2007 RRS feed

  • Pergunta

  •  

    Prezados,

     

    Estou com alguns problemas em um server win2003 64x, ele está rodando o exchange 2007 e não comunica com os clientes outlook.

    Meu ambiente é de data center e exchange está funcionando, tando que roda via OWA. Consigo enviar emails inernos e externos sem problemas.

    Habilitei o anywhere, rpc over http e criei um certificado self ssf conforme os tutoriais do anderson patricio. (muito bons por sinal)

    Quanto ao outlook, ele não consegue validar o usuário para acesso ao exchange.

     

    O DNS está rodando no servidor para fins de testes, com a zona completa do email, na maquina que uso para o testo do outlook, aponto seu dns client para utilizar o dns do server, a fim de resolver os endereços sem conflitar com os NS atuais da empresa.

     

    Se alguem puder ajudar ou quiser mais detalhes por favor me contate.

     

    Agradeço pela atenção.

    terça-feira, 29 de abril de 2008 18:29

Respostas

  • Ola Simental,

     

    Se todo o acesso será via internet, realmente a tua solução é anywhere ou OWA.

    No seu caso, eu arrisco dizer que a configuração do Outlook para o Anywhere é que está errada, pois para conseguir acesso MAPI via internet apenas com o Anywhere mesmo.

    Reveja tua configuração local no Outlook, pode ser isso. E também se tiver algo nos logs poste aqui que ajuda.

     

    Abs.

     

    terça-feira, 29 de abril de 2008 19:02
  • Olá Simental,

     

         Como o Rodrigo já informou, eu também creio que seja problema de configuração no outlook client.

         Apenas para previnir que o processo de instalção do Exchange ocorreu com exito, que os serviços do Exchange estão funcionais e para checar os protocolos de acesso dos usuários, execute os seguintes comandos no Shell:

         - Test-MapiConnectivity

         - Test-OutlookWebServices

     

    Se o teste passar com sucesso é sinal que seu Exchange está bem configurado.

     

    - Ao habilitar o Outlook AnyWhere nós escolhemos qual o tipo de autenticaçao que iremos aceitar dos clientes outlook (basic ou NTLM) devemos configurar o outlook para usar o mesmo tipo de autenticacao configurada no server.

    - Caso voce escolha a opcao de basic é necessario alterarmos no IIS, no diretorio RPC as configuracoes de seguranca desmarcando o acesso anonimo e marcando basic authentication.

     

    Este recurso é bem simples e nao tem muiiiiitas opcoes de configuracoes, creio que solucionará seu problema.

     

     

     

    quarta-feira, 30 de abril de 2008 20:10
  • Ola Simental,

     

    Para ver todas informacoes tu pode usar no final docomando | fl, mas nao te baseia somente neste cmdlet para dar o servidor como okay, vc precisa aplicar os certificados e configural-los de forma correta, como também fazer o teste atraves do cliente outlook para ter certeza.

     

    Existiram alguns issues com este comando em determinados cenários, ou seja, pode utilizar mas conhecendo bem o teu ambiente para o resultado ser apropriado.

     

     

    quarta-feira, 30 de abril de 2008 20:51

Todas as Respostas

  • Ola Simental,

     

    Antes de mais nada o DNS tá rodando bem?

    E também, sem o Outlook Anywhere funcionava? Ou funciona? Se tu não habilitar o Anywhere no cliente o outlook vai na boa?

     

    Abs.

     

    terça-feira, 29 de abril de 2008 18:37
  • Salve Rodrigo, agradeço pela rápida resposta.

     

    Não utilizei outro tipo de acesso que não pelo OWA ou nas tentativas do Anywhere. Meu serviço de exchange está locado diretamente em um data center e os acessos ao servidor serão sempre via internet, sem usar vpn, por isso meu interesse em habilitar o anywhere.

     

    O micro que estou usando para o teste do outlook, esta usando um ipfixo externo, sem firewall, O dns que ele utiliza para pesquisa é o dns do servidor. Ou seja ele resolve com autoridade o dominio, ja utilizei o nslookup aqui e estou resolvendo todos os meus endereços do servidor.

    Algumas vezes ele abre a janela de autenticação, mas mesmo assim não autentica.

     

    Com relação ao acesso, o outlook consegue acesso via MAPI direto pela internet? Alguma coisa precisa ser habilitada no server pra isso? Não habilitei o pop3 nem o imap4 pois o que mais me interessa no exchange são as features de agenda compartilhada, calendario etc. e pela documentação informa que não tem suporte nestes protocolos.

     

    Estou achando que passei batido em alguma configuração.

     

    Agradecendo pela atenção, envio um forte abraço.

     

     

    terça-feira, 29 de abril de 2008 18:54
  • Ola Simental,

     

    Se todo o acesso será via internet, realmente a tua solução é anywhere ou OWA.

    No seu caso, eu arrisco dizer que a configuração do Outlook para o Anywhere é que está errada, pois para conseguir acesso MAPI via internet apenas com o Anywhere mesmo.

    Reveja tua configuração local no Outlook, pode ser isso. E também se tiver algo nos logs poste aqui que ajuda.

     

    Abs.

     

    terça-feira, 29 de abril de 2008 19:02
  • Vou verificar os logs e posto aqui.

    Com relação ao outlook, como falei eu conectei a maquina diretamente a um ip fixo, sem firewall justamente para testar a conexão direta do anywhere e nada.

    Nas configurações da conta eu habilitei a utilização do anywhere com os dados do server etc.

    Algumas vezes inclusive pediu autenticação mas não prosseguiu.

     

    Os logs do DNS estão normais sem problemas, na maquina cliente usando o nslookup ele resolve tranquilo on endereços, o certificado eu criei usando o tutorial do anderson patricio.

    Ou seja na teoria está ok, na pratica... não sei...

     

    VOu tentar garimpar os logs aqui.

    Abraço

     

    terça-feira, 29 de abril de 2008 22:41
  • Olá Simental,

     

         Como o Rodrigo já informou, eu também creio que seja problema de configuração no outlook client.

         Apenas para previnir que o processo de instalção do Exchange ocorreu com exito, que os serviços do Exchange estão funcionais e para checar os protocolos de acesso dos usuários, execute os seguintes comandos no Shell:

         - Test-MapiConnectivity

         - Test-OutlookWebServices

     

    Se o teste passar com sucesso é sinal que seu Exchange está bem configurado.

     

    - Ao habilitar o Outlook AnyWhere nós escolhemos qual o tipo de autenticaçao que iremos aceitar dos clientes outlook (basic ou NTLM) devemos configurar o outlook para usar o mesmo tipo de autenticacao configurada no server.

    - Caso voce escolha a opcao de basic é necessario alterarmos no IIS, no diretorio RPC as configuracoes de seguranca desmarcando o acesso anonimo e marcando basic authentication.

     

    Este recurso é bem simples e nao tem muiiiiitas opcoes de configuracoes, creio que solucionará seu problema.

     

     

     

    quarta-feira, 30 de abril de 2008 20:10
  • Thiago, saudações e obrigado pela resposta.

     

    Fiz os testes que indicou e realmente to com um erro na configuração,

    Como o log só tem códigos e uma descrição breve, onde posso ver a descrição destes codigos para interpretar os erros?

       

                      Id                       Type Message                 
                            --                       ---- -------                 
                          1003                Information About to test AutoDisc...
                          1007                Information Testing server insolob...
                          1019                Information Found a valid AutoDisc...
                          1018                Information The SSL certificate on...
                          1006                Information Contacted AutoDiscover...
                          1016                    Success [EXCH]-Successfully co...
                          1015                    Success [EXCH]-Successfully co...
                          1014                    Success [EXCH]-Successfully co...
                          1016                Information [EXPR]-The AS is not c...
                          1015                    Success [EXPR]-Successfully co...
                          1014                Information [EXPR]-The UM is not c...
                          1013                      Error When contacting https:...
                          1017                      Error [EXPR]-Error when cont...
                          1006                    Success Successfully tested Au...
                          1021                Information The following web serv...

    O teste do MAPI não apresentou nenhum erro.
    quarta-feira, 30 de abril de 2008 20:25
  • Ola Simental,

     

    Para ver todas informacoes tu pode usar no final docomando | fl, mas nao te baseia somente neste cmdlet para dar o servidor como okay, vc precisa aplicar os certificados e configural-los de forma correta, como também fazer o teste atraves do cliente outlook para ter certeza.

     

    Existiram alguns issues com este comando em determinados cenários, ou seja, pode utilizar mas conhecendo bem o teu ambiente para o resultado ser apropriado.

     

     

    quarta-feira, 30 de abril de 2008 20:51
  • Salve Anderson,

     

    Rodei o comando com a opção que me passou e tá indicando que não consegue resolver o meu domain name, com o Id      : 1013
    Type    : Error
    Message : When contacting https://blablabla.com.br/Rpc received the error The remo
              te name could not be resolved: 'blablabla.com.br'

     

    Fui no dns verificar e está ok.

    segue o resultado do lookup

     

    Default Server:  blablabla.com.br
    Address:  189.xx.yyy.zz

    > set q=any
    > blablabla.com.br
    Server:  blablabla.com.br
    Address:  189.xx.yyy.zz

    blablabla.com.br   internet address = 189.xx.yyy.zz

    blablabla.com.br   nameserver = hosthost.zzz.blablabla.com.br
    blablabla.com.br
            primary name server = hosthost.zzz.blablabla.com.br
            responsible mail addr = hostmaster.zzz.blablabla.com.br
            serial  = 7
            refresh = 900 (15 mins)
            retry   = 600 (10 mins)
            expire  = 86400 (1 day)
            default TTL = 3600 (1 hour)
    blablabla.com.br   MX preference = 10, mail exchanger = hosthost.zzz.blablabla.com.br
    hosthost.zzz.blablabla.com.br     internet address = 189.xx.yyy.zz

    hosthost.zzz.blablabla.com.br      internet address = 189.xx.yyy.zz

    >

    quarta-feira, 30 de abril de 2008 21:28
  •  

    Testa usando este cara: http://msmvps.com/blogs/andersonpatricio/archive/2008/04/09/validating-autodiscover-rpc-over-http-and-inbound-smtp.aspx

     

     

    Ps.: nao entendi nada deste teu blabla.zzz,xxxyyy Tongue Tied cara isto é publico, coloca a informação ai. Smile
    quarta-feira, 30 de abril de 2008 22:52
  •  

    Olá Simental, tudo bom ????

     

    Andei pesquisando sobre esse event ID e me parece ser algo relacionado ao application pool que o RPC utiliza para rodar. Eu tive um problema semelhante com o OWA depois de fazer um Microsoft Update, por acaso vc possui o FrameWork 1.1 + FrameWork 2.0 na mesma maquina ???? Isoo ocorreu depois de algum update ????

     

    De uma olhada na console do IIS, expanda application pools e veja se o application pool do RPC está habilitado (caso esteja desabilitado ele ficará com um icone vermelho)

     

    veja se há algum evento descrito no link em seu event viwer: http://support.microsoft.com/kb/821268

     

     

    poste aqui o resultado !!!

     

    abraco e boa sorte !

    quinta-feira, 1 de maio de 2008 13:27
  • Salve anderson,

     

    Apenas deixei os troquei meus domain names por fake names!!

    189.xxx.yyy.zz like 189.100.200.50 ok?

    e blablabla.com.br like microsoft.com.br!!

     

    Pequenas mudanças pra deixar o domain mais privativo.

     

    Agradeço pelas dicas e vou tentar amanha, pois hoje quero descansar um pouco, afinal é o dia do trabalho... e é para descansar... (lógica incompreensível à dos politicos, mas...)

     

    Um forte abraço!!

    quinta-feira, 1 de maio de 2008 19:37
  • Salve anderson

     

    Fiz o teste do link que me passou e acusou problema no certificado.

    Para criar o certificado usei o selfSSL conforme um de seus tutoriais.

    Tem alguma idéia do que pode ser?

     

    sexta-feira, 2 de maio de 2008 17:09
  •  

    Ola Simental,

     

    para os clientes nao terem erro nenhum, tu precisa comprar certificados com selfssl sempre tereas este erro, pq o mesmo nao pode ser validado.

     

     

    sexta-feira, 2 de maio de 2008 17:13
  • Salve Anderson,

     

    Sim, sei disto, mas não aparece nenhuma mensagem pedindo pra aceitar o certificado, apenas retorna erro nele.

    O procedimento é mesmo esse (pra usar um certificado de testes), criar no self ssl e só?

    Ou tem mais algum passo que deixei de fazer?

    sexta-feira, 2 de maio de 2008 17:17
  •  

    Ola Simental,

     

    teus testes nao funcionarão desta maneira, certificado selfssl no 2003 até ia para o website, mas para o exchange 2007 é melhor usar PKI do que selfssl.

     

    sexta-feira, 2 de maio de 2008 17:20
  • Thiago, saudações

     

    QUando instalei o EXC2007 ela ja estava up-to-date.

    Tinha instalado todos os upgrades disponiveis

    Depois de instalar o EXC fiz outro update até não ter mais nada

    Só a partir dai iniciei a configuração da maquina.

     

    Será que é necessário registrar o framework 2.0 novamente??

     

    Se tiver alguma idéia, sou todo ouvidos

    Obrigado!

    sexta-feira, 2 de maio de 2008 17:21
  • Ok, entendo...

    Bom agora vem a pergunta, como fazer isso?

    Vc tem algum tutorial a respeito?

     

    sexta-feira, 2 de maio de 2008 17:26
  •  

    Ola Simental,

     

    se tiveres problema no owa, pod eestar registrando mas tem que ver o erro que está dando.

     

    La no site tem como criar para uma PKI, de uma olhada ou aqui no histórico que temos o link.

     

     

    sexta-feira, 2 de maio de 2008 18:08
  •  

    Senhores,

     

    Creio que consegui fazer funcionar o exchange via anywhere.

    Bom, realmente como o Rodrigo falou, era configuração do cliente, mas por um lapso (burrice mesmo) eu esqueci de configurar o autodiscover.

    Queria agradecer ao pessoal que postou aqui pelo tempo dispensado e espero um dia poder ajudar a todos também. Creio que após muito estudo e alguma experiência poderei ajudar outros, pois os mestres estarão num nível muito maior.

     

    Mais uma vez envio um grande abraço a todos.

    sexta-feira, 2 de maio de 2008 18:50
  •  Ola Simental,

     

    Que bom que resolveu e ficamos felizes em tê-lo ajudado.

    Apenas para manter o fórum organizado marque os posts que foram úteis para você ok.

     

    Abs.

     

    sexta-feira, 2 de maio de 2008 19:10
  • Thiago, analisei melhor seu post e estou com duas duvidas:

    1)Meu RPC está em default app pool.

    2) Está dando erro no domain support.microsoft.com, nao consigo acessar o kb

    Eu estou com o o framework 1.1 e 2.0 no meu server sim.

    sábado, 10 de maio de 2008 17:23
  • Olá Simental, blz ?

     

     

         Na verdade eu tive um problema semelhante com o app pool do OWA depois de ter aplicado algumas atualizacoes do Microsoft Update ... Fui pesquisar e descobri que um dos motivos era a coexistencia dos Frameworks 1.1 e 2.0, além de ter que forcar o IIS a usar o .Net Framework 2.0 64 bits editando um parametro no metabase do IIS ....

     

    Seu app pool default está funcional ou está parado ??? No meu caso ele ficava parado ... Vc ainda tem problemas com seu Anywhere ??? Se os sintomas forem semelhantes eu posso te dar mais detalhes do procedimento de troubleshoot completo ...

    sábado, 10 de maio de 2008 18:44
  • Thiago, saudações

     

    Bom, estou com os dois frameworks mesmo, então preciso ver como mudar esse parâmetro.

    No caso em questão, fui revisar o RPC e ele não estava setado para pool algum e meu owa agora está retornando erro que nao consegue localizar o DC.

    Se puder me passar os passo que utilizou para resolver isto.

    Eu criei uma pKI para testar o funcionamento, e inclui ela via exchange, tudo ok pelo resultado dos comandos.

     

    Estou tento o erro a seguir no OWA, peguei pelo event viewer

    Event Type: Error
    Event Source: MSExchange OWA
    Event Category: ADNotifications
    Event ID: 64
    Date:  10/5/2008
    Time:  16:02:45
    User:  N/A
    Computer: MAQUINA

    Description: Failed to read and update the Outlook Web Access configuration settings. Virtual directory: "owa". Web site: "DOMAIN.com.br".
    Error message: "Failed to access the Active Directory configuration settings for virtual directory "owa" under web site "DOMAIN.com.br"."

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Cliquei no link, mas retornou erro de pagina...

    Pode ser resultado do certificado que criei??
    sábado, 10 de maio de 2008 19:26
  • usa este cara aqui para asp.net se for o mesmo erro http://support.microsoft.com/kb/894435

    sábado, 10 de maio de 2008 23:21
  • Olá Simental,

     

     

        Segui o seguinte procedimento para solucionar meu problema:

     

    - Removi o .Net 1.1

    - Reiniciei a maquina

    - Na console do IIS permitir que o o Matebase seja editado, indo nas propriedades do servidor.

    - Abrir o Arquivo metabase.xml (c:\windows\system32\inetsrv\metabase.xml) com um editor de texto - notepad -

    - Localizar a seguinte linha de comando:

     


      FilterDescription="ASP.NET Cookieless Session Filter"
      FilterEnableCache="TRUE"
      FilterFlags="0"
      FilterPath="C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_filter.dll"
      FilterState="4"

     

    e editar para


      FilterDescription="ASP.NET Cookieless Session Filter"
      FilterEnableCache="TRUE"
      FilterFlags="0"
      FilterPath="C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\aspnet_filter.dll"
      FilterState="4"

     

     

    Note que basta adicionarmos o 64 (vermelho) após o framework ....

     

     

     

     

     

    ___________________________

     

    Lembrando que .... Faca um backup do seu metabase antes de executar essa acao .... qualquer problema vc consegue voltar no estado anterior facilmente.

     

    Para executar o backup vá console do IIS, nas propriedades do servidor, all tasks, backup/restore ....

    segunda-feira, 12 de maio de 2008 14:20