locked
Serviço WINS não inicia RRS feed

  • Pergunta

  • Estou com um problema no meu SBS2003. Sempre que tento iniciar o Serviço WINS recebo o seguinte erro:

     

    Tipo de evento: Erro
    Fonte de evento: Wins
    Categoria do evento: Nenhuma
    Id. do evento: 4193
    Descrição: O WINS não pôde criar o soquete de notificação. Certifique-se de que o driver TCP/IP está  instalado e sendo executado corretamente.

     

    Não encontrei nada na Internet que indique este tipo de erro, apenas uma referência na página abaixo que fala na falta do arquivo Services na pasta system32\Drivers. Nesta pasta realmente não tem este arquivo, mas este artigo faz referência ao Windows NT Server (KB153740)

    http://support.microsoft.com/kb/153740/en-us

     

    Alguém pode me ajudar.

     

    Grato ...

    sexta-feira, 28 de março de 2008 02:19

Respostas

  • Marcos,

     

    antes de reinstalar qualquer serviço, tente corrigi-lo, pois a reinstalação deve ser sempre o último recurso, uma vez que alterando arquivos compartilhados por outros serviços ela pode gerar problemas neles, aumentando as tuas dores de cabeça ao invés de reduzí-las.

     

    Inicialmente faça o seguinte:

    • Iniciar -> Executar -> Regedit;
    • Vá até a chave: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters;
    • Verifique o tipo de item para DataBasePath. Ele deve ser: REG_EXPAND_SZ. Se for algo diferente exclua e recrie ele;
    • O valor padrão para ele deve ser: %SystemRoot%\System32\drivers\etc. Novamente, se for algo diferente, altere.

     

    Depois vá até a pasta: system32\drivers\etc e verifique ono arquivo services se os seguintes registros existem:

    nameserver               42/tcp    name                   #Host Name Server
    nameserver               42/udp    name                   #Host Name Server

     

    Mais informações em: http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Windows%20Operating%20System&ProdVer=5.2&EvtID=4193&EvtSrc=Wins&LCID=1033

     

    http://support.microsoft.com/default.aspx?scid=kb;en-us;153740

     

    sexta-feira, 28 de março de 2008 17:35

Todas as Respostas

  •  Olá Marcos,

     

    Acho que antes de mais nada, vc deveria tentar reinstalar o serviço de WINS no seu servidor, e tente novamente.

     

    Mas caso não funcione mesmo assim esses links abaixo podem te dar uma luz (essa página abrirá uma outra página com mais 3 link relatando sobre o assunto)

     

    http://www.microsoft.com/technet/support/ee/SearchResults.aspx?Type=0&Message=4193

     

    Espero ter ajudado

     

    Caso sejá útil não esqueça de marcar

     

    Um abraço

    sexta-feira, 28 de março de 2008 11:52
  • Marcos,

     

    antes de reinstalar qualquer serviço, tente corrigi-lo, pois a reinstalação deve ser sempre o último recurso, uma vez que alterando arquivos compartilhados por outros serviços ela pode gerar problemas neles, aumentando as tuas dores de cabeça ao invés de reduzí-las.

     

    Inicialmente faça o seguinte:

    • Iniciar -> Executar -> Regedit;
    • Vá até a chave: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters;
    • Verifique o tipo de item para DataBasePath. Ele deve ser: REG_EXPAND_SZ. Se for algo diferente exclua e recrie ele;
    • O valor padrão para ele deve ser: %SystemRoot%\System32\drivers\etc. Novamente, se for algo diferente, altere.

     

    Depois vá até a pasta: system32\drivers\etc e verifique ono arquivo services se os seguintes registros existem:

    nameserver               42/tcp    name                   #Host Name Server
    nameserver               42/udp    name                   #Host Name Server

     

    Mais informações em: http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Windows%20Operating%20System&ProdVer=5.2&EvtID=4193&EvtSrc=Wins&LCID=1033

     

    http://support.microsoft.com/default.aspx?scid=kb;en-us;153740

     

    sexta-feira, 28 de março de 2008 17:35
  • Carlos,

     

    muito obrigado pela sua dica. O problema foi resolvido. Realmente no arquivo services não tinha os registros citados. Coloquei e reiniciei o serviço WINS e agora está funcionando normalmente.

     

    Tipo de evento: Informações
    Fonte de evento: Wins
    Categoria do evento: Nenhuma
    Id. do evento: 4097
    Descrição: O WINS foi inicializado corretamente e está totalmente operacional.

     

    Abraços,

     

    Marcos Alvim

    Cimcorp Informática

    sexta-feira, 28 de março de 2008 23:28