none
Contagem com laço Repetição RRS feed

  • Pergunta

  • Bom dia!

    Problema pendente devido não encontrar a solução.

    Na célula a1 tenho a fórmula =hoje()

    Na célula  b1 tenho a data    21/09/2014

    Na célula c1 tenho a fórmula  =a1-b1  o resultado é 11 uma variável e vai aumentando a quantidade de dias.

    O grande problema é colocar um laço repetitivo, fazer com que esta variável  limite  a  cada 10 dias renove  a contagem.

    Não é interessante a contagem sucessivamente.

    Ou seja contou 10 dias apresentar o número 10.

    Iniciando o décimo primeiro dia  voltar o número, apresenta o número 1 e  conta mais uma sequência de 10 dias, e assim sucessivamente. 

    A solução pode ser em vba.

    Grato, Geneci.

    quinta-feira, 2 de outubro de 2014 13:30

Respostas

  • Olá Geneci!

    Pensei numa fórmula mais simples para sua necessidade:

    =(B1-A1)-INT((B1-A1)/8)*8+1

    Se quiser mudar a quantidade de dias é só substituir os dois números 8 da fórmula. E essa fórmula inicia a contagem a partir da data inicial igual a 1, ou seja, se as datas em A1 e B1 são iguais o resultado é 1.

    Espero que te atenda e não esqueça de marcar como resposta os posts que te ajudaram.

    Abraços!


    Rafael Kamimura

    • Marcado como Resposta GENECIOFICIAL segunda-feira, 6 de outubro de 2014 22:01
    segunda-feira, 6 de outubro de 2014 11:55

Todas as Respostas

  • Experimente a fórmula:

    =SE(A1=B1;0;SE(VALOR(DIREITA(B1-A1;1))=0;10;VALOR(DIREITA(B1-A1))))


    Rafael Kamimura

    • Sugerido como Resposta Rafael Kamimura sexta-feira, 3 de outubro de 2014 13:53
    sexta-feira, 3 de outubro de 2014 13:53
  • Boa Tarde!

    Com a fórmula complexa elaborada e apresentada.

    Finalmente o problema foi solucionado.

    Mil vezes obrigado.

    Agradecido - Geneci 

    sexta-feira, 3 de outubro de 2014 20:42
  • Bom dia!  Rafael Kamimura

    Mais uma vez, obrigado pela fórmula complexa que desenvolveu.

    =SE(A1=B1;0;SE(VALOR(DIREITA(B1-A1;1))=0;10;VALOR(DIREITA(B1-A1))))

    Havendo necessidade de alterar o número  de 10 dias,

    para o número 8 dias no contador automático.

    Como vai ficar a fórmula?

    Por favor? Pode descrever passo a passo da fórmula?

    Muito obrigado,

    Geneci.

    domingo, 5 de outubro de 2014 22:33
  • Olá Geneci!

    Pensei numa fórmula mais simples para sua necessidade:

    =(B1-A1)-INT((B1-A1)/8)*8+1

    Se quiser mudar a quantidade de dias é só substituir os dois números 8 da fórmula. E essa fórmula inicia a contagem a partir da data inicial igual a 1, ou seja, se as datas em A1 e B1 são iguais o resultado é 1.

    Espero que te atenda e não esqueça de marcar como resposta os posts que te ajudaram.

    Abraços!


    Rafael Kamimura

    • Marcado como Resposta GENECIOFICIAL segunda-feira, 6 de outubro de 2014 22:01
    segunda-feira, 6 de outubro de 2014 11:55
  • Boa Noite!

    Rafael Kamimura.

    Atendeu e resolveu o meu problema em definitivo.

    Digno de agradecimentos mútuos.

    segunda-feira, 6 de outubro de 2014 22:07