none
Degree Parallelism no Resource Governor RRS feed

  • Pergunta

  • Eu tenho uma query que roda em 3 segundos quando executada com o hint OPTION (MAXDOP 1), porém a mesma query é executada em 20 segundos quando executada sem este hint mas com o resource governor enable e o degree parallelism configurado to 1 no workload group deste usuário. O maxdop do resource governor não trabalha da mesma forma que o hint maxdop?

    SQL 2008 R2 Enterprise
    Windows 2008 R2 Standard x64
    quarta-feira, 22 de setembro de 2010 13:37

Respostas

  • Sim. De acordo com a documentação do Books Online, o Resource Governor sobrepõe os valores do sp_configure e OPTION(MAXDOP). Você poderia confirmar se o Workload e a função Classifier foram definidos corretamente?

    Abraços,
    Fabricio

    quarta-feira, 29 de setembro de 2010 00:44

Todas as Respostas

  • Rafael,

    Quando utilizamos o Resource Governor, estamos habilitando o gerenciamento e limitando o uso dos nossos recursos para atender a demanda de processamento simultâneos, desta forma, existe diversas em o Table Hint MaxDOP e o MAXDop do Resource Governor.

     


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário]
    quarta-feira, 22 de setembro de 2010 16:58
    Moderador
  • Junior,

    Se eu altero o max degree parallelism no sp_configure, minha query roda em 3 segundos, porém se eu faço esta alteração somente no nível do resource governor, minha query vai para quase 1 minuto (quando executada por usuário deste workload group).

    O parametro Degree of Parallelism do Workload Group não deveria ter o mesmo resultado do max degree parallelism do sp_configure?

    quarta-feira, 22 de setembro de 2010 17:31
  • Sim. De acordo com a documentação do Books Online, o Resource Governor sobrepõe os valores do sp_configure e OPTION(MAXDOP). Você poderia confirmar se o Workload e a função Classifier foram definidos corretamente?

    Abraços,
    Fabricio

    quarta-feira, 29 de setembro de 2010 00:44